Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 3 of 3
  1. #1
    New to the CF scene
    Join Date
    Apr 2014
    Posts
    2
    Thanks
    1
    Thanked 0 Times in 0 Posts

    I Need a bit of an explination

    Hello all. I took web programming in school and ive since graduated (go me) I did an assignment a few years back and everything worked. However I decided that I wanted to brush up on my xml and for some reason it is not working anymore. I dont know what the problem is. I posted it to the net so that anyone who can help me can view it.

    Central High Class of 1959

    The problem is that the next buttons dont work... thing is... when I gave it to the professor it did work.... I dont know what changed. please help... thank you...

  • #2
    The fat guy next door VIPStephan's Avatar
    Join Date
    Jan 2006
    Location
    Halle (Saale), Germany
    Posts
    8,915
    Thanks
    6
    Thanked 1,040 Times in 1,013 Posts
    Quote Originally Posted by ruckus09 View Post
    I dont know what changed.
    The world changed — while your code stayed the same.

    In the source code it says “Date: 10/22/2013” but that code looks more like it is from 1995 mixed with some contemporary HTML 5. In any case, this page is parsed in quirks mode, meaning that browsers interpret that as random “tag soup” and try to figure out what to do with it, and they differ in their attempts at doing so.

    Anyway, besides this flaw the buttons execute some JavaScript on the click event but the JS doesn’t know at all what it’s supposed to do. For example, the “back” button is supposed to execute studInfo.recordset.movePrevious(); but there is nothing in your file that tells the browser what “studInfo” is, or “recordset”, or “movePrevious”, for that matter. The only thing I can imagine is that you have changed the code afterwards and removed some JavaScript function or something like that. But it would surprise me if it would work even with the JS as this is really bad HTML.

  • Users who have thanked VIPStephan for this post:

    ruckus09 (04-30-2014)

  • #3
    New to the CF scene
    Join Date
    Apr 2014
    Posts
    2
    Thanks
    1
    Thanked 0 Times in 0 Posts
    mmmm... Ive been searching online and apparently this guy has the same problem I guess?
    Freezing Point Refrigerators
    I saw an assignment online that I am working on...
    and I want to use the onclick to move from one image to another with xml. do you know any tutorials that I can check out that help me out?
    but I want to do it properly... as you said I did it badly the first time lol thanks for your help.


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •