Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 4 of 4
  1. #1
    New Coder
    Join Date
    Dec 2002
    Location
    New York State
    Posts
    18
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Blank date export to excel fills cell with # symbols

    Hello:

    I'm running an xslt page that exports filemaker data to excel. I have setup a column as a datetype datatype. When I export the data, some rows have blank datetime values. The result is that excel fills the cell with "#" symbols rather than leaving it blank. Is there a workaround for this?

    Elsewise, I can use a datatype of string for the dates, which works fine with the empty values, but when I attempt to reformat the dates, it does not affect the cells until you click in and out of them.

    Any ideas??

    Thanks

  • #2
    Master Coder
    Join Date
    Dec 2007
    Posts
    6,682
    Thanks
    436
    Thanked 890 Times in 879 Posts
    Quote Originally Posted by dulatoag View Post
    Hello:

    I'm running an xslt page that exports filemaker data to excel. I have setup a column as a datetype datatype. When I export the data, some rows have blank datetime values. The result is that excel fills the cell with "#" symbols rather than leaving it blank. Is there a workaround for this?

    Elsewise, I can use a datatype of string for the dates, which works fine with the empty values, but when I attempt to reformat the dates, it does not affect the cells until you click in and out of them.

    Any ideas??

    Thanks
    xml or xslt could be invalid if that is happend. If xml is the problem the best thing is to validate before use it. In case the xslt is the problem solution is simple you just need to fix it.

    best regards

  • #3
    New Coder
    Join Date
    Dec 2002
    Location
    New York State
    Posts
    18
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thanks for the reply. I can test in the xslt whether the value of the data field is blank, but it seems that since the datatype is set to datetime, excel converts a null value to something not null. That make sense? I'm a total novice at xslt btw ... this is just something I have to get done in order to proceed in the project. I just want to pass along an empty value, but it seems excel does not support an empty datetime.

  • #4
    Master Coder
    Join Date
    Dec 2007
    Posts
    6,682
    Thanks
    436
    Thanked 890 Times in 879 Posts
    Quote Originally Posted by dulatoag View Post
    Thanks for the reply. I can test in the xslt whether the value of the data field is blank, but it seems that since the datatype is set to datetime, excel converts a null value to something not null. That make sense? I'm a total novice at xslt btw ... this is just something I have to get done in order to proceed in the project. I just want to pass along an empty value, but it seems excel does not support an empty datetime.
    I'm not sure, I work with excel long time ago, but I guess that the fields is '1 ian 1979' or something like that. Probably the best way is to test if in xml have a null value and insert something like N/A in excel or change cell format.

    Edit: in both cases, N/A and reformat cell, I have no idea what you must generate with xslt

    best regards
    Last edited by oesxyl; 09-30-2008 at 05:18 AM.


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •