Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 15 of 15

Thread: Site Review !!!

  1. #1
    Regular Coder
    Join Date
    Aug 2002
    Location
    UK
    Posts
    324
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Site Review !!!

    Hi everyone,

    Well here it is. The first site I have built, which I would like reviewing by you guys. Please give me your honest opinions about it. I would like to hear any comments, even if there just spelling errors !!!

    Points to bear in mind though:

    1. I have only tested the site in Internet Explorer 5.5. So I have no idea what it looks like in netscape or any others. Please let me know of any errors, I would like to get it working just the same if I can.

    2. There are one or two pages still under construction.

    3. The feedback forms are not connected with the cgi script yet, but please check the validation routine on them.

    Anyway just let me know what you think

    Thanks in advance.

    P.S. can you tell me what platform and browser your using so I have an idea on where it works ok
    Last edited by wap3; 12-07-2002 at 03:27 PM.

  • #2
    Regular Coder
    Join Date
    Jun 2002
    Location
    Depends on the time of year
    Posts
    478
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Love the site, simple, to the point.

    Here are some suggestions:

    On the front page, instead of having blank boxes, have like one word so ppl can recognize more what they represent, it may look nice right now, but its not really functional, esp. for a commercial site.

    For the tables of the products, create header rows, telling us what each column represents, I might not know anything about the industry, but I'd like to know what you're talking about.

    Liked the Vat System. Maybe instead of just clicking on the "=" button, we can click anywhere outside the textfield and it comes up, click on the "=" button is just an option then, that way we don't have to keep aiming - it is a small button after all..

    As for the index, liked the scollbars and how you mention it. Possibly, you can create a function that if you have reached the bottom of the page (or top), the scroll arrow gets "blurred" or similar. Not familiar on making scroll functions, so don't know if that's been implemented.

    Those are just the improvements, no comments on how good your site is yet, so I'll just break it down to, REAL NICE!!

    Duniyadnd

  • #3
    Regular Coder
    Join Date
    Aug 2002
    Location
    UK
    Posts
    324
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hi duniyadnd

    Thanks for the pointers, very much appreciated and some good ideas to help me improve it.

    When you say tables of products would it be helpful if there was a button, like a help icon, which you could click to get a description of what exactly the column headings (8 hrs, 24 hrs etc) mean ??

    About the az-index were you able to figure out when the content could be scrolled down ?? Would it be an idea to have text at the bottom saying 'scroll down for more' when it is necessary ??

    As for changing the button when the bottom is reached. I will see if I can work it so it greys out or something.

    Can I ask you what browser, platform and screen resolution your using to please ??

    Thanks ever so much
    Last edited by wap3; 08-29-2002 at 02:48 PM.

  • #4
    Regular Coder
    Join Date
    Aug 2002
    Location
    UK
    Posts
    324
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Oh by the way I would appreciate some more reviews, if any of you guys have the time !!

    The more reviews I get the better

    Thanks

    P.S Thanks to all the people from here who have helped me in building this site. In case you're wandering this is the former 'waps' now 'waps3'. I had problems logging on so I changed my name. Anyway you may remember me now.

  • #5
    Regular Coder
    Join Date
    Jun 2002
    Location
    Depends on the time of year
    Posts
    478
    Thanks
    0
    Thanked 0 Times in 0 Posts
    To answer your questions:

    1. IE 5.5, 1024x...; Win 98

    2. If the headers are going to have explanations, include popups, but I'd include both, one as a key word, the popups for explanations

    3. As for the text for telling you to scroll up/down, its up to you, if you are also doing the blur button, then you can include both, or just one of them, the final choice is up to you.

    4. Yeah, it was easy to figure out the scroll feature, you very prominently mentioned it on top.

    5. Btw, what do those icons represent on the left side? Are those the recommended safety equipment you have to get before you use the following products? (Safety goggles, gloves etc.)

    Hope that helps, if you got anymore questions, let me know. Welcome back Waps/Wap3.

    Duniyadnd

  • #6
    Regular Coder
    Join Date
    Aug 2002
    Location
    UK
    Posts
    324
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hey

    "waps/wap3"

    Yer those icons are recommended safety items. Funny you should say that cause Im just putting together a little icon, which explains them.

    Chow


  • #7
    Regular Coder
    Join Date
    Jul 2002
    Posts
    124
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Ahhh, I remember chugging down the A roads from London to west country caravans for my summer holidays as a lad...

    Hi. Gooood site. I'm on a mac, 1024x768, IE5. Just thought I'd add a few comments:

    I was looking for a 'home' button. Using the logo is a novel idea, but it isn't obvious.

    The words in the menu across the top are not evenly spaced (screenshot attached).

    I agree about needing text in the boxes on the top page. And when the cursor changed I was expecting a link. Then again, if you put text in a box it may appear even more of a broken link...

    This is being extremely picky, but...the right hand pic on the top page with the guy attempting suicide from the top has a blue background which doesn't match the page background. I only mention it because the others are all perfect.

    The VAT part doesn't work (btw it's only 5% here in Japan...). I get a grey box drop down but nothing in it. And more importantly, those pages keep crashing my browser (VERY unusual). Got some anti-mac code in there?!? Could be coincidence.

    On the pages with a white background with the curved top, the blue title looks a bit pallid on my screen. Also on those pages I can hardly read the time periods under the Hire Rates (screen shot attached).

    Hope that helps. If you want more from this end of a mac, just ask.

  • #8
    Regular Coder
    Join Date
    Jul 2002
    Posts
    124
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Well there should be screenshots. Know how I can attach them? I used the browse button below but when I submitted nothing has shown up.

  • #9
    Regular Coder
    Join Date
    Aug 2002
    Location
    UK
    Posts
    324
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hi

    Chesneil

    With regards to the vat calculator. Can you revisit those pages if possible to see if it still crashes. One of the boxes which you should see is disabled ? Could that be it.

    Here is the code im using, does anyone see a problem. I do not know if there are differences between a mac and pc, so if anyone could help who does ??

    I see my site brought back some memories of devon

    Could some people with netscape please take a look. I have not tested it all with netscape so would appreaciate it if you could look.

    Attached Files Attached Files

  • #10
    Regular Coder
    Join Date
    Jul 2002
    Posts
    124
    Thanks
    0
    Thanked 0 Times in 0 Posts
    It's still giving me problems. A couple of times I had to restert my computer before I could use IE again. I'd get another Mac to test it, though (maybe start another thread 'brave Mac users wanted')

    I tried your site out on Mac Netscape 6.2.2 and Windows Netscape 6.2. Both render it exactly the same as far as I could see. The VAT doesn't work on either, and you lose some formatting...but it's perfectly readable so I wouldn't worry too much about it since I suspect it's a lot of xbrowser coding to do (depends how much they're paying you...)

    A couple of screen shots below from Netscape showing the formatting problems, plus the two from IE I tried to attach above.

    www.v-gr.com/temp/mac_ie5no1.jpg
    www.v-gr.com/temp/mac_ie5no2.jpg
    www.v-gr.com/temp/mac_netscape6_2_2no1.jpg
    www.v-gr.com/temp/mac_netscape6_2_2no2.jpg

  • #11
    Senior Coder joh6nn's Avatar
    Join Date
    Jun 2002
    Location
    72° W. 48' 57" , 41° N. 32' 04"
    Posts
    1,887
    Thanks
    0
    Thanked 1 Time in 1 Post
    pc mozilla 1.1, the screen is pretty much blank. i have your navigation at the top, and that's it.
    bluemood | devedge | devmo | MS Dev Library | WebMonkey | the Guide

    i am a loser geek, crazy with an evil streak,
    yes i do believe there is a violent thing inside of me.

  • #12
    Regular Coder
    Join Date
    Aug 2002
    Location
    UK
    Posts
    324
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Ok thanks guys

    Looks like a need to do a bit of work in netscape. Once I got all these improvements done I will be back for another review. In the meantime feel free to post any more.

    Thanks for those screenshots chesneil very helpful.

    Well chow for now

  • #13
    New Coder
    Join Date
    Jun 2002
    Posts
    80
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I'd recommend going to the W3C. You don't have a <!DOCTYPE>

    Also, CSS will help out in making sure your text appears OK in browsers that don't support backgrounds. I had white text on a blue background and a browser displayed white text on a white background (making it appear that nothing is there). Now I have the info in a style sheet and on older browsers, it appears back on a white background (degrades well).

    You have a ton of "<font face="Verdana, Arial, Helvetica, sans-serif">'s in there. I'd recommend using a BASEFONT tag.

    On the "Contact Details" page, your email links are the same as the text. Someone might not click on it (might not be a problem).

    Besides this,

  • #14
    Regular Coder
    Join Date
    Aug 2002
    Location
    UK
    Posts
    324
    Thanks
    0
    Thanked 0 Times in 0 Posts
    OK,

    I have played around with it now and I have got it looking ok in netscape 6.2. Can someone please take a look and see if it appears ok to them.

    Two problems though with netscape:

    1. The first is when you mouseover the menus the white seperation lines dissapear, they come back when the menu is closed and opened again. Does anyone know why this is happening ??

    2. I can't get the vat function working, it won't display the first input field, anyone know why again ??


    Thanks

  • #15
    Regular Coder
    Join Date
    Jun 2002
    Location
    United Kingdom Confused: Often
    Posts
    859
    Thanks
    0
    Thanked 0 Times in 0 Posts
    at this point in development its alot to ask... but... it'd be nice if it fitted on my 800*600...

    Other than that... I like it.
    redhead


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •