Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Page 1 of 2 12 LastLast
Results 1 to 15 of 16
  1. #1
    Senior Coder crmpicco's Avatar
    Join Date
    Jan 2005
    Location
    Mauchline, Scotland
    Posts
    1,097
    Thanks
    15
    Thanked 1 Time in 1 Post

    Cool AyrshireMinis.com - Suggestions/Comments

    Hi All,

    I have set my site - www.ayrshireminis.com - live for about a fortnight now. It is written in PHP with a MySQL Database.

    I would really appreciate it if some of you guys could take a look at it and let me know what you think of it, if you find any errors then let me know. Or if you notice something that isn't there that should be let me know.

    Would really appreciate it if some of you registered for the forum and posted up a quick message :-)

    Cheers Again!
    Picco

    www.ayrshireminis.com

  • #2
    Regular Coder
    Join Date
    Jul 2007
    Posts
    571
    Thanks
    25
    Thanked 28 Times in 28 Posts
    -You use tables for layout - not good...
    -The design is not very exciting, you need some more of that web2.0 feel
    -shout boxes are so out...
    -I have a 21inch monitor and your site does not look to great on it. For example your main text area stretches out into 1 very long line of text.

  • #3
    Senior Coder twodayslate's Avatar
    Join Date
    Mar 2007
    Location
    VA
    Posts
    1,042
    Thanks
    67
    Thanked 39 Times in 39 Posts
    Quote Originally Posted by srule_ View Post
    -You use tables for layout - not good...
    -The design is not very exciting, you need some more of that web2.0 feel
    -shout boxes are so out...
    -I have a 21inch monitor and your site does not look to great on it. For example your main text area stretches out into 1 very long line of text.
    same here

    layout is very dull. I like how you have an option for languages, however ditch the drop down box.
    twitter | Quality Hosting - $5.95/mo*
    Feel free to PM me!

  • #4
    The Apostate Apostropartheid's Avatar
    Join Date
    Oct 2007
    Posts
    3,215
    Thanks
    16
    Thanked 265 Times in 263 Posts
    The HTML 4.0 standard is deprecated. Try using HTML 4.01 or switching to XHTML.

  • #5
    Senior Coder crmpicco's Avatar
    Join Date
    Jan 2005
    Location
    Mauchline, Scotland
    Posts
    1,097
    Thanks
    15
    Thanked 1 Time in 1 Post
    Thanks, yes I am going to switch over to HTML 4.01.

    Thanks for those comments, have been looking into moving to "Web 2.0" with this site. It is definately something I wish to do. Drop-down box not likely to be used do you think?

    Picco

  • #6
    Regular Coder
    Join Date
    Jul 2007
    Posts
    571
    Thanks
    25
    Thanked 28 Times in 28 Posts
    well, you have the flags to switch languages and the drop down box. You do not need both, so drop one of them

  • #7
    The Apostate Apostropartheid's Avatar
    Join Date
    Oct 2007
    Posts
    3,215
    Thanks
    16
    Thanked 265 Times in 263 Posts
    Huh.

    Your URL for German is http://www.ayrshireminis.com/mini/de/index.php?lang=DE.

    But your one for English is http://www.ayrshireminis.com/mini/index.php?lang=en.

    If you're generating the pages dynamically, what's the point in the /mini/de/ folder?

  • #8
    Senior Coder crmpicco's Avatar
    Join Date
    Jan 2005
    Location
    Mauchline, Scotland
    Posts
    1,097
    Thanks
    15
    Thanked 1 Time in 1 Post
    No, the pages aren't generated dynamically. After doing a bit of research it seems the best way to do this was to have two directories for the different languages:

    /en for English and /de for German

    Picco

  • #9
    The Apostate Apostropartheid's Avatar
    Join Date
    Oct 2007
    Posts
    3,215
    Thanks
    16
    Thanked 265 Times in 263 Posts
    That's my point.

    Why put "/index?lang=DE" if you're not generating at all? What's wrong with "/"? Why is there no /en/ directory?

  • #10
    Senior Coder crmpicco's Avatar
    Join Date
    Jan 2005
    Location
    Mauchline, Scotland
    Posts
    1,097
    Thanks
    15
    Thanked 1 Time in 1 Post
    hi CyanLight, i've taken your recommendation and moved to HTML 4.01 and it all validates:

    http://www.ayrshireminis.com/

    Da, Picco

  • #11
    Supreme Master coder! _Aerospace_Eng_'s Avatar
    Join Date
    Dec 2004
    Location
    In a place far, far away...
    Posts
    19,291
    Thanks
    2
    Thanked 1,043 Times in 1,019 Posts
    In agreement with the others except why do you use javascript for the color change on your navigation? It can be done in CSS and links.

    You should read the link in my sig titled "Why Tables for Layout is Stupid".
    ||||If you are getting paid to do a job, don't ask for help on it!||||

  • #12
    Banned
    Join Date
    Dec 2007
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    try checking the code again... link is not opening here at my place...

  • #13
    Senior Coder crmpicco's Avatar
    Join Date
    Jan 2005
    Location
    Mauchline, Scotland
    Posts
    1,097
    Thanks
    15
    Thanked 1 Time in 1 Post
    After a few changes over the past few months (when I had the chance and time) I've changed the layout and general look and feel of the site. I still have a few CSS issues to sort out, and change the German version of the site to the new design - but, I would appreciate any comments on the site as it stands now:

    http://www.ayrshireminis.com/

    Obrigado,
    Picco

  • #14
    UE Antagonizer Fumigator's Avatar
    Join Date
    Dec 2005
    Location
    Utah, USA, Northwestern hemisphere, Earth, Solar System, Milky Way Galaxy, Alpha Quadrant
    Posts
    7,691
    Thanks
    42
    Thanked 637 Times in 625 Posts
    I can't see the text of the link when I mouseover it.. it's a grey color that is swallowed in the green color. (Firefox 2.0.0.6)

    The thumbnail images in the gallery really should be separate thumbnail-sized images, rather than the normal-sized image forced into a thumbnail size by way of the width and height attributes of the <img> tag. They will look much better and the page will load quickly.

    The newsletter signup thingie tells me I've entered an invalid email address even when I've entered a valid email address. Also, there should be some mention there that to sign up for the newsletter, enter your email address.

    Other than that... attractive colors, pleasant to look at. You aught to get away from using tables for layout though.

  • #15
    Senior Coder gnomeontherun's Avatar
    Join Date
    Sep 2007
    Location
    Houston
    Posts
    2,846
    Thanks
    10
    Thanked 238 Times in 229 Posts
    Here are a few things I noticed while browsing:

    Your link rollover color is hard to read.

    The logo doesn't appear on the forums?

    You should resize the images you use as the thumbnails in the gallery, that way it doesn't take forever to load the thumbs, which you are actually just using the fullsized image scaled down. So it still has to load .5 MB per image just to see the thumb! It wasn't all of them, but people need fast loading pages.

    Es gibt eine Fehler mit den detuschen Seiten. (Ich muss meine Deutsch probieren!)
    Last edited by gnomeontherun; 03-16-2008 at 07:45 PM.
    jeremy - gnomeontherun
    Educated questions often get educated answers, and simple questions often get simple answers.


  •  
    Page 1 of 2 12 LastLast

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •