Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Page 45 of 85 FirstFirst ... 35434445464755 ... LastLast
Results 661 to 675 of 1275
Like Tree8Likes

Thread: YouTube-to-MP3 conversion - PHP class and script

  1. #661
    Senior Coder chump2877's Avatar
    Join Date
    Dec 2004
    Location
    the U.S. of freakin' A.
    Posts
    2,830
    Thanks
    21
    Thanked 157 Times in 148 Posts
    Quote Originally Posted by ivink3aray View Post
    Yes install on my server.

    How much your price (script + fee installation) ?
    I have emailed you a response.
    Regards, R.J.

    ---------------------------------------------------------

    Help spread the word! Like my YouTube-to-Mp3 Conversion Script on Facebook !! :-)
    [Related videos and tutorials are also available at my YouTube channel and on Dailymotion]
    Get free updates about new software version releases, features, and bug fixes!
    ♪♪ Need Web Hosting For My YouTube-To-Mp3 Conversion Software? Check Here !! ♪♪

  2. #662
    New Coder
    Join Date
    Jun 2012
    Posts
    45
    Thanks
    3
    Thanked 0 Times in 0 Posts
    Hi, videos are not converting has youtube changed stuff up?

  3. #663
    Senior Coder chump2877's Avatar
    Join Date
    Dec 2004
    Location
    the U.S. of freakin' A.
    Posts
    2,830
    Thanks
    21
    Thanked 157 Times in 148 Posts
    Regards, R.J.

    ---------------------------------------------------------

    Help spread the word! Like my YouTube-to-Mp3 Conversion Script on Facebook !! :-)
    [Related videos and tutorials are also available at my YouTube channel and on Dailymotion]
    Get free updates about new software version releases, features, and bug fixes!
    ♪♪ Need Web Hosting For My YouTube-To-Mp3 Conversion Software? Check Here !! ♪♪

  4. #664
    New to the CF scene
    Join Date
    Mar 2013
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hello

    today im buy this script YouTube-to-MP3 conversion

    but after upload files when im try to open url i got this error

    Parse error: syntax error, unexpected T_FUNCTION in /home/../public_html/,,,,,.com/index.php on line 147


    im used arvixe.com hosting .

    FFmpeg is already installed on server .

    please help me to fix it

    thank you

  5. #665
    Senior Coder chump2877's Avatar
    Join Date
    Dec 2004
    Location
    the U.S. of freakin' A.
    Posts
    2,830
    Thanks
    21
    Thanked 157 Times in 148 Posts
    Quote Originally Posted by Promediadir View Post
    Hello

    today im buy this script YouTube-to-MP3 conversion

    but after upload files when im try to open url i got this error

    Parse error: syntax error, unexpected T_FUNCTION in /home/../public_html/,,,,,.com/index.php on line 147


    im used arvixe.com hosting .

    FFmpeg is already installed on server .

    please help me to fix it

    thank you
    Hi,

    Please make sure that you have at least PHP 5.3+ installed on your server....That error implies that you are running an older version of PHP...Please see the software requirements for the script here: http://www.tradebit.com/visit.php/23...ct/-/173257962

    If FFmpeg is already installed on the server, then do you have a Linux server? Did you purchase the Windows version of the software by mistake? Do you want me to send you the Linux version?
    Regards, R.J.

    ---------------------------------------------------------

    Help spread the word! Like my YouTube-to-Mp3 Conversion Script on Facebook !! :-)
    [Related videos and tutorials are also available at my YouTube channel and on Dailymotion]
    Get free updates about new software version releases, features, and bug fixes!
    ♪♪ Need Web Hosting For My YouTube-To-Mp3 Conversion Software? Check Here !! ♪♪

  6. #666
    New to the CF scene
    Join Date
    Apr 2013
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hello,
    i tested the free script and everthing works fine.
    Today I buy the full version an now the .flv files are downloaded but not converted.
    Logfile:
    PHP Code:
    FFmpeg version SVN-r0.5.9-4:0.5.9-0ubuntu0.10.04.3Copyright (c2000-2009 Fabrice Bellardet al.
      
    configuration: --extra-version=4:0.5.9-0ubuntu0.10.04.3 --prefix=/usr --enable-avfilter --enable-avfilter-lavf --enable-vdpau --enable-bzlib --

    enable-libgsm --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libvorbis --enable-pthreads --enable-zlib --disable-stripping --

    disable-vhook --enable-runtime-cpudetect --enable-gpl --enable-postproc --enable-swscale --enable-x11grab --enable-libdc1394 --enable-shared --

    disable-static
      
    libavutil     49.1549.150
      libavcodec    52.20
    52.201
      libavformat   52.31
    52.310
      libavdevice   52. 1. 0 
    52. 1. 0
      libavfilter    0. 4. 0 
    /  0. 4. 0
      libswscale     0. 7. 1 
    /  0. 7. 1
      libpostproc   51. 2. 0 
    51. 2. 0
      built on Jan 24 2013 19
    :42:59gcc4.4.3
    videos
    /1366129956_516d7d243d4db5.82569286.flvUnknown format 

    I set disable_errors in index.php to 1 and here is the result:

    PHP Code:
    Noticeob_flush(): failed to flush bufferNo buffer to flushin /var/www/vhosts/XYZ.COM/httpdocs/converter/index.php on line 171

    Notice
    ob_end_flush(): failed to delete and flush bufferNo buffer to delete or flushin /var/www/vhosts/XYZ.COM/httpdocs/converter/index.php on line 182 

    Notice
    ob_flush(): failed to flush bufferNo buffer to flushin /var/www/vhosts/XYZ.COM/httpdocs/converter/index.php on line 183

    Warning
    curl_setopt(): CURLOPT_FOLLOWLOCATION cannot be activated when in safe_mode or an open_basedir is set in /var/www/vhosts/XYZ.COM/httpdocs/converter/VideoConverter.class.php on line 232

    Warning
    Division by zero in /var/www/vhosts/XYZ.COM/httpdocs/converter/VideoConverter.class.php on line 134

    Notice
    ob_end_flush(): failed to delete and flush bufferNo buffer to delete or flushin /var/www/vhosts/XYZ.COM/httpdocs/converter/VideoConverter.class.php on line 139

    Notice
    ob_flush(): failed to flush bufferNo buffer to flushin /var/www/vhosts/XYZ.COM/httpdocs/converter/VideoConverter.class.php on line 140 
    I already read all posts in this thread but it doesnt work..
    Please help me to fix it.
    thx

  7. #667
    Senior Coder chump2877's Avatar
    Join Date
    Dec 2004
    Location
    the U.S. of freakin' A.
    Posts
    2,830
    Thanks
    21
    Thanked 157 Times in 148 Posts
    Hi SolidSnake,

    Here's a list of observations:

    1) You are using a very old version of FFmpeg, and it looks like you tried to compile FFmpeg yourself instead of downloading the latest, stable version via "apt-get install".

    2) You appear to be missing vital codecs required for conversion. Notably, libmp3lame and libx264 are missing from your FFmpeg log file. Run "ffmpeg -codecs" at the command line to verify if these codecs are installed.

    3) Looks like you are using an older versi0n of Ubuntu. It may not make any difference, but you could try a newer version of Ubuntu. (11.10+)

    4) You could also try installing and using "avconv" package as a substitute for "ffmpeg" (for Ubuntu/Debian users). Please see this post.

    5) The majority of the PHP warnings/notices that you are receiving when error reporting is switched on are of no consequence and do not inhibit the execution of the script. That said, this particular warning might be the exception:

    Warning: curl_setopt(): CURLOPT_FOLLOWLOCATION cannot be activated when in safe_mode or an open_basedir is set in /var/www/vhosts/XYZ.COM/httpdocs/converter/VideoConverter.class.php on line 232
    You should check your PHP configuration. It is generally better to "not" run PHP in safe mode these days. Also, an open_basedir restriction could be causing problems if the restriction blocks PHP access to certain app directories.
    Regards, R.J.

    ---------------------------------------------------------

    Help spread the word! Like my YouTube-to-Mp3 Conversion Script on Facebook !! :-)
    [Related videos and tutorials are also available at my YouTube channel and on Dailymotion]
    Get free updates about new software version releases, features, and bug fixes!
    ♪♪ Need Web Hosting For My YouTube-To-Mp3 Conversion Software? Check Here !! ♪♪

  8. #668
    New Coder
    Join Date
    Feb 2012
    Posts
    29
    Thanks
    1
    Thanked 0 Times in 0 Posts
    hi,

    I've have the same probleme, on my ubuntu server, i've run php in safe mod, open base dire set off / on , but nothing more I've have no log in the log folder. but the flv file downloaded successfully.

    I don't throught why this happen.

  9. #669
    Senior Coder chump2877's Avatar
    Join Date
    Dec 2004
    Location
    the U.S. of freakin' A.
    Posts
    2,830
    Thanks
    21
    Thanked 157 Times in 148 Posts
    Quote Originally Posted by bedo1975 View Post
    hi,

    I've have the same probleme, on my ubuntu server, i've run php in safe mod, open base dire set off / on , but nothing more I've have no log in the log folder. but the flv file downloaded successfully.

    I don't throught why this happen.
    I don't know if you have the free or paid-for version, but it sounds like:

    1) File permissions on the 'logs' directory are not set to 0777, and/or
    2) The FFmpeg command is never getting executed or failing to execute, and/or
    3) There is a problem restarting the session in exec_ffmpeg.php (paid-for version only), and/or
    4) You have modified the original code in some way

    #1 is self-explanatory. #2, #3, and #4 will require that you insert some error checking code in:

    1) The method of the conversion class that sends the FFmpeg command to exec_ffmpeg.php.
    2) exec_ffmpeg.php

    Error checking involves echo'ing out and/or logging in a text file various values in the code to determine what the problem is.

    Once you locate the errant values and/or code that is failing (or failing to execute), then you can figure out why this is happening for you.

    I can assure you that the original code runs perfectly on a properly configured server.
    So do some troubleshooting to identify the source of your problem, and post back here if you have additional questions.

    Edit: You can also run ffmpeg/avconv at the command level to see if you are able to convert videos from there.
    Regards, R.J.

    ---------------------------------------------------------

    Help spread the word! Like my YouTube-to-Mp3 Conversion Script on Facebook !! :-)
    [Related videos and tutorials are also available at my YouTube channel and on Dailymotion]
    Get free updates about new software version releases, features, and bug fixes!
    ♪♪ Need Web Hosting For My YouTube-To-Mp3 Conversion Software? Check Here !! ♪♪

  10. #670
    New Coder
    Join Date
    Feb 2012
    Posts
    29
    Thanks
    1
    Thanked 0 Times in 0 Posts
    I've the free and the paid version :

    I can execute ffmpeg commande via ssh. file permissions 0.777 already. result of firebug : 0 | 2 | 0 | 0

  11. #671
    Senior Coder chump2877's Avatar
    Join Date
    Dec 2004
    Location
    the U.S. of freakin' A.
    Posts
    2,830
    Thanks
    21
    Thanked 157 Times in 148 Posts
    Quote Originally Posted by bedo1975 View Post
    I've the free and the paid version :

    I can execute ffmpeg commande via ssh. file permissions 0.777 already. result of firebug : 0 | 2 | 0 | 0
    If there is no log file in logs directory, then the output of ffmpeg_progress.php doesn't help us here. ffmpeg_progress.php execution hinges on the existence of a FFmpeg log file.

    And, if there is no log file in the logs directory, then your firebug output doesn't make any sense. You should be getting:

    Code:
    0 | 0 | 2 | 1
    ...because the log file does not exist for you, so conversion fails.

    The numbers correspond to:

    1) log file length
    2) percent progress
    3) conversion success (1 for success, 2 for failure)
    4) error (1 for error, 2 for no error)

    Again, please do the following to figure out what code is not working correctly for you, so that we can diagnose your exact issue:

    #1 is self-explanatory. #2, #3, and #4 will require that you insert some error checking code in:

    1) The method of the conversion class that sends the FFmpeg command to exec_ffmpeg.php.
    2) exec_ffmpeg.php

    Error checking involves echo'ing out and/or logging in a text file various values in the code to determine what the problem is.

    Once you locate the errant values and/or code that is failing (or failing to execute), then you can figure out why this is happening for you.
    Also check that the _FFMPEG constant in the Config class is the correct location of the FFmpeg (or avconv) binary on your server.
    Regards, R.J.

    ---------------------------------------------------------

    Help spread the word! Like my YouTube-to-Mp3 Conversion Script on Facebook !! :-)
    [Related videos and tutorials are also available at my YouTube channel and on Dailymotion]
    Get free updates about new software version releases, features, and bug fixes!
    ♪♪ Need Web Hosting For My YouTube-To-Mp3 Conversion Software? Check Here !! ♪♪

  12. #672
    New Coder
    Join Date
    May 2012
    Posts
    71
    Thanks
    1
    Thanked 0 Times in 0 Posts
    nice script

  13. #673
    New Coder
    Join Date
    Feb 2012
    Posts
    29
    Thanks
    1
    Thanked 0 Times in 0 Posts
    hey chump, ok finally I have the downloaded files, and the logs txt file.

    Another just small error :

    sh: /usr/local/cpffmpeg/bin/: Is a directory


    My ffmpeg are in this directory.

    any idears


    Edit : simply add ffmpeg at the end and he works fine.
    Last edited by bedo1975; 04-20-2013 at 03:55 PM. Reason: solution

  14. #674
    New to the CF scene
    Join Date
    Apr 2013
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by chump2877 View Post
    Hi SolidSnake,

    Here's a list of observations:

    1) You are using a very old version of FFmpeg, and it looks like you tried to compile FFmpeg yourself instead of downloading the latest, stable version via "apt-get install".

    2) You appear to be missing vital codecs required for conversion. Notably, libmp3lame and libx264 are missing from your FFmpeg log file. Run "ffmpeg -codecs" at the command line to verify if these codecs are installed.

    3) Looks like you are using an older versi0n of Ubuntu. It may not make any difference, but you could try a newer version of Ubuntu. (11.10+)

    4) You could also try installing and using "avconv" package as a substitute for "ffmpeg" (for Ubuntu/Debian users). Please see this post.

    5) The majority of the PHP warnings/notices that you are receiving when error reporting is switched on are of no consequence and do not inhibit the execution of the script. That said, this particular warning might be the exception:



    You should check your PHP configuration. It is generally better to "not" run PHP in safe mode these days. Also, an open_basedir restriction could be causing problems if the restriction blocks PHP access to certain app directories.

    Thanks for the quick replay.
    5) I checked my PHP config and thats not the reason.

    4) Via apt-get install I cannot install avconv. It is available from Version 12.XX as far as I know

    3) My Hoster only supports Ubuntu Server 10.04.4. Its an LTS Version. At the end of this year Ubuntu Server 12 LTS is planned

    1 and 2) I installed ffmpeg via apt-get install and the result can be seen in the log file. Perhaps this is due to the older version of Ubuntu. I'm not sure ...

    I found this (https://ffmpeg.org/trac/ffmpeg/wiki/...tionGuideLucid) to Compile an new Version of ffmpeg on Ubuntu 10.04 LTS.

    Now the MP3 output is ok!

    I tried to convert the same video as MP4, but got an error message.

    The syntax of ffmpeg and x264 has probably changed a bit.
    I edit line 33 from config.class.php
    PHP Code:
    -vpre veryfast      to      preset veryfast 
    Now your script / ffmpeg convert the flv to a mp4 file, but the video file is corrupted.

    It took a very long time. About 45 minutes.

    Have you tested the script/ffmpeg on a VPS?
    What's the minimum System requirement for the Video conversion?

    Or do you think the error has a different cause?

    I tried to explain it all in English, I hope you understand me ;-)
    thx

  15. #675
    Senior Coder chump2877's Avatar
    Join Date
    Dec 2004
    Location
    the U.S. of freakin' A.
    Posts
    2,830
    Thanks
    21
    Thanked 157 Times in 148 Posts
    Now your script / ffmpeg convert the flv to a mp4 file, but the video file is corrupted.

    It took a very long time. About 45 minutes.

    Have you tested the script/ffmpeg on a VPS?
    What's the minimum System requirement for the Video conversion?

    Or do you think the error has a different cause?
    Please paste the contents of the FFmpeg log file that corresponds to the conversion that results in the corrupted mp4 file.

    If mp4 download/conversion is taking a long time:

    1) Are you converting a HD video? Those take longer to download and encode.
    2) How long is the video? A full length tv show or movie is going to take awhile to download and encode.
    3) What is your server's internet download speed? You'll want a minimum of 100 mbps to 1 gbps (somewhere in that range). If you expect to be downloading a lot of long, HD videos, then you'll want a faster connection speed.
    4) Please set the 'maxDuration' key for each converted file type listed in Config::_convertedFileTypes in config.class.php to limit the length of YouTube videos that can be downloaded/converted.

    This script will run on a dedicated, VPS, or shared host, as long as the server is configured correctly and has ample resources.

    Why don't you start by telling me what the server specs are for your VPS? I can help you identify any potential problems there.

    For a low traffic site, you don't need much in the way of server resources to facilitate video conversion. Of course, as your site traffic increases, you will need more server resources and a more powerful server.

    Edit: By the way, the -vpre flag still works fine for me with the latest stable version of FFmpeg on Ubuntu 12.04. So your problems could stem from a faulty server installation and/or configuration. If you continue to have issues, please consider having a professional install the software's required dependencies on your server.
    Last edited by chump2877; 04-25-2013 at 04:27 PM.
    Regards, R.J.

    ---------------------------------------------------------

    Help spread the word! Like my YouTube-to-Mp3 Conversion Script on Facebook !! :-)
    [Related videos and tutorials are also available at my YouTube channel and on Dailymotion]
    Get free updates about new software version releases, features, and bug fixes!
    ♪♪ Need Web Hosting For My YouTube-To-Mp3 Conversion Software? Check Here !! ♪♪


 
Page 45 of 85 FirstFirst ... 35434445464755 ... LastLast

LinkBacks (?)

  1. 08-24-2014, 04:09 AM
  2. 07-21-2014, 05:32 PM
  3. 07-12-2014, 05:59 PM
  4. 06-26-2014, 03:39 PM
  5. 05-31-2014, 09:13 PM
  6. 04-24-2014, 07:53 PM
  7. 04-19-2014, 10:22 AM
  8. 04-04-2014, 08:33 PM
  9. 04-04-2014, 01:58 AM
  10. 03-28-2014, 06:03 AM
  11. 03-20-2014, 06:11 PM
  12. 03-16-2014, 01:22 AM
  13. 03-08-2014, 04:56 PM
  14. 03-07-2014, 06:21 PM
  15. 03-01-2014, 12:48 PM
  16. 02-22-2014, 08:40 PM
  17. 02-22-2014, 12:02 AM
  18. 02-21-2014, 08:15 PM
  19. 02-21-2014, 12:00 AM
  20. 02-20-2014, 08:37 PM
  21. 02-20-2014, 06:53 PM
  22. 02-20-2014, 03:21 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •