Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Page 18 of 91 FirstFirst ... 816171819202868 ... LastLast
Results 256 to 270 of 1355
Like Tree14Likes

Thread: YouTube-to-MP3 conversion - PHP class and script

  1. #256
    New Coder
    Join Date
    Feb 2012
    Posts
    24
    Thanks
    0
    Thanked 3 Times in 3 Posts
    Quote Originally Posted by orditeck View Post
    worked fine here...

  2. #257
    New to the CF scene
    Join Date
    Feb 2012
    Posts
    7
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by drakus View Post
    worked fine here...
    What kind of FLV url does it give you? Same as mine?

    Just trying to figure out if the problem comes from the URL...
    Else it means that it comes from the download, I'll have to figure out why it creates a 0kb file in the video folder and then directly try to convert it as if it was completed..!
    Last edited by orditeck; 02-26-2012 at 08:06 PM.

  3. #258
    New Coder
    Join Date
    Feb 2012
    Posts
    10
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Hi, i have came across something. when i put a URL to convert the video into mp3 and before it downloads i refresh the page or close it, script does not stops downloading the video it keeps on downloading video....has anyone seen this with them as well?

  4. #259
    New Coder
    Join Date
    Feb 2012
    Posts
    24
    Thanks
    0
    Thanked 3 Times in 3 Posts
    Quote Originally Posted by orditeck View Post
    What kind of FLV url does it give you? Same as mine?

    Just trying to figure out if the problem comes from the URL...
    Else it means that it comes from the download, I'll have to figure out why it creates a 0kb file in the video folder and then directly try to convert it as if it was completed..!
    For some reason your server is grabbing it from the cache of youtube & not the main url.

    i bolded the cache part...

    http://o-o.preferred.par08s01.v5.lscache4.c.youtube.com/videoplayback?sparams=id,expire,ip,ipbits,itag,source,ratebypass,cp&fexp=916012,901700&itag=46&ip=17 6.0.0.0&signature=D197D5B65021AE7FB63941EA1F4C487AA633C36D.48853737618BFCD963ED3B8434C2C7B30EA52021& sver=3&ratebypass=yes&source=youtube&expire=1330300216&key=yt1&ipbits=8&cp=U0hSRVNLTl9GUENOMl9LRVJDO lZucTZ3c3dLVDRl&id=768db7b137b87610

  5. #260
    New to the CF scene
    Join Date
    Feb 2012
    Posts
    7
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by drakus View Post
    For some reason your server is grabbing it from the cache of youtube & not the main url.

    i bolded the cache part...

    http://o-o.preferred.par08s01.v5.lscache4.c.youtube.com/videoplayback?sparams=id,expire,ip,ipbits,itag,source,ratebypass,cp&fexp=916012,901700&itag=46&ip=17 6.0.0.0&signature=D197D5B65021AE7FB63941EA1F4C487AA633C36D.48853737618BFCD963ED3B8434C2C7B30EA52021& sver=3&ratebypass=yes&source=youtube&expire=1330300216&key=yt1&ipbits=8&cp=U0hSRVNLTl9GUENOMl9LRVJDO lZucTZ3c3dLVDRl&id=768db7b137b87610
    The url seems to work...
    Could you send me the FLV URL you get from the same youtube video?

  6. #261
    New Coder
    Join Date
    Feb 2012
    Posts
    24
    Thanks
    0
    Thanked 3 Times in 3 Posts
    Code:
    http:\/\/o-o.preferred.ord12s06.v22.lscache8.c.youtube.com\/generate_204?sparams=id%2Cexpire%2Cip%2Cipbits%2Citag%2Csource%2Calgorithm%2Cburst%2Cfactor%2Ccp\u0026fexp=913528\u0026algorithm=throttle-factor\u0026itag=34\u0026ip=66.0.0.0\u0026burst=40\u0026sver=3\u0026signature=18FBDA9A65641990622D4AF4B2260F7AC029FE0E.5A4F885F9D917F8B6483E0A3E5477A0D9A5AD80A\u0026source=youtube\u0026expire=1330307416\u0026key=yt1\u0026ipbits=8\u0026factor=1.25\u0026cp=U0hSRVNLVV9GUENOMl9LRVlFOjZZbHZ3N0tOTDZH\u0026id=768db7b137b87610
    For most part same one just different cache link..

    If you look at the source, you will that it will be the same thing or very similiar.

    look for img.src and you will see something like this.

    Code:
    img.src = "http:\/\/o-o.preferred.ord12s06.v22.lscache8.c.youtube.com\/generate_204?sparams=id%2Cexpire%2Cip%2Cipbits%2Citag%2Csource%2Calgorithm%2Cburst%2Cfactor%2Ccp\u0026fexp=913528\u0026algorithm=throttle-factor\u0026itag=34\u0026ip=66.0.0.0\u0026burst=40\u0026sver=3\u0026signature=18FBDA9A65641990622D4AF4B2260F7AC029FE0E.5A4F885F9D917F8B6483E0A3E5477A0D9A5AD80A\u0026source=youtube\u0026expire=1330307416\u0026key=yt1\u0026ipbits=8\u0026factor=1.25\u0026cp=U0hSRVNLVV9GUENOMl9LRVlFOjZZbHZ3N0tOTDZH\u0026id=768db7b137b87610";

  7. #262
    New to the CF scene
    Join Date
    Feb 2012
    Posts
    7
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by drakus View Post
    Code:
    http:\/\/o-o.preferred.ord12s06.v22.lscache8.c.youtube.com\/generate_204?sparams=id%2Cexpire%2Cip%2Cipbits%2Citag%2Csource%2Calgorithm%2Cburst%2Cfactor%2Ccp\u0026fexp=913528\u0026algorithm=throttle-factor\u0026itag=34\u0026ip=66.0.0.0\u0026burst=40\u0026sver=3\u0026signature=18FBDA9A65641990622D4AF4B2260F7AC029FE0E.5A4F885F9D917F8B6483E0A3E5477A0D9A5AD80A\u0026source=youtube\u0026expire=1330307416\u0026key=yt1\u0026ipbits=8\u0026factor=1.25\u0026cp=U0hSRVNLVV9GUENOMl9LRVlFOjZZbHZ3N0tOTDZH\u0026id=768db7b137b87610
    For most part same one just different cache link..

    If you look at the source, you will that it will be the same thing or very similiar.

    look for img.src and you will see something like this.

    Code:
    img.src = "http:\/\/o-o.preferred.ord12s06.v22.lscache8.c.youtube.com\/generate_204?sparams=id%2Cexpire%2Cip%2Cipbits%2Citag%2Csource%2Calgorithm%2Cburst%2Cfactor%2Ccp\u0026fexp=913528\u0026algorithm=throttle-factor\u0026itag=34\u0026ip=66.0.0.0\u0026burst=40\u0026sver=3\u0026signature=18FBDA9A65641990622D4AF4B2260F7AC029FE0E.5A4F885F9D917F8B6483E0A3E5477A0D9A5AD80A\u0026source=youtube\u0026expire=1330307416\u0026key=yt1\u0026ipbits=8\u0026factor=1.25\u0026cp=U0hSRVNLVV9GUENOMl9LRVlFOjZZbHZ3N0tOTDZH\u0026id=768db7b137b87610";
    Yes I saw that it's very similar in the source of the YouTube page,
    so why are you saying that my problem may be that my server grab the cache URL and not the main url? It seems that youtube itself takes the cache, so I guess this is actually the main url. Don't know if I'm clear enough here hehe.

    If my link is good, I really don't see where my issue come from then...

  8. #263
    Senior Coder chump2877's Avatar
    Join Date
    Dec 2004
    Location
    the U.S. of freakin' A.
    Posts
    2,860
    Thanks
    22
    Thanked 157 Times in 148 Posts
    orditeck, I tried to convert your video. The first time, it said there was an error downloading the video. The second time --- well it's still downloading at the moment (so it is downloading, but VERY slowly).

    I converted another video and it worked fine.

    My best guess is that YouTube is currently experiencing some server difficulties or perhaps is changing parts of their site's front end.

    I do know that YouTube has been making some changes with their channel layouts recently, so it wouldn't surprise me if we are in for another format change site-wide. In that case, I'll have to make some changes to the code to adjust. Keep me posted.
    Regards, R.J.

    ---------------------------------------------------------

    Help spread the word! Like my YouTube-to-Mp3 Conversion Script on Facebook !! :-)
    [Related videos and tutorials are also available at my YouTube channel and on Dailymotion]
    Get free updates about new software version releases, features, and bug fixes!
    ♪♪ Need Web Hosting For My YouTube-To-Mp3 Conversion Software? Check Here !! ♪♪

  9. Users who have thanked chump2877 for this post:

    orditeck (02-26-2012)

  10. #264
    New to the CF scene
    Join Date
    Feb 2012
    Posts
    7
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by chump2877 View Post
    orditeck, I tried to convert your video. The first time, it said there was an error downloading the video. The second time --- well it's still downloading at the moment (so it is downloading, but VERY slowly).

    I converted another video and it worked fine.

    My best guess is that YouTube is currently experiencing some server difficulties or perhaps is changing parts of their site's front end.

    I do know that YouTube has been making some changes with their channel layouts recently, so it wouldn't surprise me if we are in for another format change site-wide. In that case, I'll have to make some changes to the code to adjust. Keep me posted.
    Hi,

    thanks for your answer.
    The problem appears with every video I tried.
    I tried the same videos on some live URL people gave here and it was working...

    You can also try my demo if you want: http://188.165.33.43/yt/index.php
    There is just no download. It creates an emply .flv and try to convert it, that's it.

    Log shows:
    Code:
    FFmpeg version SVN-r0.5.1-4:0.5.1-1ubuntu1.3, Copyright (c) 2000-2009 Fabrice Bellard, et al.
      configuration: --extra-version=4:0.5.1-1ubuntu1.3 --prefix=/usr --enable-avfilter --enable-avfilter-lavf --enable-vdpau --enable-bzlib --enable-libgsm --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libvorbis --enable-pthreads --enable-zlib --disable-stripping --disable-vhook --enable-runtime-cpudetect --enable-gpl --enable-postproc --enable-swscale --enable-x11grab --enable-libdc1394 --enable-shared --disable-static
      libavutil     49.15. 0 / 49.15. 0
      libavcodec    52.20. 1 / 52.20. 1
      libavformat   52.31. 0 / 52.31. 0
      libavdevice   52. 1. 0 / 52. 1. 0
      libavfilter    0. 4. 0 /  0. 4. 0
      libswscale     0. 7. 1 /  0. 7. 1
      libpostproc   51. 2. 0 / 51. 2. 0
      built on Dec 21 2011 18:41:38, gcc: 4.4.3
    videos/1330284731_4f4a88bb907ce9.36842226.flv: Unknown format
    Edit:
    I've just got this video downloaded by the server:
    http://www.youtube.com/watch?v=D-rm8...eature=related
    in LOW mode.

    But I'm still getting the " Unknown format " in the LOG.
    Last edited by orditeck; 02-26-2012 at 09:33 PM.

  11. #265
    Senior Coder chump2877's Avatar
    Join Date
    Dec 2004
    Location
    the U.S. of freakin' A.
    Posts
    2,860
    Thanks
    22
    Thanked 157 Times in 148 Posts
    Quote Originally Posted by umang.goyal View Post
    Hi, i have came across something. when i put a URL to convert the video into mp3 and before it downloads i refresh the page or close it, script does not stops downloading the video it keeps on downloading video....has anyone seen this with them as well?
    If you are having problems with people abandoning conversions, my suggestion to you is to run a cron job periodically that purges both the '/logs/' and '/videos/' directories. You can check the 'last modified' dates of each of the files in those directories to verify that the files are older than a certain date, and therefore OK to delete.

    That will get rid of the files. If you are looking to stop the downloads midstream to save bandwidth, then that's a different problem. Offhand, I don't know how that would be accomplished. You'd have to find a way to stop the cURL process at any time, and not just after a certain period or when the connection times out, i.e.:

    PHP Code:
    curl_setopt($ciCURLOPT_CONNECTTIMEOUT5);
    curl_setopt($ciCURLOPT_TIMEOUT5); 
    Last edited by chump2877; 02-26-2012 at 09:52 PM.
    Regards, R.J.

    ---------------------------------------------------------

    Help spread the word! Like my YouTube-to-Mp3 Conversion Script on Facebook !! :-)
    [Related videos and tutorials are also available at my YouTube channel and on Dailymotion]
    Get free updates about new software version releases, features, and bug fixes!
    ♪♪ Need Web Hosting For My YouTube-To-Mp3 Conversion Software? Check Here !! ♪♪

  12. #266
    Senior Coder chump2877's Avatar
    Join Date
    Dec 2004
    Location
    the U.S. of freakin' A.
    Posts
    2,860
    Thanks
    22
    Thanked 157 Times in 148 Posts
    Quote Originally Posted by orditeck View Post

    But I'm still getting the " Unknown format " in the LOG.
    Maybe you are missing a video codec. That shouldn't be an issue with XAMPP or Windows OS, but maybe with a Linux system.

    BTW, I was able to convert your original video successfully - albeit slowly.
    Regards, R.J.

    ---------------------------------------------------------

    Help spread the word! Like my YouTube-to-Mp3 Conversion Script on Facebook !! :-)
    [Related videos and tutorials are also available at my YouTube channel and on Dailymotion]
    Get free updates about new software version releases, features, and bug fixes!
    ♪♪ Need Web Hosting For My YouTube-To-Mp3 Conversion Software? Check Here !! ♪♪

  13. #267
    New to the CF scene
    Join Date
    Feb 2012
    Posts
    7
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by chump2877 View Post
    Maybe you are missing a video codec. That shouldn't be an issue with XAMPP or Windows OS, but maybe with a Linux system.

    BTW, I was able to convert your original video successfully - albeit slowly.
    But the actual problem is...
    why me server isn't loading the .FLV?

    It creates a 0kb file instead of downloading it.

  14. #268
    Senior Coder chump2877's Avatar
    Join Date
    Dec 2004
    Location
    the U.S. of freakin' A.
    Posts
    2,860
    Thanks
    22
    Thanked 157 Times in 148 Posts
    Quote Originally Posted by orditeck View Post
    But the actual problem is...
    why me server isn't loading the .FLV?

    It creates a 0kb file instead of downloading it.
    Sounds like a cURL problem.
    Regards, R.J.

    ---------------------------------------------------------

    Help spread the word! Like my YouTube-to-Mp3 Conversion Script on Facebook !! :-)
    [Related videos and tutorials are also available at my YouTube channel and on Dailymotion]
    Get free updates about new software version releases, features, and bug fixes!
    ♪♪ Need Web Hosting For My YouTube-To-Mp3 Conversion Software? Check Here !! ♪♪

  15. #269
    New to the CF scene
    Join Date
    Feb 2012
    Posts
    7
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by chump2877 View Post
    Sounds like a cURL problem.
    Yes, I installed the script on another server and it works well.
    I will update cURL and PHP, will probably work after that.

    Thanks.

  16. #270
    New Coder
    Join Date
    Feb 2012
    Posts
    24
    Thanks
    0
    Thanked 3 Times in 3 Posts
    Quote Originally Posted by orditeck View Post
    Yes, I installed the script on another server and it works well.
    I will update cURL and PHP, will probably work after that.

    Thanks.
    Make sure you have latest php 5.3.10 or whatever is latst version for your distro.

    I had same problem, slower than slow, it took about 3 - 5 min for any of my servers to download it and they are all on 1 gig ports.

    PS: I custom compile all my stuff, i do not use the distros releases.


 
Page 18 of 91 FirstFirst ... 816171819202868 ... LastLast

LinkBacks (?)

  1. 08-24-2014, 05:09 AM
  2. 07-21-2014, 06:32 PM
  3. 07-12-2014, 06:59 PM
  4. 06-26-2014, 04:39 PM
  5. 05-31-2014, 10:13 PM
  6. 04-24-2014, 08:53 PM
  7. 04-19-2014, 11:22 AM
  8. 04-04-2014, 09:33 PM
  9. 04-04-2014, 02:58 AM
  10. 03-28-2014, 07:03 AM
  11. 03-20-2014, 07:11 PM
  12. 03-16-2014, 02:22 AM
  13. 03-08-2014, 05:56 PM
  14. 03-07-2014, 07:21 PM
  15. 03-01-2014, 01:48 PM
  16. 02-22-2014, 09:40 PM
  17. 02-22-2014, 01:02 AM
  18. 02-21-2014, 09:15 PM
  19. 02-21-2014, 01:00 AM
  20. 02-20-2014, 09:37 PM
  21. 02-20-2014, 07:53 PM
  22. 02-20-2014, 04:21 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •