Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 10 of 10
  1. #1
    Senior Coder NancyJ's Avatar
    Join Date
    Feb 2005
    Location
    Bradford, UK
    Posts
    3,174
    Thanks
    19
    Thanked 66 Times in 65 Posts

    Script ending prematurely

    Since yesterday, a script that I have just stops, well it stops outputting to the browser and continues to run for some time and then stops for no reason. I havent changed anything - except some mysql settings - I just cant see any reason for it to do this.
    The basic flow goes

    call the preprocess function
    call the process data function
    call the postprocess function

    What happens is part way through the process data function, output is no longer sent. The function completes but nothing else happens after that.

  • #2
    Senior Coder chump2877's Avatar
    Join Date
    Dec 2004
    Location
    the U.S. of freakin' A.
    Posts
    2,830
    Thanks
    21
    Thanked 157 Times in 148 Posts
    Seeing your code would help...
    Regards, R.J.

    ---------------------------------------------------------

    Help spread the word! Like my YouTube-to-Mp3 Conversion Script on Facebook !! :-)
    [Related videos and tutorials are also available at my YouTube channel and on Dailymotion]
    Get free updates about new software version releases, features, and bug fixes!
    ♪♪ …Need Web Hosting For My YouTube-To-Mp3 Conversion Software? Check Here !!… ♪♪

  • #3
    Senior Coder NancyJ's Avatar
    Join Date
    Feb 2005
    Location
    Bradford, UK
    Posts
    3,174
    Thanks
    19
    Thanked 66 Times in 65 Posts
    the code hasnt changed at all but if it makes you feel better.

    PHP Code:
    lockTable($clientID);
    prepareData($activeTable$altTable$clientID);
    processData($clientID);
    removeDuplicates($activeTable$altTable);
    unlockTable();
    setDepartures(); 
    FWIW, its just run fine as a cron job for another client (with 100k rows, the ones that were failing were 260-450k rows), it seems to be intermittent or possibly related to the amount of data being processed.

  • #4
    UE Antagonizer Fumigator's Avatar
    Join Date
    Dec 2005
    Location
    Utah, USA, Northwestern hemisphere, Earth, Solar System, Milky Way Galaxy, Alpha Quadrant
    Posts
    7,691
    Thanks
    42
    Thanked 637 Times in 625 Posts
    Is your script running into the max_execution_time limit? You should get a warning if that's the case but maybe warnings are being suppressed?

  • #5
    Senior Coder NancyJ's Avatar
    Join Date
    Feb 2005
    Location
    Bradford, UK
    Posts
    3,174
    Thanks
    19
    Thanked 66 Times in 65 Posts
    warnings arent suppressed on this part of the site - otherwise, yeah it could be max execution time, but shouldnt be since mysql time isnt included in that. But it cant be - cos as you said - it woul give an error

  • #6
    Supreme Overlord Spookster's Avatar
    Join Date
    May 2002
    Location
    Marion, IA USA
    Posts
    6,278
    Thanks
    4
    Thanked 83 Times in 82 Posts
    You said you changed some mysql settings. What did you change? Have you tried changing things back to see if it works again?
    Spookster
    CodingForums Supreme Overlord
    All Hail Spookster

  • #7
    Senior Coder NancyJ's Avatar
    Join Date
    Feb 2005
    Location
    Bradford, UK
    Posts
    3,174
    Thanks
    19
    Thanked 66 Times in 65 Posts
    Just the read and sort buffer sizes

  • #8
    Supreme Overlord Spookster's Avatar
    Join Date
    May 2002
    Location
    Marion, IA USA
    Posts
    6,278
    Thanks
    4
    Thanked 83 Times in 82 Posts
    When you change those settings back to what they were does it work again?
    Spookster
    CodingForums Supreme Overlord
    All Hail Spookster

  • #9
    Senior Coder NancyJ's Avatar
    Join Date
    Feb 2005
    Location
    Bradford, UK
    Posts
    3,174
    Thanks
    19
    Thanked 66 Times in 65 Posts
    It seems to be working again today /shrug - didnt change anything

  • #10
    New Coder
    Join Date
    Feb 2005
    Posts
    40
    Thanks
    0
    Thanked 0 Times in 0 Posts
    your script ha some IA ? eheheh little joking
    you can only understend the problem with some dedugging.
    if these script are run from a cron, create you dedugging to output to a log file and see whats really happening.
    think i cant help other way.


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •