Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 6 of 6
  1. #1
    New to the CF scene
    Join Date
    Feb 2006
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts

    flush output not working with me why, help

    hi all,
    i have one problem
    the output is output once
    i love to use flush() function put i get the all page once
    iam add after etch block the flush function put the output apper fully once

    i am trying to add usleep() function after evry flush and still get the body fully once
    my server system liunx and the function flush working good with any vb forum in this server

    // sorry for bad english
    -------------------------------
    this is my script that i need to flush the header block frist
    http://wd.nilesolutions.org/

    in the top off my php files i added this code
    PHP Code:
    ob_implicit_flush(FALSE);

    if (!
    headers_sent()
         AND 
    function_exists('ob_start')
             AND 
    function_exists('crc32')
                 AND 
    function_exists('gzcompress'))
       {
       
    $output_handler = @ini_get('output_handler');

       if (
    $output_handler != 'ob_gzhandler')
       {
                    @
    ob_end_clean();
       }
       
    ob_start();
       } 
    i used template system ok, so after parse any block i added the flush function ,
    Any ideas on how to fix this?
    thanks ,
    Last edited by ejasoft; 02-14-2006 at 04:16 PM.

  • #2
    New to the CF scene
    Join Date
    Feb 2006
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Question

    any help ??

  • #3
    Regular Coder
    Join Date
    Jun 2002
    Posts
    905
    Thanks
    23
    Thanked 5 Times in 5 Posts
    hey... there is an explanation here .. sleep function help

    it will explain why you get it all at once

  • #4
    New to the CF scene
    Join Date
    Feb 2006
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts
    thankz but the problem still exists
    i am added a flush function after etch block
    i am not looking for sleep after any block i need only output the etch block after parse it like vb forums , or like this site http://www.codingforums.com

    regard

  • #5
    Regular Coder
    Join Date
    Jun 2002
    Posts
    905
    Thanks
    23
    Thanked 5 Times in 5 Posts
    as per that post .. could be the browser not flushing .. and php will not flush browser... only the web server cache .. could also be your connection which also cant be flushed you see ..

  • #6
    New to the CF scene
    Join Date
    Feb 2006
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts
    i found the reason is i am make all output in one table and the ie not output any thing to locate the end of table so flush not wroking
    thankz


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •