Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 2 of 2
  1. #1
    Regular Coder
    Join Date
    Nov 2004
    Location
    Edinburgh, SCO
    Posts
    113
    Thanks
    0
    Thanked 0 Times in 0 Posts

    PHP + XSLT + IIS = crash?

    Hi ya,

    a friend of mine uses a windows 2003 Server. He recently installed PHP 4.3.11 and so far it was running smoothly. However:

    1) If he uses IIS and PHP 4.3.11 and then starts the XSLT extension, the server crashes
    2) If he uses Apache2 and PHP 4.3.11 and then starts XSLT, Apache crashes.
    3) Using Apache 2 on Win 2003 Server with PHP 5 and XSLT works fine
    4) Using Apache 2 on Win 2003 Server with PHP 5 and XSLT and MySQL results in apache crashing again.

    So he asked me how he could get PHP, XSLT and MySQL running on a Win 2003 Server. But to be fair I habe no clue what so ever. Does anyone of you know why this doesnt work or how one could solve this problem?

    Cheers

    Schotte

  • #2
    God Emperor Fou-Lu's Avatar
    Join Date
    Sep 2002
    Location
    Saskatoon, Saskatchewan
    Posts
    16,994
    Thanks
    4
    Thanked 2,662 Times in 2,631 Posts
    I'm guessing he's using the incorrect library.
    XSL = php 5.0
    XSLT = php 4.3+

    XSL requires libxslt 1.0.18+ and php 5.x
    XSLT requires Sablotron and expat as well as iconv - I believe these are bundled with 4.3+

    So I'm guessing since it has no problems with the 5.x, that he is loading the libxml library, and not the sablotron and expat libraries.

    Personally, I prefer the 4.3.x xslt functions. Find that they output the way I like them

    Have him check on these files though, make sure its loading the ones required for the php version


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •