Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 1 of 1
  1. #1
    New to the CF scene
    Join Date
    Jun 2005
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    single quote in GET variable -- help! [solved, please delete!]

    Okay, I've searched for over an hour on this forum and others, and I've tried every method I've found to circumvent this, but nothing's worked. Here's the problem.

    I'm using PHP to pull information from a database, simple enough. Certain variables are posted using GET for sorting purposes. The problem is that one row value contains an apostrophe: "Mine's". I need to be able to post that to GET, but every time I do--no matter what method I use to try and encode, decode, addslash, stripslash, replace, whatever--it comes up "Mine%27s" and breaks everything. I can't even figure out where this is happening. Is there a method to force an apostrophe into the URL, or is there something else I can do? I'm totally frustrated by this, and I've come to a dead end.

    EDIT: So much for dead end. Right after posting this, I decided to search for "apostrophe" instead of "single quote," and almost immediately found what I needed. It's taken some tweaking, but it works now. Could a mod please delete this thread?
    Last edited by iamthejarha; 06-11-2005 at 06:19 AM.


 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •