Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 5 of 5
  1. #1
    New Coder
    Join Date
    Feb 2012
    Posts
    85
    Thanks
    8
    Thanked 0 Times in 0 Posts

    Strange Problem Driving me mad! Wamp or Include code

    Hi Guys,

    Basically I'm working on a website in my local host which is WAMP...the directory for the site is localhost/shirts4mike/index.php....This takes you too the homepage which works okay.

    The problem is when you click on one of the links on the homepage..contacts...this should take you too the contract.php page...however it just doesn't take you anywhere and takes you too localhost/shirts4mike/#

    What's also strange is...when you go too localhost/shirts4mike/contact.php it takes you too the correct page!

    index.php code:

    PHP Code:
    <?php include('inc/header.php'); ?>

            <div class="section banner">

                <div class="wrapper">

                    <img class="hero" src="img/mike-the-frog.png" alt="Mike the Frog says:">
                    <div class="button">
                        <a href="#">
                            <h2>Hey, I&rsquo;m Mike!</h2>
                            <p>Check Out My Shirts</p>
                        </a>
                    </div>
                </div>

            </div>

            <div class="section shirts latest">

                <div class="wrapper">

                    <h2>Mike&rsquo;s Latest Shirts</h2>

                    <ul class="products">
                        <li><a href="#">
                                <img src="img/shirts/shirt-108.jpg">
                                <p>View Details</p>
                            </a>
                        </li><li>
                            <a href="#">
                                <img src="img/shirts/shirt-107.jpg">
                                <p>View Details</p>
                            </a>
                        </li><li>
                            <a href="#">
                                <img src="img/shirts/shirt-106.jpg">
                                <p>View Details</p>
                            </a>
                        </li><li>
                            <a href="#">
                                <img src="img/shirts/shirt-105.jpg">
                                <p>View Details</p>
                            </a>
                        </li>                                
                    </ul>

                </div>

            </div>

        </div>

        <div class="footer">

            <div class="wrapper">

                <ul>        
                    <li><a href="http://twitter.com/treehouse">Twitter</a></li>
                    <li><a href="https://www.facebook.com/TeamTreehouse">Facebook</a></li>
                </ul>

                <p>&copy;<?php echo date('Y'); ?> Shirts 4 Mike</p>

            </div>
        
        </div>

    </body>
    </html>
    inc page which is header.php:

    PHP Code:
    <html>
    <head>
        <title><?php echo"Shirts 4 Mike"?></title>
        <link rel="stylesheet" href="css/style.css" type="text/css">
        <link rel="stylesheet" href="http://fonts.googleapis.com/css?family=Oswald:400,700" type="text/css">
        <link rel="shortcut icon" href="favicon.ico">
    </head>
    <body>

        <div class="header">

            <div class="wrapper">

                <h1 class="branding-title"><a href="./">Shirts 4 Mike</a></h1>

                <ul class="nav">
                    <li class="shirts"><a href="#">Shirts</a></li>
                    <li class="contact"><a href="contact.php">Contact</a></li>
                    <li class="cart"><a href="#">Shopping Cart</a></li>
                </ul>

            </div>

        </div>

        <div id="content">
    contact.php code:

    PHP Code:
    <?php include('inc/header.php'); ?>

        <div class="section page">

            <h1>Contact</h1>

        </div>
    Any ideas, its only something small but its driving me mad!
    Attached Thumbnails Attached Thumbnails Strange Problem Driving me mad! Wamp or Include code-homepage.jpg   Strange Problem Driving me mad! Wamp or Include code-contactpage.jpg   Strange Problem Driving me mad! Wamp or Include code-whenyouclickcontact.jpg  
    Don't Click Here!

  • #2
    Regular Coder student101's Avatar
    Join Date
    Nov 2007
    Posts
    634
    Thanks
    80
    Thanked 15 Times in 15 Posts

    Thumbs up

    try ../contact.php

    Edit: Your header is inside a folder called inc
    This exists in header.php
    <li class="contact"><a href="contact.php">Contact</a></li>
    that link means its in the same folder & not on the root, in this case the root folder being shirts4mike
    Last edited by student101; 01-16-2013 at 09:22 PM.
    Thanks for your support!
    Update MySQL with checkboxes | Tell A Friend | Delete MySQL with checkboxes

    Give thanks & resolve when done :thumbsup:

  • #3
    New Coder
    Join Date
    Feb 2012
    Posts
    85
    Thanks
    8
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by student101 View Post
    try ../contact.php

    Edit: Your header is inside a folder called inc
    This exists in header.php
    <li class="contact"><a href="contact.php">Contact</a></li>
    that link means its in the same folder & not on the root, in this case the root folder being shirts4mike
    I thought you had cracked it then but it's still not working!

    It looks like it should, just to make sure if turned off the WAMP server and put back on again just to make sure that my browser wasn't displaying some kind of cached code but it still just resolves too localhost/shirts4mike/index.php# (when i click contact, the hash is added)

    Any more ideas guys!?
    Don't Click Here!

  • #4
    Regular Coder student101's Avatar
    Join Date
    Nov 2007
    Posts
    634
    Thanks
    80
    Thanked 15 Times in 15 Posts
    Still unresolved?
    Thanks for your support!
    Update MySQL with checkboxes | Tell A Friend | Delete MySQL with checkboxes

    Give thanks & resolve when done :thumbsup:

  • #5
    God Emperor Fou-Lu's Avatar
    Join Date
    Sep 2002
    Location
    Saskatoon, Saskatchewan
    Posts
    16,994
    Thanks
    4
    Thanked 2,662 Times in 2,631 Posts
    This problem is neither the include nor the wamp, rather its an HTML or a browser issue.
    Clear your browser cache and try again, or append a random querystring to force a non-cached request. I have no problem with running the above. You should be able to verify after forcing a non-cached request and clicking the link or viewing the HTML source code.
    PHP Code:
    header('HTTP/1.1 420 Enhance Your Calm'); 
    Been gone for a few months, and haven't programmed in that long of a time. Meh, I'll wing it ;)


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •