Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 6 of 6
  1. #1
    Regular Coder
    Join Date
    Oct 2007
    Location
    Glencoe, Ontario, Canada
    Posts
    340
    Thanks
    19
    Thanked 27 Times in 27 Posts

    Login bar no longer working

    Its odd I checked my site today and for some reason my login bar is no longer working the portion after you log in where i have the headings for dashboard and so on works but the to text boxs no longer appear. www.teamvindictive.org

    PHP Code:
    <div id="dashboard"><div id="bar">

    <ul class="reg">
    <li><?php global $user_ID$user_identity$user_level ?></li>
           <li> <?php if ( $user_ID ) : ?><a href="#">Welcome <?php echo $user_identity ?>.</a></li> <li><a href="<?php bloginfo('url'?>/wp-admin/">Dashboard</a></li>
    <li><?php if ( $user_level >= ) : ?>
    <a href="<?php bloginfo('url'?>/wp-admin/post-new.php">Write a post</a><?php endif // $user_level >= 1 ?></li>

    <li><a href="<?php bloginfo('url'?>/wp-admin/profile.php">Profile</a></li>
    <li><?php wp_loginout(); ?></li>
    <?php elseif ( get_option('users_can_register') ) : ?>

    <form action="<?php bloginfo('url'?>/wp-login.php" method="post">
    <div class="login-row.email"><label for="log"><input type="text" name="log" id="log" value="
    " size="22" autocomplete="off"/><span></span>User</label></div>

    <div class="login-row.password"><label for="pwd"><input type="password" name="pwd" id="pwd" size="22" autocomplete="off"/><span></span>Password</label></div>

    <span class="generic_surround float-left"><input type="submit" name="submit" value="Connect" class="button" /></span>

    <div class="login-row" style="display: none"><label for="rememberme"><input name="rememberme" id="rememberme" type="checkbox" checked="checked" value="forever" />Remember me</label></div>
    <input type="hidden" name="redirect_to" value="<?php echo $_SERVER['REQUEST_URI']; ?>"/>
    </form>
     
    <li><a href="<?php bloginfo('url'?>/wp-login.php?action=register">Register</a></li>
    <li><a href="<?php bloginfo('url'?>/wp-login.php?action=lostpassword">Recover password</a></li>
            </ul>

            <?php endif // get_option('users_can_register') ?>
    </div></div>
    Eric "PitbullMean" Melo
    Always Start your layout with*{border:0; margin:0; padding:0;}
    Be sure to Thank ALL Users who give assistance.

  • #2
    Regular Coder
    Join Date
    Oct 2007
    Location
    Glencoe, Ontario, Canada
    Posts
    340
    Thanks
    19
    Thanked 27 Times in 27 Posts
    bump!
    Eric "PitbullMean" Melo
    Always Start your layout with*{border:0; margin:0; padding:0;}
    Be sure to Thank ALL Users who give assistance.

  • #3
    Super Moderator Inigoesdr's Avatar
    Join Date
    Mar 2007
    Location
    Florida, USA
    Posts
    3,647
    Thanks
    2
    Thanked 406 Times in 398 Posts
    Quote Originally Posted by PitbullMean View Post
    Its odd I checked my site today and for some reason my login bar is no longer working the portion after you log in where i have the headings for dashboard and so on works but the to text boxs no longer appear.
    It sounds like you have an issue with your CSS. You have some strange values for class names, such as:
    Code:
    <div class="login-row.password"><label for="pwd"><input type="password" name="pwd" id="pwd" size="22" autocomplete="off"/><span></span>Password</label></div>
    
    <span class="generic_surround float-left">
    When you are logged in hit F12 in your browser and inspect the header to see if you can see the text fields you are referring to in the page source. If you can check the developer tools(how to do this varies by browser) to see what CSS values are being applied to your text fields. It may be as simple as updating your class names, or adding CSS to "display: block" your fields.

  • #4
    Regular Coder
    Join Date
    Oct 2007
    Location
    Glencoe, Ontario, Canada
    Posts
    340
    Thanks
    19
    Thanked 27 Times in 27 Posts
    ya I know i updated my css to css3 but i guess i should of left it alone. sad part is i dont have a copy of my old css. But its weird i remove all div coding from the coding above and the text areas dont even show up plain jane, still a blank box
    Last edited by PitbullMean; 12-28-2012 at 05:45 PM.
    Eric "PitbullMean" Melo
    Always Start your layout with*{border:0; margin:0; padding:0;}
    Be sure to Thank ALL Users who give assistance.

  • #5
    Regular Coder
    Join Date
    Oct 2007
    Location
    Glencoe, Ontario, Canada
    Posts
    340
    Thanks
    19
    Thanked 27 Times in 27 Posts
    Ok well I traced it down to it being a problem with the PHP cause if i totally remove the PHP the log text blocks show up proper, but then when u log in it doesnt cycle over to the other function which is it having to show Welcome (username) Profile | Log out and other functions
    Eric "PitbullMean" Melo
    Always Start your layout with*{border:0; margin:0; padding:0;}
    Be sure to Thank ALL Users who give assistance.

  • #6
    God Emperor Fou-Lu's Avatar
    Join Date
    Sep 2002
    Location
    Saskatoon, Saskatchewan
    Posts
    16,994
    Thanks
    4
    Thanked 2,662 Times in 2,631 Posts
    Is this in a function or class? Globalizing doesn't make sense if its in a main scope (and you should avoid global unless you cannot modify a signature).
    Where are the variables for this coming from: <li><?php global $user_ID, $user_identity, $user_level ?></li>? Perhaps you are relying on register_globals being on (which is now officially gone from PHP), which means you need to extract those variables from something.


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •