Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 2 of 2
  1. #1
    Regular Coder Bengal313's Avatar
    Join Date
    Jun 2002
    Location
    Metro Detroit
    Posts
    298
    Thanks
    8
    Thanked 0 Times in 0 Posts

    Connecting to oracle 9i using php

    I am using php 4.3.2, apache 2, oracle 9i, and everything is running on linux Suse. I created a connection to oracle using php and the connection wizard in dreamweaver mx. I got the connection to work using php-adodb server model. But I am getting a weird problem. After I get the connection to create successfully, and create a recordset, after a few minutes the connection fails. It seems that apache hangs up the connection or something. I have to go into apache 2.0 and restart it. Them it comes back again. And the same thing happens again. Any thoughts.
    Last edited by Bengal313; 11-03-2003 at 08:18 PM.
    "Knowledge Speaks But Wisdom Listens"

  • #2
    New Coder
    Join Date
    Feb 2006
    Posts
    15
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hi Bengal313,
    How r u connecting to the oracle through php and adodb. I am myself connecting to remote oracle with the following code. Can you tell me what's going wrong. I am not being able to connect to the oracle.

    Code:
    $DSN="oci8://".USERNAME.":".PASSWORD."@".HOST."/".SID;
    $DB=NewADOConnection($DSN);
    $DB->debug = 1;
    Then I am using this code:
    Code:
    $res	=	$DB->Execute($sql) or die($DB->ErrorMsg());
    It is showing error:
    Fatal error: Call to undefined method stdClass::Execute()

    I would be greatly obliged if you can share me some light on this...

    Thanks in advance,
    Always blame on me..


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •