Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 7 of 7
  1. #1
    New Coder
    Join Date
    Oct 2012
    Posts
    10
    Thanks
    2
    Thanked 0 Times in 0 Posts

    PHP error when sending emails

    Hello,

    I have installed email script on a server but when i try to send emails i am receiving this error:

    Fatal error: require_once() [function.require]: Failed opening required '/srv/disk11/1171009/www/mydomain.com/inter/admin/functions/api/module_factory.php' (include_path='.:/usr/local/php5/share/pear') in /srv/disk11/1171009/www/mydomain.com/inter/admin/functions/api/module_trackerfactory.php on line 17

    Does anyone have an idea what this error could mean?

    Thanks!

  • #2
    New to the CF scene
    Join Date
    Oct 2012
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    see the module_factory.php in line 17

  • #3
    New Coder
    Join Date
    Oct 2012
    Posts
    10
    Thanks
    2
    Thanked 0 Times in 0 Posts
    This is the code in line 17 for module_factory.php

    Code:
    require_once(dirname(__FILE__) . '/api.php');



    and this is the code in line 17 for module_trackerfactory.php

    Code:
    require_once(dirname(__FILE__) . '/module_factory.php');



    I think it is a server related issue but i am not sure what exactly is the problem.
    Last edited by peter089; 10-26-2012 at 05:04 PM.

  • #4
    New Coder
    Join Date
    Oct 2012
    Posts
    10
    Thanks
    2
    Thanked 0 Times in 0 Posts
    anyone?

  • #5
    Senior Coder
    Join Date
    Feb 2011
    Location
    Your Monitor
    Posts
    4,474
    Thanks
    63
    Thanked 537 Times in 524 Posts
    It sounds like the file its looking for isn't there.

    Have you even looked to see if it is?
    I can't really think of anything to write here now...

  • #6
    New Coder
    Join Date
    Oct 2012
    Posts
    10
    Thanks
    2
    Thanked 0 Times in 0 Posts
    Yes, that was the problem. I uploaded the files with Filezila but it didn't notify me for any unsuccessfully uploaded files.

  • #7
    Senior Coder
    Join Date
    Feb 2011
    Location
    Your Monitor
    Posts
    4,474
    Thanks
    63
    Thanked 537 Times in 524 Posts
    That would be why is said this then:

    Quote Originally Posted by peter089 View Post
    Fatal error: require_once() [function.require]: Failed opening required '/srv/disk11/1171009/www/mydomain.com/inter/admin/functions/api/module_factory.php' (include_path='.:/usr/local/php5/share/pear') in /srv/disk11/1171009/www/mydomain.com/inter/admin/functions/api/module_trackerfactory.php on line 17
    I can't really think of anything to write here now...


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •