Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 6 of 6

Thread: cURL WONT WORK

  1. #1
    New Coder
    Join Date
    Aug 2011
    Posts
    14
    Thanks
    1
    Thanked 0 Times in 0 Posts

    cURL WONT WORK

    I have been at this for days. I can not get even the simplest of cURL scripts to work. I am on hostmonster.com and they have curl enabled.

    curl information = libcurl/7.21.7 OpenSSL/0.9.8b zlib/1.2.3 libidn/0.6.5

    The tech support employee from hostmosnter I spoke with said he uses curl on the server daily.

    Do I have to specify some sort of file path to the curl library? Mine would be /usr/bin/curl if this is the case.

    Please help I'm at my witts end and 3 days past a deadline.

    Thanks,

  • #2
    Senior Coder
    Join Date
    Jul 2011
    Posts
    1,226
    Thanks
    3
    Thanked 171 Times in 171 Posts
    'Wont work' is such a vague term. Could you elaborate a bit more on what error you're getting?

  • #3
    New Coder
    Join Date
    Aug 2011
    Posts
    14
    Thanks
    1
    Thanked 0 Times in 0 Posts
    I am getting nothing, no html output when I print_r. Completely blank pages and no insertion into the remote database.

  • #4
    Senior Coder
    Join Date
    Jul 2011
    Posts
    1,226
    Thanks
    3
    Thanked 171 Times in 171 Posts
    And what does your PHP error log say? It could simply be an error further up your code. What is your code?

    Check your error log.

  • #5
    Senior Coder
    Join Date
    Feb 2011
    Location
    Your Monitor
    Posts
    4,341
    Thanks
    60
    Thanked 527 Times in 514 Posts
    Blog Entries
    4
    So what is the code you're using? (posted inside [php] tags naturally)
    See my new CodingForums Blog: http://www.codingforums.com/blogs/tangoforce/

    Many useful explanations and tips including: Cannot modify headers - already sent, The IE if (isset($_POST['submit'])) bug explained, unexpected T_CONSTANT_ENCAPSED_STRING, debugging tips and much more!

  • #6
    New Coder
    Join Date
    Aug 2011
    Posts
    14
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Hey guys, sorry I completely forgot I posted on this forum as well. Here is a link to another forum I posted in. I answered all these questions in correspondence with phphelpme. http://forums.devnetwork.net/viewtopic.php?f=1&t=131196

    Thank you all very much for your help


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •