Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 8 of 8
  1. #1
    New to the CF scene
    Join Date
    Apr 2010
    Location
    Oakland, Ca
    Posts
    4
    Thanks
    2
    Thanked 0 Times in 0 Posts

    My site works in firefox, but not in IE/Chrome/Safari

    Hello, I'm very new to this and I wanted to know if anyone could help me with my site. I just finished my first actual website in a web class at the univ last quarter but finally uploaded to an actual online host and can't figure out why. I assume it's a PHP only because I don't know what else it could be. If anyone could look at my coding and help me out I would greatly appreciate it!

    the URL

    http://www.DSPZO.COM

    remember, it works fine in firefox, but not at all in IE/chrome/safari



    It's hosted through godaddy if that matters at all.

    Thanks guys!

    Also, let me know if this goes somewhere else on the forum.

    PS - I can copy and paste the entire code here but not sure if people want to walk into a thread and see all coding. If there are any specific sections requested let me know, either wise I guess one could just rightclick+view source on the main page
    Last edited by dspbuckle; 04-02-2010 at 04:21 AM.

  • #2
    Senior Coder Len Whistler's Avatar
    Join Date
    Jul 2002
    Location
    Vancouver, BC Canada
    Posts
    1,323
    Thanks
    26
    Thanked 100 Times in 100 Posts
    It's not a PHP issue, the problem is the HTML/CSS. When coding a site you have to check it in all the browsers as you go along. For now the best thing to do is correct one mistake at a time.





    -------
    Leonard Whistler

  • Users who have thanked Len Whistler for this post:

    dspbuckle (04-02-2010)

  • #3
    Regular Coder ajetrumpet's Avatar
    Join Date
    Jul 2009
    Location
    Iowa City, IA
    Posts
    407
    Thanks
    44
    Thanked 5 Times in 5 Posts
    what do you want help with? the site shows up blank. I doubt you will come across anyone here that wants to sift through source code in a browser. However, it looks like the index page is supposed to show a link to a PHP extension of the index page, as this code in the BODY indicates:
    PHP Code:
    <body>
    <
    div id="wrapper">
      <
    div id="banner">
      <
    a href=/index.php><img src=banners/banner01.jpg border=0></a>  
      </
    div
    but if you're wanting help with the PHP code, you have to post it because it doesn't show up behind browsers. It is server side only. It's executed too soon.

  • #4
    New to the CF scene
    Join Date
    Apr 2010
    Location
    Oakland, Ca
    Posts
    4
    Thanks
    2
    Thanked 0 Times in 0 Posts
    yeh it shows up blank in the browsers except for in firefox. So It's a css/html issue then huh?

    damn, where to start. At least that has narrowed it down.

  • #5
    New to the CF scene
    Join Date
    Apr 2010
    Location
    Oakland, Ca
    Posts
    4
    Thanks
    2
    Thanked 0 Times in 0 Posts
    Ok, i've discovered that if I remove the first few lines (the ones in red) that the site actually appears, but with no style.

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml">
    <head>
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
    <title>Delta Sigma Phi - Zeta Omicron Chapter</title>
    <link href="css/lightbox.css" rel="stylesheet" type="text/css" />
    <script type="text/javascript" src="js/prototype.js"></script>
    <script type="text/javascript" src="js/scriptaculous.js?load=effects,builder"></script>
    <script type="text/javascript" src="js/lightbox.js"></script>
    <style type="text/css">

    <!--
    body,td,th {
    font-family: Verdana, Geneva, sans-serif;
    font-size: 10px;
    I guess from here I just go one by one until I find the issue. Those are there because the lightbox code instructions told me to place them there, now I just have to figure out where to go from there

  • #6
    Regular Coder
    Join Date
    Feb 2007
    Location
    London
    Posts
    225
    Thanks
    16
    Thanked 2 Times in 2 Posts
    Put back in all the stuff you highlighted in red, except:

    Code:
    <style type="text/css">
    Then see if the page displays as before (we still expect no formatting of course).

    This will at least narrow the search down even more.

    As others have already said here, it's very likely that the problems you're looking for are in your CSS, although html and CSS are so interdependent that it's probably a bit of both.

    Start by validating the site here:
    http://validator.w3.org/

    Once it's free from all errors, and displaying perfectly in Firefox, then you should move on to getting it working with other browsers.

    As a first port of call, the fact that you're seeing nothing in the browser when the CSS is being displayed is a clue that you can forget about all the 'details' and look at the CSS for your overall structure - the big picture, like divs for headers, columns, and styling on the body tag etc. There must be something strange going on there.

  • #7
    Senior Coder
    Join Date
    Feb 2009
    Location
    Ilkley, West Yorkshire, UK
    Posts
    2,956
    Thanks
    9
    Thanked 727 Times in 721 Posts
    If you view the page in IE7 and use the Developer Toolbar you can see IE isn't seeing the #wrapper div at all. That's because of this open comment line in your css:

    Code:
    <style type="text/css">
    <!--
    body,td,th {
    	font-family: Verdana, Geneva, sans-serif;
    	font-size: 10px;
    	color: #FFF;
    Delete that and the page appears in IE. Then work your way through the validation errors as cfructose suggests.

  • Users who have thanked SB65 for this post:

    dspbuckle (04-16-2010)

  • #8
    New to the CF scene
    Join Date
    Apr 2010
    Location
    Oakland, Ca
    Posts
    4
    Thanks
    2
    Thanked 0 Times in 0 Posts
    ^sir! Thank you so much! I owe you a beer!!!


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •