Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 5 of 5
  1. #1
    New Coder
    Join Date
    Apr 2003
    Location
    Canada
    Posts
    21
    Thanks
    0
    Thanked 0 Times in 0 Posts

    SSL problem, I think it's the include php

    My problem is "this page contains secure and unsecure items" (when I load my index.php page under https://www.mysite.com/index.php)
    Everything is fine in firefox and opera, IE is the problem.
    If I click view/privacy report in IE6 it lists one of my graphics, and the name of the page itself. The graphic has an https link to it, so why it is showing up in the privacy report at all I don't know.
    But on the page itself, (which is index.php) I have a php include ("sig.php") statement (in the same directory) which is a form with no graphics, but it does have javascript form validation. I have realized I cannot put the full address here as in include ("https://www.mysite.com/sig.php")
    So is there a way I can reference this as a sercure ssl page? or would it need to be?
    Thanks,
    Tin
    Last edited by TinmanIII; 06-06-2007 at 05:06 AM.

  • #2
    Senior Coder kbluhm's Avatar
    Join Date
    Apr 2007
    Location
    Philadelphia, PA, USA
    Posts
    1,509
    Thanks
    3
    Thanked 258 Times in 254 Posts
    Server-side coding would have nothing to do with this, as it is parsed prior to sending the data as a string to the client. Could you post the link, or the source code itself, so we could check it out?

  • #3
    New Coder
    Join Date
    Apr 2003
    Location
    Canada
    Posts
    21
    Thanks
    0
    Thanked 0 Times in 0 Posts

    unsecure items

    I guess if the php is parsed prior to the client's browser, then I am in the wrong forum since it wouldn't be a PHP problem then.
    Last edited by TinmanIII; 06-07-2007 at 04:04 AM.

  • #4
    New Coder
    Join Date
    Apr 2003
    Location
    Canada
    Posts
    21
    Thanks
    0
    Thanked 0 Times in 0 Posts

    "signature.php" page code

    No need, it is fixed.
    Last edited by TinmanIII; 06-07-2007 at 04:05 AM.

  • #5
    New Coder
    Join Date
    Apr 2003
    Location
    Canada
    Posts
    21
    Thanks
    0
    Thanked 0 Times in 0 Posts

    It's the flash

    I took the flash header out and this was my problem, can anyone explain why?
    Thanks,
    Tin


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •