Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 2 of 2
  1. #1
    New to the CF scene
    Join Date
    Jun 2011
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    cgi form working in safari and chrome but error message in ff and ie

    I am having trouble with the bformmail code. It appears to work in safari and chrome but I get an error msg in ff and ie. Could anyone help me out please this is killing me. error msg & code below. thanks in advance.

    Tom

    error msg -

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, webmaster@allstore.com.au and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.


    code -

    [code]<form id="form1" name="form1" action="../cgi-bin/BFormMail.pl" method="post" enctype="text/plain">

    <input type="hidden" name="subject" value="Storage Inquiry - allstore.com.au">
    <input type="hidden" name="recipient" value="info@allstore.com.au">
    <input type="hidden" name="required" value="realname,email,inquiry,list">
    <input type="hidden" name="sort" value="order:realname,email,phone,list,inquiry">
    <input type="hidden" name="env_report" value="REMOTE_HOST,HTTP_USER_AGENT">
    <input type="hidden" name="print_config" value="subject,realname,email">
    <input type="hidden" name="title" value="Thank You!">
    <input type="hidden" name="return_link_url" value="http://www.allstore.com.au">
    <input type="hidden" name="return_link_title" value="Back to Home Page">
    <input type="hidden" name="background" value="/images/backgrnd.jpg">[code]

  • #2
    Master Coder
    Join Date
    Apr 2003
    Location
    in my house
    Posts
    5,211
    Thanks
    39
    Thanked 201 Times in 197 Posts
    Unfortunately that code is just html and not perl. It seems either to be the perl scripting causing the error or your file permissions are set incorrectly.

    This link gives you a link to a better formmail script.

    http://www.codingforums.com/showpost...35&postcount=2

    bazz
    "The day you stop learning is the day you become obsolete"! - my late Dad.

    Why do some people say "I don't know for sure"? If they don't know for sure then, they don't know!
    Useful MySQL resource
    Useful MySQL link


  •  

    Tags for this Thread

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •