Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 5 of 5
  1. #1
    New to the CF scene
    Join Date
    Sep 2012
    Posts
    4
    Thanks
    1
    Thanked 0 Times in 0 Posts

    "identical" only one works.

    http://www.zootgeist.com/allhouston/wc1.htm

    http://www.zootgeist.com/allhouston/wc2.htm

    I copied #2 from #1, and, I thought, only changed the image names.
    I know my code is amateurish, and I know #2 has 23 items in array but only 19 are linked. But #2 works fine!?

    I am hoping someone will note - by viewing source code, the GLARING mistake I haven't seen in 2 days.

    Thanks.

  • #2
    Senior Coder
    Join Date
    Apr 2011
    Location
    London, England
    Posts
    2,120
    Thanks
    15
    Thanked 354 Times in 353 Posts
    See screenshot. I haven't looked beyond this error.

    You should also validate your HTML.
    Attached Thumbnails Attached Thumbnails "identical" only one works.-error1.png  
    "I'm here to save your life. But if I'm going to do that, I'll need total uninanonynymity." Me Myself & Irene.
    Validate your HTML and CSS

  • #3
    Supreme Master coder! Old Pedant's Avatar
    Join Date
    Feb 2009
    Posts
    25,986
    Thanks
    79
    Thanked 4,432 Times in 4,397 Posts
    I give up. What is your question?

    And what does "only 19 are linked" mean?

    And the two pages do *NOT* look the same. wc2 has 4 images slopping over outside the boundaries. wc1 does not.

    And wc1 doesn't work right, in any case. Click on some of the images and the wrong large image shows up (right one shows of for others).
    An optimist sees the glass as half full.
    A pessimist sees the glass as half empty.
    A realist drinks it no matter how much there is.

  • #4
    New to the CF scene
    Join Date
    Sep 2012
    Posts
    4
    Thanks
    1
    Thanked 0 Times in 0 Posts
    I apologize for presenting you with such a mess.
    I have cleaned up the distractions.
    I am using Dreamweaver MX 2004 - and both pages show no html errors.
    My question was;
    One page will show an image when a thumbnail is clicked, whether they match - a larger image will appear. That is on wc1.htm
    On wc2.htm, not picture appears at all.


    thanks for your help. It is appreciated.

  • #5
    Supreme Master coder! Old Pedant's Avatar
    Join Date
    Feb 2009
    Posts
    25,986
    Thanks
    79
    Thanked 4,432 Times in 4,397 Posts
    Okay, for starters, don't believe anything NightmareStalker (the correct name for DreamWeaver, most agree) tells you about JavaScript. And certainly never trust it to write JS code for you.

    That having been said, the best thing you can do for yourself is learn to use a JavaScript debugger. I am (mildly) partial to the one in Chrome. It has a few niceties that MSIE and FireBug for FireFox don't have.

    Try it sometime. Bring up your page in Chrome, hit the F12 key, and then explore.

    In the meantime, I took my own advice. And the problem is obvious. As Chrome reports:
    Failed to load resource: the server responded with a status of 404 (Not Found) http://www.zootgeist.com/allhouston/...pg/21_4RJ7.png
    Failed to load resource: the server responded with a status of 404 (Not Found) http://www.zootgeist.com/allhouston/...g/22_5WHWC.png
    Failed to load resource: the server responded with a status of 404 (Not Found) http://www.zootgeist.com/allhouston/...pg/23_b206.png
    Failed to load resource: the server responded with a status of 404 (Not Found) http://www.zootgeist.com/allhouston/...owloffruit.png
    Failed to load resource: the server responded with a status of 404 (Not Found) http://www.zootgeist.com/allhouston/...25_bwstudy.png
    Failed to load resource: the server responded with a status of 404 (Not Found) http://www.zootgeist.com/allhouston/...26_church1.png
    Failed to load resource: the server responded with a status of 404 (Not Found) http://www.zootgeist.com/allhouston/..._coffeecup.png
    Failed to load resource: the server responded with a status of 404 (Not Found) http://www.zootgeist.com/allhouston/...8_coffeet2.png
    Failed to load resource: the server responded with a status of 404 (Not Found) http://www.zootgeist.com/allhouston/...eamRouleau.png
    Failed to load resource: the server responded with a status of 404 (Not Found) http://www.zootgeist.com/allhouston/.../30_forest.png
    Failed to load resource: the server responded with a status of 404 (Not Found) http://www.zootgeist.com/allhouston/...useandtree.png
    Failed to load resource: the server responded with a status of 404 (Not Found) http://www.zootgeist.com/allhouston/..._landscape.png
    Failed to load resource: the server responded with a status of 404 (Not Found) http://www.zootgeist.com/allhouston/...landscape2.png
    Failed to load resource: the server responded with a status of 404 (Not Found) http://www.zootgeist.com/allhouston/...4_Luseland.png
    Failed to load resource: the server responded with a status of 404 (Not Found) http://www.zootgeist.com/allhouston/...5_palesilo.png
    Failed to load resource: the server responded with a status of 404 (Not Found) http://www.zootgeist.com/allhouston/..._redchurch.png
    Failed to load resource: the server responded with a status of 404 (Not Found) http://www.zootgeist.com/allhouston/...7_redtrees.png
    Failed to load resource: the server responded with a status of 404 (Not Found) http://www.zootgeist.com/allhouston/..._redtrees2.png
    Failed to load resource: the server responded with a status of 404 (Not Found) http://www.zootgeist.com/allhouston/...hinesecamp.png
    Failed to load resource: the server responded with a status of 404 (Not Found) http://www.zootgeist.com/allhouston/..._study0904.png
    Failed to load resource: the server responded with a status of 404 (Not Found) http://www.zootgeist.com/allhouston/..._teaandcup.png
    Failed to load resource: the server responded with a status of 404 (Not Found) http://www.zootgeist.com/allhouston/.../42_teaset.png
    Failed to load resource: the server responded with a status of 404 (Not Found) http://www.zootgeist.com/allhouston/.../43_tncup2.png

    In other words, NOT ONE SINGLE ONE of your larger images can be *FOUND*!

    Go ahead. Try it youself. Just hit the uRLs. SUch as
    http://www.zootgeist.com/allhouston/...pg/21_4RJ7.png

    Did you forget to upload those images to your server?
    An optimist sees the glass as half full.
    A pessimist sees the glass as half empty.
    A realist drinks it no matter how much there is.


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •