Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 7 of 7
  1. #1
    New Coder
    Join Date
    Feb 2006
    Posts
    44
    Thanks
    2
    Thanked 0 Times in 0 Posts

    Script not showing up in some browsers

    Not sure if I'm in the right category, apologies if I am not..

    I have a small flash/javascript streaming mp3 player on my site that works fine in Chrome and Safari, but doesn't show up at all in Firefox, IE, or Opera.

    the site is here: www.thehordeandtheharem.com/index2.html

    the player is in the top left corner. I don't even know where to begin troubleshooting this as I didn't write the player myself, but copied it from another site. If anyone could shed any light on this for me I would be very grateful, thanks!

  • #2
    Senior Coder xelawho's Avatar
    Join Date
    Nov 2010
    Posts
    2,983
    Thanks
    56
    Thanked 557 Times in 554 Posts
    I get an error:
    "hyj is not defined"

    and I can't see why you have that hyj there on line 23 - have you tried removing it?

  • Users who have thanked xelawho for this post:

    devonrs (01-05-2012)

  • #3
    New Coder
    Join Date
    Feb 2006
    Posts
    44
    Thanks
    2
    Thanked 0 Times in 0 Posts
    not sure what you're talking about.. i don't see hyj anywhere?

  • #4
    Supreme Master coder! Philip M's Avatar
    Join Date
    Jun 2002
    Location
    London, England
    Posts
    18,146
    Thanks
    203
    Thanked 2,547 Times in 2,525 Posts
    Quote Originally Posted by devonrs View Post
    not sure what you're talking about.. i don't see hyj anywhere?
    Use your error console.

    22 }
    23 hyj
    24 Array.prototype.remove = function (element) {

    I am surprised that it shows up in any browser.

    All the code given in this post has been tested and is intended to address the question asked.
    Unless stated otherwise it is not just a demonstration.

  • Users who have thanked Philip M for this post:

    devonrs (01-05-2012)

  • #5
    New Coder
    Join Date
    Feb 2006
    Posts
    44
    Thanks
    2
    Thanked 0 Times in 0 Posts
    ah, got it.. okay removed those lines, and am trying to clean up other errors from the console.. still no dice on the mp3 player though..

  • #6
    New Coder
    Join Date
    Feb 2006
    Posts
    44
    Thanks
    2
    Thanked 0 Times in 0 Posts
    digging further i saw that their was a display:none tag on the CSS element, I removed that and now the buttons show up but the songs don't show up (unless you press "next" then the titles show up but they still won't play) - I don't know where to go from here or why it was set to display:none and yet still displayed in some browsers - also, the site that i copied this player from (mumfordandsons.com) has the CSS set the same (display:none) and it shows and plays just fine on all browsers - clearly I'm missing something else here but I can't figure out what.. anybody?

    thanks!
    jack

  • #7
    New Coder
    Join Date
    Feb 2006
    Posts
    44
    Thanks
    2
    Thanked 0 Times in 0 Posts
    To make troubleshooting this easier I created a stripped down page with only the player and it's related CSS and javascript files - nothing else. There are no errors reported by the console and it works fine with Chrome and Safari, but only shows the buttons in other browsers and doesn't play the songs. Here's the test page:

    http://thehordeandtheharem.com/test/

    no idea where to go from here though.. thanks in advance for your help! jack


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •