Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 3 of 3
  1. #1
    New to the CF scene
    Join Date
    Jun 2003
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Question IE and Netscape Compatability Problem (slide show time interval)

    I am using a Javascript slideshow to rotate images, and the rotation works great in IE 5 and greater, however the rotation goes bizurk (to fast) with NetScape 7. Not sure about earlier versions of nestscape. I tried messing around with the time interval without luck.

    Does anyone know of a workaround ?

    My code is attached.

    btw: i isolated the script on a page all by itself, and the problesm still persists; so the problem appears to be in the js code.
    Attached Files Attached Files
    Last edited by marko37; 06-14-2003 at 10:48 PM.

  • #2
    Regular Coder
    Join Date
    Aug 2002
    Location
    Silicon Valley, CA
    Posts
    980
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Well, I noticed that this:
    Code:
    runit=setInterval("slideit()",interval)
    get run once too many times. It's called when the page loads (as an interval) and again when links are clicked (as an interval). This is probably your issue. It's on line 349.

  • #3
    New to the CF scene
    Join Date
    Jun 2003
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thanks for catching that error. Unfortunatly I removed the extreneous line of code, and still observe the same dismal high speed slide show when using NS6 and NS7. If you have any other thoughts regarding this problem please let me know.

    And...Thanks again for all of your help !


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •