Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 6 of 6
  1. #1
    New to the CF scene
    Join Date
    Jul 2010
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts

    BackBox Will Not Open in IE

    Hi i am designing a site for my cross country team, it can be seen here..

    http://craterxc.angelfire.com/

    If you click the photos link you will see one image on the page.. when you click it it is supposed to open the backbox image viewer which i got from..

    http://javascriptkit.com/script/script2/backbox/

    If you are using IE you will notice instead of opening the image viewer it opens a new page with a larger version of the original picture. All other browsers work correctly and open the backbox image viewer..

    Please help me figure out why this does not work in IE as i've searched for an answer for a few days now and have had no luck! Thanks

  • #2
    Supreme Master coder! Old Pedant's Avatar
    Join Date
    Feb 2009
    Posts
    27,700
    Thanks
    80
    Thanked 4,658 Times in 4,620 Posts
    Pure guess: One or more of the other <script>s on the page are interfering with the slideshow code.

    Try (temporarily) removing all the other <script ... src=xxx> tags.

    Ahhh...but of course some of that is from your free web host, no doubt!

    Try paying for hosting and see if the problem goes away?

    Or what happens if you simply try this on your own local computer, not on the host?
    An optimist sees the glass as half full.
    A pessimist sees the glass as half empty.
    A realist drinks it no matter how much there is.

  • #3
    New to the CF scene
    Join Date
    Jul 2010
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts
    You know you could have something there.. because i HAVE tried it on my own computer in IE and it works just fine.

    Unfortunately i have to use the free hosting until school starts up again, when i can talk to my web design teacher about uploading the site to the schools server.. also we have a current site but its crappy so i'm in the process of getting ahold of the old domain name from the lady who designed the outdated site. Thanks for the insight

  • #4
    New to the CF scene
    Join Date
    Jul 2010
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Here is a copy of what the angelfire site added to the code.. which cannot be removed. Red is part of my code, blue is what angelfire added

    <body><script type="text/javascript" src="http://hb.lycos.com/hb.js"></script>
    <script type="text/javascript" src="http://ratings.lycos.com/ratings/lycosRating.js.php"></script>
    <script type="text/javascript"><!--//--><![CDATA[//><!--
    var cm_role = "live";
    var cm_host = "angelfire.lycos.com";
    var cm_taxid = "/memberembedded";
    var angelfire_member_name = "craterxc";
    var angelfire_member_page = "craterxc/photos.html";
    var angelfire_ratings_hash = "1279172109:c06a465e2d05a6a42c72e666d65fa2da";

    var lycos_ad_category = null;

    var lycos_ad_remote_addr = "96.39.160.53";
    var lycos_ad_www_server = "www.angelfire.lycos.com";
    var edit_site_url = "www.angelfire.lycos.com/landing/landing.tmpl?utm_source=house&utm_medium=landingpage&utm_campaign=toolbarlink";
    var lycos_ad_track_small = "http://www.angelfire.com/doc/images/track/ot_smallframe.gif?rand=972539";
    var lycos_ad_track_served = "http://www.angelfire.com/doc/images/track/ot_adserved.gif?rand=972539";
    //--><!]]></script>
    <script type="text/javascript" src="http://scripts.lycos.com/catman/init.js"></script>
    <script type="text/javascript" src="http://www.angelfire.com/sys/ad/code-start.js"></script>
    <script type="text/javascript" src="http://www.angelfire.com/sys/ad/code-middle.js"></script>
    <script type="text/javascript" src="http://www.angelfire.com/sys/ad/code-end.js"></script>
    <noscript>
    <img src="http://www.angelfire.com/doc/images/track/ot_noscript.gif?rand=972539" alt="" width="1" height="1" />
    <!-- BEGIN STANDARD TAG - 728 x 90 - Lycos - Angelfire Fallthrough - DO NOT MODIFY -->
    <iframe frameborder="0" marginwidth="0" marginheight="0" scrolling="no" width="728" height="90" src="http://ad.yieldmanager.com/st?ad_type=iframe&ad_size=728x90&section=280303"></iframe>
    <!-- END TAG -->
    </noscript>

    <div class="header" align="center"><!-- end .header --><a href="index.html"><img src="images/xcheader.gif" width="965" height="100" alt="Crater XC Home" /></a></div>

  • #5
    Supreme Master coder! Old Pedant's Avatar
    Join Date
    Feb 2009
    Posts
    27,700
    Thanks
    80
    Thanked 4,658 Times in 4,620 Posts
    You know, you can get paid sites for as little as $3 a month. If you could get everybody on the team to kick in 25 cents of 50 cents a month, you could avoid the hassle.

    Anyway, I'd sure bet on some of that Anglefire code interfering. The way you attach event handlers (including window.load handlers) is different between MSIE and all other browsers, and I would bet that's the culprit.
    An optimist sees the glass as half full.
    A pessimist sees the glass as half empty.
    A realist drinks it no matter how much there is.

  • #6
    New to the CF scene
    Join Date
    Jul 2010
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Well thanks for the help any how! At least i know why its not working now


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •