Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 4 of 4
  1. #1
    New to the CF scene
    Join Date
    Dec 2009
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Cross Browser Issue?

    Hello all,

    I've got a cross browser issue with two javascript codes I'm using within a website: http://www.thewursteditions.com

    Someone just pointed out today that they don't see my gallery (galleria javascript) nor my rollover on the size guide.

    The site works great on the iphone, firefox, and safari, but not in Internet Explorer.

    I really have no idea what the issue could be as I don't do this too often but I would greatly appreciate any of your help!

    Thanks

  • #2
    Supreme Master coder! Old Pedant's Avatar
    Join Date
    Feb 2009
    Posts
    25,869
    Thanks
    79
    Thanked 4,421 Times in 4,386 Posts
    MSIE is reporting an error here in your code:

    if(jQuery.browser.msie){var ihistory=$("#jQuery_history")[0];

    THe error is "object required", so apparently $("#jQuery_history") is not a valid object, even though it looks like it is something specifically for MSIE.

    I'm not a jQuery user, so dunno what that is supposed to be doing. I especially don't understand why that code is invoked when you click on one of the images.

    Incidentally, in IE7 at least, the rollover effects on the thumbnails *do* work. After the images load. But the images take *FOREVER* to load. Are you using large images and just force-shrinking them to get the thumbnails??? Please say you aren't doing that.

    [Oh, yeah. You are. No wonder it's slow. Partly MSIE, though, I'm sure.]

    [People really pay $150 for a *shirt*??? I thought my sister was extravagant when she paid that for a cashmere sweater for me. But I can kind of understand that price for cashmere. Wow.]
    An optimist sees the glass as half full.
    A pessimist sees the glass as half empty.
    A realist drinks it no matter how much there is.

  • #3
    Supreme Master coder! Philip M's Avatar
    Join Date
    Jun 2002
    Location
    London, England
    Posts
    18,079
    Thanks
    203
    Thanked 2,542 Times in 2,520 Posts
    Quote Originally Posted by Old Pedant View Post
    y MSIE, though, I'm sure.]

    [People really pay $150 for a *shirt*??? I thought my sister was extravagant when she paid that for a cashmere sweater for me. But I can kind of understand that price for cashmere. Wow.]
    Hand tailored at a small-run factory ..... Edition limited to 45 pieces so you’ll be one of a select few to wear the Wurst.

    Sounds cheap compare with what some idiots might pay! Personally I only wear the best quality of clothing - purchased from charity shops! And my wife also buys expensive clothes - marked down by 90% or more at T.K.Maxx.

  • #4
    New to the CF scene
    Join Date
    Dec 2009
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thanks for the reply and your feedback!

    I should have fixed the variable error now. I tried testing it on IE NetRenderer but it's still not showing the images. Do you see the images in IE yet? Maybe the screen captures before they fade...

    Anyone know why the images wouldn't show up in IE? Ah the joys of web


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •