Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 6 of 6
  1. #1
    New Coder
    Join Date
    Jan 2008
    Posts
    85
    Thanks
    25
    Thanked 0 Times in 0 Posts

    Javascript slideshow only works on Firefox

    Hey guys,

    My problem here is that I recently implemented a javascript slideshow for my page, but it only seems to work on Firefox and not on any other browser (such as IE and Safari).

    Here's the page: http://www.bobbivanstudio.com/work.php

    Could anyone take a peek and see what's going on?

    I'd greatly appreciate the help!

    Cheers,

  • #2
    Gütkodierer
    Join Date
    Apr 2009
    Posts
    2,127
    Thanks
    1
    Thanked 426 Times in 424 Posts
    You have an opening <!-- in your <script> without a closing //-->, and in the next <script> the other way round. This prevents your slideshow from ever being properly defined.

    Add those missing comment delimiters and it will work.

  • Users who have thanked venegal for this post:

    cmxsevenfoldxmc (05-20-2009)

  • #3
    Supreme Master coder! Old Pedant's Avatar
    Join Date
    Feb 2009
    Posts
    26,603
    Thanks
    80
    Thanked 4,500 Times in 4,464 Posts
    Better: Get rid of the nonsense comment junk.

    True, you will need them if you ever run into somebody running MSIE 3 or Netscape 3.

    That will happen when you go back more than 5 years in your time machine.

    (Talk about code that is left over from the dark ages! HOW does that stuff linger around so long???)

  • Users who have thanked Old Pedant for this post:

    cmxsevenfoldxmc (05-20-2009)

  • #4
    New Coder
    Join Date
    Jan 2008
    Posts
    85
    Thanks
    25
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by venegal View Post
    You have an opening <!-- in your <script> without a closing //-->, and in the next <script> the other way round. This prevents your slideshow from ever being properly defined.

    Add those missing comment delimiters and it will work.
    That was exactly what I needed to do!!! Many many thanks! I couldn't believe it was right under my nose! >_<

  • #5
    New Coder
    Join Date
    Jan 2008
    Posts
    85
    Thanks
    25
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by Old Pedant View Post
    Better: Get rid of the nonsense comment junk.

    True, you will need them if you ever run into somebody running MSIE 3 or Netscape 3.

    That will happen when you go back more than 5 years in your time machine.

    (Talk about code that is left over from the dark ages! HOW does that stuff linger around so long???)
    Lmao I'll keep that in mind! True.

  • #6
    Regular Coder
    Join Date
    Mar 2009
    Location
    Portland Oregon
    Posts
    690
    Thanks
    44
    Thanked 63 Times in 62 Posts
    Quote Originally Posted by Old Pedant View Post
    Better: Get rid of the nonsense comment junk.

    True, you will need them if you ever run into somebody running MSIE 3 or Netscape 3.

    That will happen when you go back more than 5 years in your time machine.

    (Talk about code that is left over from the dark ages! HOW does that stuff linger around so long???)
    OMG I laughed so hard I cried


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •