Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 2 of 2
  1. #1
    New to the CF scene
    Join Date
    Mar 2009
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Dropdown Menu Problems

    Hello,

    I've been trying to figure this out for a couple of days now, and I just have no idea why I would be having these problems. (Granted, I hate coding and know next to nothing about it.)

    Anyways, http://www.integralenergy.ca . I'm having problems with the drop down menu. In Firefox, the menu is fine, it works as intended. In IE, the drop down menu goes up instead of down. Would anyone know what is causing this?

    Any help would be greatly appreciated.

    Thanks.
    Mitch.

  • #2
    Supreme Master coder! Old Pedant's Avatar
    Join Date
    Feb 2009
    Posts
    26,603
    Thanks
    80
    Thanked 4,500 Times in 4,464 Posts
    Bigger question is why it works at all on FF.

    Usually, FF is the fussier of the two browsers.

    There are several HTML errors on that page.

    For example:
    -- no <HTML> tag
    -- no </HEAD>
    -- no <BODY>
    -- no such thing as "z-ndex" (it's "z-index")

    And that's just in first few lines.

    Oh...I see...and then later in the code you have not one but *TWO* <body> tags.

    ANd and and and...

    Fix all your HTML problems and *THEN* see if it starts working.

    And if you aren't sure if they are fixed, use an HTML validator.


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •