Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 13 of 13
  1. #1
    Regular Coder
    Join Date
    Feb 2003
    Location
    Brooklyn, New York
    Posts
    149
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Question No Right Click script question:

    Hello out there,
    I'm Mr. Rookie at this web thing, but, I very much so enjoy it. I built the site with Front Page 4.0. I'm trying to use a small script that prevents right clicking on my site. Problem is, when I go to the HTML page and paste the script right under the <head> like I was told, it actually becomes visible on the preview page. I put up a hidden page on the site to try this. This is the link to it so you can see the mess I'm making. Can someone tell me what I'm doing wrong? www.mcd4x4.com/secret.html
    page repaired
    Last edited by MCD4x4; 02-20-2003 at 09:35 PM.
    BrianNY/Rookie

  • #2
    Regular Coder
    Join Date
    Dec 2002
    Location
    a bit west of pittsburgh
    Posts
    236
    Thanks
    1
    Thanked 0 Times in 0 Posts
    ok. are youu sure you put the script in the HTML editor, not the DESIGN editor?

  • #3
    Regular Coder
    Join Date
    Feb 2003
    Location
    Brooklyn, New York
    Posts
    149
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Yes, on the bottom left of Front Page 4.0 there is a tab that says HTML. I clicked that, placed the cursor to the right of <head> in order to move the next line down, then pasted the script there. If you like I can e-mail you what it looked like before and after I messed it up. Thanks.
    BrianNY/Rookie

  • #4
    Senior Coder joh6nn's Avatar
    Join Date
    Jun 2002
    Location
    72° W. 48' 57" , 41° N. 32' 04"
    Posts
    1,887
    Thanks
    0
    Thanked 1 Time in 1 Post
    i'm pretty sure you pasted it into the design part, not the HTML part. try it again. if it still messes up, then we'll try something else.
    bluemood | devedge | devmo | MS Dev Library | WebMonkey | the Guide

    i am a loser geek, crazy with an evil streak,
    yes i do believe there is a violent thing inside of me.

  • #5
    Regular Coder
    Join Date
    Feb 2003
    Location
    Brooklyn, New York
    Posts
    149
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Lightbulb

    Thanks Guys,
    What I was doing was pasting the script in on the HTMP page. I got it right from reading this http://cometzone.cometsystems.com/he.../frontpage.asp
    BrianNY/Rookie

  • #6
    Senior Coder
    Join Date
    Jun 2002
    Location
    Nashua, NH
    Posts
    1,724
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Now that the technical stuff is sorted out, can I ask what is wrong with right click
    Vladdy | KL
    "Working web site is not the one that looks the same on common graphical browsers running on desktop computers, but the one that adequately delivers information regardless of device accessing it"

  • #7
    Regular Coder
    Join Date
    Feb 2003
    Location
    Brooklyn, New York
    Posts
    149
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Vladdy
    Well, the thing is this, I've developed a bunch of modifications for a 1/5 scale gas powered Monster Truck. I put all the info and picture up on my site for everyone to view. I want to water mark all the pictures so when people copy them and send them around, they have the domain name on them. I'm having a problem with photoShop trying to do this. So this will buy me some time. Can you help me with the water marking?
    BrianNY/Rookie

  • #8
    Senior Coder
    Join Date
    Jun 2002
    Location
    near Oswestry
    Posts
    4,508
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Originally posted by MCD4x4
    So this will buy me some time.
    No it won't - it will confuse and frustrate people who use right-click for navigation, while providing no security at all.

    For watermarking in Photoshop you need the Digimarc plugin, which is available at http://www.digimarc.com
    Last edited by brothercake; 02-20-2003 at 05:19 PM.

  • #9
    Regular Coder
    Join Date
    Feb 2003
    Location
    Brooklyn, New York
    Posts
    149
    Thanks
    0
    Thanked 0 Times in 0 Posts
    OK, the water marking on that site is the wrong one, or I'm explaining it wrong. I just want to print, in white lettering on each picture. That way when people take them, the domain name goes with it. When I do it in Front Page 4.0, and you copy the picture, when you paste it, the type is not there. When I type on them in PhotoShop, save it and pull them into Front Page the picture becomes distorted, blurred. I don't know why.
    Last edited by MCD4x4; 02-20-2003 at 05:42 PM.
    BrianNY/Rookie

  • #10
    Regular Coder
    Join Date
    Feb 2003
    Location
    Brooklyn, New York
    Posts
    149
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Can nanyone help me with this?
    BrianNY/Rookie

  • #11
    Senior Coder
    Join Date
    Jun 2002
    Location
    near Oswestry
    Posts
    4,508
    Thanks
    0
    Thanked 0 Times in 0 Posts
    There's a few possibilites

    - is the image on the page the natural size of the image - resizing in HTML can cause distortion (because text in an image is rasterized - can explain what this means if you want); resize in Photoshop, not in HTML.

    - is it a JPG? JPG's compression is not suitable for images of text, because it's not sharp enough; try a gif.

    If it's not either of those things - well, lets see a page where this happens.

  • #12
    Regular Coder
    Join Date
    Feb 2003
    Location
    Brooklyn, New York
    Posts
    149
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thank for helping me. To be more specific, I pulled the .jpg picture into Front Page, re-sized it from 1800x1200 pixels to 775x516. So far, there's no problem. This one is on the site now. When I pull the picture into ADOBE PhotoShop and type on them, then save the picture with the print on it, it becomes a .psd extension on it. Keep in mind I'm only adding type to the picture, not re-sizing it. When I pull that picture into Front Page 4.0 and replace the original one, it becomes distorted. That's what I can't figure out. Can you help? Thanks.
    BrianNY/Rookie

  • #13
    Senior Coder
    Join Date
    Jun 2002
    Location
    near Oswestry
    Posts
    4,508
    Thanks
    0
    Thanked 0 Times in 0 Posts
    When you resize an image in FP, you haven't really changed the dimensions of the actual image file - you've just set different numbers for width and height - the image is still the same size really, and that's why it looks dodgy.

    You should use photoshop to get it to be the actual size you want, then use width and height in FP to *reflect* those values, not set them - *don't* resize the image in design view.

    As for PSD - web browsers can't display PSD files. Use "File > Export to Web" to save it as a GIF (for icons and text) or JPG (for photographs and abstract textures)

    Was that what you wanted to know?
    Last edited by brothercake; 02-22-2003 at 06:32 AM.


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •