Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 7 of 7
  1. #1
    kb1
    kb1 is offline
    New Coder
    Join Date
    Mar 2007
    Posts
    65
    Thanks
    11
    Thanked 0 Times in 0 Posts

    Colors and underline issue- fix?

    Novice coder here - using DW 8

    If you go to

    http://www.enhancedwireless.net/Tech...ortfolio.shtml

    you'll see several underlined blue text links - So I'd like all links text to be the same color blue as the "(71 Countries)" color blue instead of the current bright blue...seems the js code or something is getting in the way of the page properties color blue I've given it, would like to know how to fix...

    Also, the "(71 Countires)" rollover is fine, and though I'd like to keep the underline, I don't want the viewer to be able to click on it,, rather just want an underline to draw attention to the rollover but not link to anything...this is a problem currently, for IE 6/7, onclick takes a person to an image index page, which I never intended.

    Thanks much

    KB

  • #2
    New Coder
    Join Date
    Aug 2006
    Posts
    15
    Thanks
    0
    Thanked 1 Time in 1 Post
    First off, color can be easily fixed. The color on that link is 0a4c89 -or- (10,36,137), so either add that to the CSS, or add it directly to the link with an inline style.

    Secondly, if you don't want people to be able to "click it" can certainly add a hash symbol "#" so that it goes nowhere, or you could even just turn it into plain text with a "title" atrribute. Either way works.

    Hope that helps.

  • Users who have thanked SyntaxError for this post:

    kb1 (09-05-2007)

  • #3
    kb1
    kb1 is offline
    New Coder
    Join Date
    Mar 2007
    Posts
    65
    Thanks
    11
    Thanked 0 Times in 0 Posts
    Very helpful - will try it - thanks

    KB

  • #4
    kb1
    kb1 is offline
    New Coder
    Join Date
    Mar 2007
    Posts
    65
    Thanks
    11
    Thanked 0 Times in 0 Posts
    Almost there - I added a font tag (bit of a hassle) to every link in the body text...looks good now, except the links (excluding "71 Countries") all have a different color brighter blue underline on them, in other words the text blue and the underline blue are 2 diff colors - how'd that happen?

    I do want the underlines there at all times, but only on IE 6/7 are they absent except on hover - why?

    KB
    Last edited by kb1; 09-05-2007 at 02:10 AM.

  • #5
    New Coder
    Join Date
    Aug 2006
    Posts
    15
    Thanks
    0
    Thanked 1 Time in 1 Post
    Looks great. I think you did something with the CSS, but it's working now.

    Glad I could help.

  • #6
    kb1
    kb1 is offline
    New Coder
    Join Date
    Mar 2007
    Posts
    65
    Thanks
    11
    Thanked 0 Times in 0 Posts
    Yes, someone mentioned, as you also did, I should do this in my css (to which I added the a:visited as well...)

    a { color: #0a4c89; text-decoration: underline;}
    a:hover { color: #ff8e09; text-decoration: underline;}
    a:visited {color: #333333; text-decoration: none;}

    Got rid of the font tags, supposedly they're not very good to have, made the "71 countries" a span instead of a dead link, with a note on the page for the viewer to rollover that text, etc.

    So thanks again for your input.

    KB

  • #7
    kb1
    kb1 is offline
    New Coder
    Join Date
    Mar 2007
    Posts
    65
    Thanks
    11
    Thanked 0 Times in 0 Posts
    Actually just got rid of the "visited" css, didn't like it...

    KB


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •