Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 3 of 3
  1. #1
    New to the CF scene
    Join Date
    Jul 2007
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Lightbox 2 Shadow Overlay Help

    Hello
    I am using the Lightbox 2 javascript (available here) for my friend's portfolio: http://www.renewiley.com/art.php, however, after a picture is clicked, the shadow overlay doesn't stretch over the full browser--especially if you scroll down.


    The support from the creator said:
    The shadow overlay doesn't stretch to cover full browser window.
    Remove the default margin and padding from the body tag. Add body{ margin: 0; padding: 0; } to your stylesheet.
    I did that, yet this still didn't fix the problem. Through a series of trial and error, I discovered the Lightbox 2 script works fine when I remove my doctype:
    Code:
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
    "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    Here is the "fixed" example

    How can I make the script work without removing my doctype?

  • #2
    Supreme Master coder! _Aerospace_Eng_'s Avatar
    Join Date
    Dec 2004
    Location
    In a place far, far away...
    Posts
    19,291
    Thanks
    2
    Thanked 1,043 Times in 1,019 Posts
    You don't. Thats one of the main reasons why I am not using Lightbox anymore for my site. I am using thickbox. http://jquery.com/demo/thickbox/

    Its a little less pretty but its still unique and appealing. Ironically the lightbox 2 version does work as expected. The overlay goes the full height of the layout. The only issue now is the image doesn't scroll down as the user does. Thickbox has this feature.

    The overlay also seems to only work properly in Firefox.
    Last edited by _Aerospace_Eng_; 07-19-2007 at 08:40 AM.
    ||||If you are getting paid to do a job, don't ask for help on it!||||

  • #3
    New to the CF scene
    Join Date
    Jul 2007
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thanks for the suggestion! But I think I fixed it--atleast in IE7--using this solution to the problem.


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •