Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 10 of 10
  1. #1
    New Coder
    Join Date
    Jan 2006
    Posts
    88
    Thanks
    4
    Thanked 1 Time in 1 Post

    script not working anymore, conflict?

    Hi there,

    this just appeared to stop working, don't think any changes have been made.

    Nothing is adding to the cart and the "view cart" usually pops up a window so presuming the scripts have just stopped working?

    can anyone help? not sure how you find the conflict

    http://laticsdrivertraining.com/book-lessons-online.php

    Thanks

  • #2
    Senior Coder xelawho's Avatar
    Join Date
    Nov 2010
    Posts
    2,981
    Thanks
    56
    Thanked 557 Times in 554 Posts
    have you checked your error console?
    Uncaught TypeError: Cannot read property 'msie' of undefined jquery.plum.shop.js:34
    Uncaught TypeError: Cannot read property 'msie' of undefined simplemodal.js:64
    Uncaught ReferenceError: TWTR is not defined book-lessons-online.php:302
    Uncaught TypeError: Object [object Object] has no method 'tooltip' book-lessons-online.php:397

  • #3
    New Coder
    Join Date
    Jan 2006
    Posts
    88
    Thanks
    4
    Thanked 1 Time in 1 Post
    I've tested removing the twitter object and tooltip and it still doesn't work. im not sure what the 2 top errors mean?

  • #4
    Senior Coder xelawho's Avatar
    Join Date
    Nov 2010
    Posts
    2,981
    Thanks
    56
    Thanked 557 Times in 554 Posts
    msie is what is returned from the now-removed jQuery browser method if the user is using Internet explorer.

    That method got removed in jQuery 1.9 and being that you include the latest version of jquery, here:
    Code:
    <script type="text/javascript" src="http://code.jquery.com/jquery-latest.min.js"></script>
    your page broke itself, all by itself.

    fun, huh?

    you can do two things: load a pre-1.9 version of jQuery instead, like this:
    Code:
    <script type="text/javascript" src="http://code.jquery.com/jquery-1.8.2.min.js"></script>
    or keep using the latest and provide your own browser-sniffer, like this post talks about

  • #5
    New Coder
    Join Date
    Jan 2006
    Posts
    88
    Thanks
    4
    Thanked 1 Time in 1 Post
    I tried both, using an older version and now that script but neither work. Any ideas?

  • #6
    Senior Coder xelawho's Avatar
    Join Date
    Nov 2010
    Posts
    2,981
    Thanks
    56
    Thanked 557 Times in 554 Posts
    what does your error console say? I assume you are testing on another page because I still see the latest version of jQuery getting loaded

  • #7
    New Coder
    Join Date
    Jan 2006
    Posts
    88
    Thanks
    4
    Thanked 1 Time in 1 Post
    The version you would have seen was instead using that script in the link you sent me, i have changed it to use an old version of jquery now.

    There are no errors other than a warning that twitter widget is soon to be out of date, but removing the twitter widget makes no difference

  • #8
    New Coder
    Join Date
    Jan 2006
    Posts
    88
    Thanks
    4
    Thanked 1 Time in 1 Post
    can anyone help? sorry to bump but it's preventing orders from getting through

  • #9
    New Coder
    Join Date
    Jan 2006
    Posts
    88
    Thanks
    4
    Thanked 1 Time in 1 Post
    Anyone, please??

  • #10
    Senior Coder DanInMa's Avatar
    Join Date
    Nov 2010
    Location
    Salem,Ma
    Posts
    1,577
    Thanks
    13
    Thanked 248 Times in 248 Posts
    I dont see the cause as it appears the events just are not firing. May I suggest you upgrade tot he most recent version of the shopping cart script? http://codecanyon.net/item/plumshop-...ng-cart/427746

    It's 6 bucks and you can probably get support directly from the developer


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •