Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 1 of 1
  1. #1
    Regular Coder
    Join Date
    Aug 2002
    Location
    San Francisco
    Posts
    455
    Thanks
    19
    Thanked 15 Times in 15 Posts

    "soldSign" image toggling instead of loading properly

    I have a lightbox that I built from a tutorial and am currently tweaking. When the user clicks on the thumbnail of an image that has been sold, the image is supposed to open up with a "sold" sign on top. What is happening instead is that it the sold sign is appearing on every other image, whether or not it's sold.

    I've uploaded the experimental HTML file so as not to disrupt the working site:
    http://www.brettkaufman.com/EXP.html. The first three images should NOT show the sign; the rest have the "sold" class.

    And here is the script: www.brettkaufman.com/mfLightbox/js/EXP.js

    I created a variable "linkClass"; it's value gets set on line 53. I added an alert on line 102 just so I could see whether it was updating the linkClass value (it is). I put my IF statement on lines 103-105.

    What is my mistake and how can I fix it?
    Last edited by marilynn.fowler; 11-04-2011 at 02:06 AM.
    Outside of a dog, a book is man's best friend. Inside of a dog it's too dark to read. Groucho Marx


 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •