Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 5 of 5
  1. #1
    New Coder
    Join Date
    Feb 2005
    Posts
    20
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Question Incomplete display of website links column in IE6

    Hi - sometimes when I view my site at http://www.johnmacleanphotography.com/index2.htm in Internet Explorer 6, some of the links at the bottom of the left hand links column don't appear, but refreshing the page brings them up. Try the B&W and Colour links, then refresh to see what I mean (although they don't always fail to show up!).

    The links column sometimes seems to 'cut off' level with the bottom of the two contact strip images on the page, but refreshing always fixes it. Any idea why this should be, and if anything can be done about it? The problem never occurs in any browser except IE.

    Added to which, I've just noticed that doing a mousover of any of the links on the 'Interesting Links' section at http://www.johnmacleanphotography.com/links.htm makes the last two links in the left-hand column disappear, but refreshing the page brings them back!

    Thanks for any help - John
    Last edited by john-22; 10-03-2006 at 11:59 AM. Reason: Additional problem noted.

  • #2
    Senior Coder
    Join Date
    Dec 2004
    Location
    Essex, UK
    Posts
    2,636
    Thanks
    0
    Thanked 0 Times in 0 Posts
    It *could* be the peekaboo bug from what I'm seeing; try giving #leftnav position:relative.

    http://www.positioniseverything.net/.../peekaboo.html

  • #3
    New Coder
    Join Date
    Feb 2005
    Posts
    20
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thanks Mark, I tried that and it does seem to have fixed the problem without affecting other browsers. Below is the adjustment to my stylesheet: I take it this is the correct way to add the line? Thanks again - John

    #leftnav {
    position:relative;
    float:left;
    width:100px;
    margin:30px 10px 0 10px;
    font-size:75%;
    clear:both;
    }

  • #4
    Senior Coder
    Join Date
    Dec 2004
    Location
    Essex, UK
    Posts
    2,636
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Yup that's correct, it seems to be working fine now in IE (the peekaboo bug is a popular one!).

  • #5
    New Coder
    Join Date
    Feb 2005
    Posts
    20
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Many thanks, Mark - you've saved me a lot of aggravation and hair-tearing!


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •