Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 4 of 4
  1. #1
    Regular Coder
    Join Date
    Mar 2005
    Location
    Brighton, UK
    Posts
    117
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Cropped text, IE CSS Bug?

    Hi
    Iíve got a problem in IE where it's cutting off the top of some text, it works perfectly in FF.

    The quotation marks are in spans which are absolutely positioned. If I turn the absolute positioning off they render fine, but thatís no good because I donít want them inline with the text.

    Does anyone have any ideas? I canít post a link because the sites not live yet, but here is the css for the spans, and attached is an image of what it looks like in FF and IE:

    Code:
    blockquote span.mark {
    	color: #ff9900;
    	font-size: 3em;
    	position: absolute;
    	font-family: Arial, Helvetica, sans-serif;
    }
    
    blockquote span.open {
    	top: 20px;
    	left: 10px;
    }
    
    blockquote span.close {
    	bottom: 33px;
    	right: 10px;
    }
    Thanks in advance

    Jack
    Last edited by Jak-S; 05-04-2006 at 10:58 AM.

  • #2
    Regular Coder
    Join Date
    Mar 2005
    Location
    Brighton, UK
    Posts
    117
    Thanks
    0
    Thanked 0 Times in 0 Posts
    OK, so I fixed it, added padding-top to the span.mark:

    Code:
    padding-top: 10px;
    Never seen this bug before, and the fix is a bit bizzare, but it seems to work.

  • #3
    Senior Coder
    Join Date
    Jun 2002
    Location
    The Netherlands, Baarn, Ut.
    Posts
    4,252
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Padding

    The span element is inline and should therefore not apply vertical padding; better use line-height instead (it's possible that IE and FF use different defaults).
    Regards,
    Ronald.
    ronaldvanderwijden.com

  • #4
    Regular Coder
    Join Date
    Mar 2005
    Location
    Brighton, UK
    Posts
    117
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Yeah, but for some reason it did. Also, when i adjusted the line height it had no effect. I would have thought a simple display:block would have fixed it, but no.

    Really weird.


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •