Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 6 of 6
  1. #1
    New to the CF scene
    Join Date
    Jul 2005
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts

    image rollover messed up in IE, OK in FF

    Heya guys, I'm kinda baffled by this...everything's working ok on FF but it screws up the menu on IE. I tried adding "no-repeat" to the images but no change there, as it seems that each image per link is being repeated. Any apparent solutions to this? Your help is greatly appreciated!!!

    Cat

    www.darcywretzky.org/new

    Code:
    /* CSS - coded by Catalina Villegas @ www.unapluma.net and www.darcywretzky.org */
    
    
    
    /* --HTML and BODY Information-- */
    
    body       { 
    	    font-family: verdana; font-size: 10px; 
    	    background: #FFFFFF url("images/header.jpg") no-repeat right top fixed; 
    	    height: 540px; width: 822px;
    	   }
    	    
    /* --Menu and Links-- */
    
    #menu a { position: absolute; text-decoration: none; top: 407px; height: 83px; }
        
    #menu a i { visibility: hidden; }
    
    a#home { background-image: url("images/menu/white/w_home.jpg"); right: 394px; width: 18px; }
    a#info { background-image: url("images/menu/white/w_info.jpg"); right: 412px; width: 14px; }
    a#www { background-image: url("images/menu/white/w_www.jpg"); right: 426px; width: 13px; }
    a#community { background-image: url("images/menu/white/w_community.jpg"); right: 439px; width: 15px; }
    a#gallery { background-image: url("images/menu/white/w_gallery.jpg"); right: 454px; width: 15px; }
    a#darcy { background-image: url("images/menu/white/w_darcy.jpg"); right: 469px; width: 14px; }
    
    a#home:hover { background-image: url("images/menu/color/color_home.jpg");}
    a#info:hover { background-image: url("images/menu/color/color_info.jpg"); }
    a#www:hover { background-image: url("images/menu/color/color_www.jpg");  }
    a#community:hover { background-image: url("images/menu/color/color_community.jpg"); }
    a#gallery:hover { background-image: url("images/menu/color/color_gallery.jpg"); }
    a#darcy:hover { background-image: url("images/menu/color/color_darcy.jpg"); }
    
    a#home:hover,
    a#info:hover, 
    a#www:hover,
    a#community:hover, 
    a#gallery:hover,
    a#darcy:hover { border: none; }
    Last edited by unapluma; 05-02-2006 at 04:59 AM.

  • #2
    Supreme Master coder! _Aerospace_Eng_'s Avatar
    Join Date
    Dec 2004
    Location
    In a place far, far away...
    Posts
    19,291
    Thanks
    2
    Thanked 1,043 Times in 1,019 Posts
    Get rid of this line
    Code:
    <?xml version="1.0" encoding="iso-8859-1"?>
    its messing up IE. Then instead of visiblity:hidden; for your <i> tag use display:none
    Code:
    #menu a i { display: none; }
    ||||If you are getting paid to do a job, don't ask for help on it!||||

  • #3
    New to the CF scene
    Join Date
    Jul 2005
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    oh wow that did the trick! thanks so much. mind explaining to me why this worked? you're good!

  • #4
    New to the CF scene
    Join Date
    Jul 2005
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    okay now i'm noticing something else. in IE the rollovers aren't showing up, and the images seem to be moving when i hover over them. in FF it's perfect.
    do you notice this as well?

  • #5
    Supreme Master coder! _Aerospace_Eng_'s Avatar
    Join Date
    Dec 2004
    Location
    In a place far, far away...
    Posts
    19,291
    Thanks
    2
    Thanked 1,043 Times in 1,019 Posts
    They show up. They just have to load first. I don't recommend using absolute positioning to position them though. Search for flicker free CSS rollovers. Changing it from visibility to display works because visibility still allows the <i> tags to take up space where as display:none; doesn't even display them.
    Last edited by _Aerospace_Eng_; 05-02-2006 at 05:21 AM.
    ||||If you are getting paid to do a job, don't ask for help on it!||||

  • #6
    New to the CF scene
    Join Date
    Jul 2005
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    ok...i added a little preloading script and that solved the problem


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •