Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 6 of 6
  1. #1
    New Coder
    Join Date
    Jun 2004
    Posts
    46
    Thanks
    0
    Thanked 0 Times in 0 Posts

    a few small problems with my site... (debug?)

    hello-

    for a class i am taking, we had to make a website... i already got some answers from you guys for a few problems i had... i've fixed a lot of stuff to make it x-browser, but there are still a few things that have me stumped:

    • why the map image (it's not an image-map by the way ) doesn't show up on the sitemap page
    • why the "top" link won't align right
    • why do the bullets on my main navbar butt up against the text like that
    • why is the content div widened

    btw: i am only referring to firefox on windows xp above... it shows up fine in i.e.

    Thanks...
    site link
    css link
    Last edited by TheRoper; 06-03-2005 at 07:40 PM.

  • #2
    Supreme Master coder! _Aerospace_Eng_'s Avatar
    Join Date
    Dec 2004
    Location
    In a place far, far away...
    Posts
    19,291
    Thanks
    2
    Thanked 1,043 Times in 1,019 Posts
    On your site map page get rid of the display:inlines and use float:left; instead, you image should appear then.

    What top link are you talking about? That one in like the old english letters? It looks fine to me, how should it be?

    The bullets well thats how it is, you can set them to outside or inside, not sure which one will work for you. Either list-style-position:inside; or list-style-position:outside;

    Likely reason for the width of the div is margin and padding count for width as well.

  • #3
    New Coder
    Join Date
    Jun 2004
    Posts
    46
    Thanks
    0
    Thanked 0 Times in 0 Posts
    thanks for the reply aerospace...

    unfortunately, when i use "float: left" on the divs for the sitemap, it ended up looking like this:



    as for the "top" link... sorry, i should've been more specific... i meant the link that jumps you to the top of the page... it says "top" and there's a little arrow, but when i try to align it to the right, it gets cut off as far as the width...

    and as for the bullets, they're not actually bullets, they're background-images set to the li's... but i already fixed that...

    and finally, i assumed the content div was wide because of margin/padding issues, but i can't figure out where i went wrong...

    Code:
    #content {
      text-align: justify;
      margin: auto;
      font-size: 1.25em;
      background-color: #cccccc;
      background-image: url("../images/fade.gif");
      background-repeat: repeat-x;
      border: 2px outset #cc0000;
      padding-top: 20px;
      padding-left: 45px;
      padding-right: 45px;
      padding-bottom: 20px;
      width: 80%;
      }
    any thoughts? thank you... (again, i'm looking at it in firefox on xp... i.e. displays fine... although it is in quirksmode )

    updated site link
    updated css link
    Last edited by TheRoper; 06-03-2005 at 08:43 PM.

  • #4
    Supreme Master coder! _Aerospace_Eng_'s Avatar
    Join Date
    Dec 2004
    Location
    In a place far, far away...
    Posts
    19,291
    Thanks
    2
    Thanked 1,043 Times in 1,019 Posts
    Without actually messing with the code, the float:left worked some what, now you need to clear your menu to clear:both;, and your site map menu to clear:left; and your image to clear:right;

    About the width, lets see if you can understand this, some people don't. Its 80%+padding and margin so your div is 80% width and then some. Remember FF shows you what you code, IE shows you what it thinks you want to see.

  • #5
    New Coder
    Join Date
    Jun 2004
    Posts
    46
    Thanks
    0
    Thanked 0 Times in 0 Posts
    still can't get the site map working (it is a background-image btw, but i suppose it doesn't have to be... and i could just use a table) oh well, don't worry about it, i'll figure it out...

    as for the content div:



    seems to me like the padding should be applied within the div which should stay at 80% width... is that not right? what should i be doing? i thought margins were applied to the outside of the element, and padding set within it?

    thanks again...
    TheRoper

  • #6
    Supreme Master coder! _Aerospace_Eng_'s Avatar
    Join Date
    Dec 2004
    Location
    In a place far, far away...
    Posts
    19,291
    Thanks
    2
    Thanked 1,043 Times in 1,019 Posts
    Okay so margin is applied to the outside yes, but its 80%+padding that makes up the width.


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •