Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 10 of 10
  1. #1
    New to the CF scene
    Join Date
    Feb 2005
    Location
    Cottonwood, MN USA
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Having a problem with an animated image

    I am trying to put an animated image on a screen that is just a pass through to the next screen while there is processing going on in the background. I am using a meta tag...
    [META HTTP-EQUIV="Refresh" CONTENT="0;

    to re-direct to the next screen. I have changed CONTENT="0; to 5 and then my image animates for 5 seconds, but it also delays my processing 5 seconds. Does anyone have any suggestions?

  • #2
    Regular Coder
    Join Date
    Jul 2004
    Location
    mile high city
    Posts
    482
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Welcome sanderk,

    You'll have to provide more context. What kind of processing? What are you trying to acheive?
    Computer, kill Flanders... Did I hear my name? My ears are burning...
    Good start. Now finish the job.

  • #3
    New to the CF scene
    Join Date
    Feb 2005
    Location
    Cottonwood, MN USA
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I am using "Cool-ICE". Which incorporates how we handle our in house database and HTML together.

    At the point where I am having the problem - I have gathered all the information from the user and I am ready to send the info off. The information is actually being sent to out mainframe system for processing and sent back to my screen.

    The screen with the image on it logs the time & date that info was sent and sends the file for processing. This screen displays and automatically redirects to the next screen that waits for the file to come back from processing. Since this process takes 20+ seconds I wanted an animated image to let them know that it is still working, but since it redirects immediately after it displays this screen my image is not animated. I need to something that will allow my image to be animated until the next screen is displayed.

    I have tried adding some javascript to my program:

    [body <DocBgImg> <DocBgClr> <TextClr> <LinkClr> <VLinkClr> <ALinkClr> onload="document.inquiry.submit();"]
    [FORM method=get action="<GUrLcat>summary_screen&CONTROL=<CONTROL>&ssocc=<ssocc>&ssroof=<ssroof>" name="inquiry"]

    My thought here was that once my page loaded it would animate my image and send it to the next screen. It did animate my image, but didn't send me to the next screen.

  • #4
    Supreme Master coder! _Aerospace_Eng_'s Avatar
    Join Date
    Dec 2004
    Location
    In a place far, far away...
    Posts
    19,291
    Thanks
    2
    Thanked 1,043 Times in 1,019 Posts
    have u tried using this as your meta refresh tag?
    Code:
    <meta http-equiv="refresh" content="5;url=http://webdesign.about.com/">

  • #5
    New to the CF scene
    Join Date
    Feb 2005
    Location
    Cottonwood, MN USA
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Yes I have. I forgot to copy that part of my code. This is what I have.

    Code:
    [META HTTP-EQUIV="Refresh" CONTENT="0;URL=https://quote.nstarco.com/cool-ice/default.asp?"]
    Last edited by sanderk; 02-10-2005 at 08:51 PM.

  • #6
    Supreme Master coder! _Aerospace_Eng_'s Avatar
    Join Date
    Dec 2004
    Location
    In a place far, far away...
    Posts
    19,291
    Thanks
    2
    Thanked 1,043 Times in 1,019 Posts
    and where is that meta tag, what language are u coding in?

  • #7
    New to the CF scene
    Join Date
    Feb 2005
    Location
    Cottonwood, MN USA
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I am coding in "cool-ICE" which incorporates HTML with BIS/MAPPER code.

    [HTML]
    [HEAD]
    [TITLE]
    [META HTTP-EQUIV...

  • #8
    Supreme Master coder! _Aerospace_Eng_'s Avatar
    Join Date
    Dec 2004
    Location
    In a place far, far away...
    Posts
    19,291
    Thanks
    2
    Thanked 1,043 Times in 1,019 Posts
    okay so y not set the meta refresh to the length of the processing, and does this image stop animating or what? most animated images loop until the browsers stop button is pressed

  • #9
    New to the CF scene
    Join Date
    Feb 2005
    Location
    Cottonwood, MN USA
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts
    If I set it to a different length it delays my processing by that much more time. The remainder of my processing happens in the next program. And if I move the code from the next program to the current program my image will not be displayed until after it processes instead of while it is processing.

  • #10
    Supreme Master coder! _Aerospace_Eng_'s Avatar
    Join Date
    Dec 2004
    Location
    In a place far, far away...
    Posts
    19,291
    Thanks
    2
    Thanked 1,043 Times in 1,019 Posts
    do u have a link so we can see what is happening? its just starting to go around in circles here back to the beginning we haven't accomplished much


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •