Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 3 of 3
  1. #1
    Senior Coder
    Join Date
    Oct 2003
    Location
    Australia
    Posts
    1,963
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Internet Explorer Having issues w/ <div> BG img CSS

    Hey all,
    I must be missing something really obvious here because I'm going insane trying to get IE to display the background image of an empty div.
    Here's my CSS, it works fine in Moz1.6
    Code:
    #compass{
    height:174px;
    width:173px;
    background:url(images/compass.gif)no-repeat;
    float:left;
    margin-left:-86px;
    margin-top:-85px;
    }
    But whenever I add any other definitions such as position:relative;display:block; it no longer works in Moz either.
    I took too big of a break over Chistmas/New Years, had a bit too much fun and have now forgotten a hell of a lot of basic stuff.

    Please Help
    Cheers,
    Andrew

    I take no responsibility for the above nonsense.


    Left Justified

  • #2
    Regular Coder
    Join Date
    Aug 2003
    Location
    Loughborough University
    Posts
    427
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Could it be because there is no space separating the URL and the no-repeat?

    background:url(images/compass.gif)no-repeat;

    Failing that it could just be that there is something over the top of it with a white background. You got a link to the page with this problem?
    AMD Athlon "Barton" XP 3200+ (11*200.5MHz = 2.2GHz)
    BFG GeForce 6800 Ultra OC 256Mb
    3 * Kingston 256Mb PC3200 DDR400
    Seagate Barracuda 120Gb Ultra ATA-100 and Seagate Barracuda 160Gb, SATA-150

  • #3
    Senior Coder
    Join Date
    Oct 2003
    Location
    Australia
    Posts
    1,963
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thanks for the reply,
    The space was the problem

    I'm still having a problem with the fact that the <div> has a negative left/top margin and IE is cutting off the overflow.
    overflow:visible/auto/etc. aren't fixing it either?

    Any suggestions?

    All the CSS/XHTML is posted in this thread .

    **edit: It DID fix the problem
    Last edited by mindlessLemming; 01-15-2004 at 11:37 AM.

    I take no responsibility for the above nonsense.


    Left Justified


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •