Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 6 of 6
  1. #1
    New to the CF scene
    Join Date
    Jan 2013
    Posts
    3
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Help: website doesn't support most browser

    my website www.SHMcafe.com only support Google chrome, when i use Firefox and others browser the boxs and word are jumping around..

    what is the problem? please advise me thanks

  • #2
    The fat guy next door VIPStephan's Avatar
    Join Date
    Jan 2006
    Location
    Halle (Saale), Germany
    Posts
    8,778
    Thanks
    6
    Thanked 1,021 Times in 994 Posts
    One problem might be your invalid HTML and another one might be your invalid CSS.

  • #3
    New to the CF scene
    Join Date
    Jan 2013
    Posts
    3
    Thanks
    1
    Thanked 0 Times in 0 Posts
    actually i am very new in making website, possible to let me know what is going wrong

  • #4
    Regular Coder
    Join Date
    Sep 2011
    Posts
    341
    Thanks
    3
    Thanked 36 Times in 36 Posts
    Quote Originally Posted by Shunsuke13 View Post
    my website www.SHMcafe.com only support Google chrome, when i use Firefox and others browser the boxs and word are jumping around..
    what is the problem? please advise me thanks
    You have a number of problems, too many for me to correct without charging you. I did write tutorials on CSS positioning and centering, though. See my signature page.
    Frank

    How to: Target IE in, Position in, Center in, Create a Fixed ('Sticky') Footer with, and Create a Drop-Down/Fly-Out Menu with CSS: Website Laten Maken Amsterdam.

  • #5
    Senior Coder jerry62704's Avatar
    Join Date
    Oct 2007
    Location
    Springfield, IL
    Posts
    1,100
    Thanks
    13
    Thanked 87 Times in 87 Posts
    Quote Originally Posted by Shunsuke13 View Post
    my website www.SHMcafe.com only support Google chrome, when i use Firefox and others browser the boxs and word are jumping around..

    what is the problem? please advise me thanks
    Let's take it step by step. Second, go to http://www.w3schools.com/html/html_headings.asp/ and run your page through the free validator. You will find a couple of problems that need to be fixed. Comment in middle of the page below the heading stuff.

    First, fix the comments. The proper format is found here http://validator.w3.org/.

    You have <!----------------------- xxxx ------------------------->

    HTML wants <!-- ------------ xxx ---------------- -->

    A comment starts with and only with <!--. If you add to that such as you did, <!---- then it is not seen as a comment. Ditto for the ending.

    Once you do that about 412 of your 422 error will go away. Of the remaining ones (the ones that are more important), you have two images missing "alt" attribute and the img tag is self closing.

    Wrong: <img xxxxx></img>
    Right: <img xxxxx alt="yyyy" />

    On line 82 you have a reversed closing.

    Wrong: </p<
    Right: </p>
    (this was most likely a simple typo of course.)

    The CSS is invalid as well (but it is REAL close). Check it at vhttp://jigsaw.w3.org/css-validator/validator.

    I see four major errors and a bunch of minor ones.

    HTH
    Last edited by jerry62704; 01-28-2013 at 03:33 PM.
    .
    .
    ...and gladly would he learn and gladly teach

    Visit www.LiberalsWin.com for humor and the unique Bush/Obama Approval Polls

  • Users who have thanked jerry62704 for this post:

    Shunsuke13 (01-28-2013)

  • #6
    New to the CF scene
    Join Date
    Jan 2013
    Posts
    3
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by jerry62704 View Post
    Let's take it step by step. Second, go to http://www.w3schools.com/html/html_headings.asp/ and run your page through the free validator. You will find a couple of problems that need to be fixed. Comment in middle of the page below the heading stuff.

    First, fix the comments. The proper format is found here http://validator.w3.org/.

    You have <!----------------------- xxxx ------------------------->

    HTML wants <!-- ------------ xxx ---------------- -->

    A comment starts with and only with <!--. If you add to that such as you did, <!---- then it is not seen as a comment. Ditto for the ending.

    Once you do that about 412 of your 422 error will go away. Of the remaining ones (the ones that are more important), you have two images missing "alt" attribute and the img tag is self closing.

    Wrong: <img xxxxx></img>
    Right: <img xxxxx alt="yyyy" />

    On line 82 you have a reversed closing.

    Wrong: </p<
    Right: </p>
    (this was most likely a simple typo of course.)

    The CSS is invalid as well (but it is REAL close). Check it at vhttp://jigsaw.w3.org/css-validator/validator.

    I see four major errors and a bunch of minor ones.

    HTH
    really thank you very much for the advise i will take a look at all the problem..
    wish i can treat you drink =)


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •