Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 5 of 5
  1. #1
    Regular Coder
    Join Date
    Aug 2002
    Posts
    152
    Thanks
    5
    Thanked 0 Times in 0 Posts

    CSS Fix for Nivo Slider

    Hello,

    I would appreciate some help me fix the positioning of nivo slider on our site...

    http://tinyurl.com/d3canxw

    thanking you in advance,
    Andy

  • #2
    Master Coder Excavator's Avatar
    Join Date
    Dec 2006
    Location
    Alaska
    Posts
    9,682
    Thanks
    22
    Thanked 1,828 Times in 1,812 Posts
    Hello neodjandre,
    You use relative positioning in many places that it should be absolute. When using either positioning, you need to tell the element where you would like it positioned.
    Look at it this way -
    Code:
    .theme-default .nivoSlider {
        background: url("loading.gif") no-repeat scroll 50% 50% #FFFFFF;
        box-shadow: 0 1px 5px 0 #4A4A4A;
        margin-bottom: 10px;
        position: absolute;
        top: 60px;
        left: 0;
    }
    Validate often DURING development - Use it like a splelchecker | Debug during Development |Write it for FireFox, ignore IE
    Use the right DocType | Validate your markup | Validate your CSS | Why validating is good | Why tables are bad

  • #3
    Regular Coder
    Join Date
    Aug 2002
    Posts
    152
    Thanks
    5
    Thanked 0 Times in 0 Posts
    ok, i have tried that but still doesn't fit.. what's more in Firefox the gap is much wider than Chrome & IE...

    I know i am not that good with CSS.. hopefully we can fix this mess with another hack.

  • #4
    Regular Coder
    Join Date
    Aug 2002
    Posts
    152
    Thanks
    5
    Thanked 0 Times in 0 Posts
    update: used !important and it worked! thanks so much..

    now need to figure out how to remove this yellow border and fully align the slider !

  • #5
    Master Coder Excavator's Avatar
    Join Date
    Dec 2006
    Location
    Alaska
    Posts
    9,682
    Thanks
    22
    Thanked 1,828 Times in 1,812 Posts
    Quote Originally Posted by neodjandre View Post
    update: used !important and it worked! thanks so much..

    now need to figure out how to remove this yellow border and fully align the slider !
    Using !important is just overriding some CSS elsewhere that has more specificity. Instead of using !important, why not find the real cause and remove that? See this article on the use of !important.

    All of those things could be seen and fixed if you used FireBug for FireFox.
    Validate often DURING development - Use it like a splelchecker | Debug during Development |Write it for FireFox, ignore IE
    Use the right DocType | Validate your markup | Validate your CSS | Why validating is good | Why tables are bad


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •