Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 2 of 2
  1. #1
    New to the CF scene
    Join Date
    Oct 2012
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Firefox incompatibility

    Hi all,

    I'm tackling my first proper "HTML" & "CSS" project, coding in Coda 2. The website spr8.wildapricot.org displays properly in Safari and Chrome, but the tables/positioning seem to be shifted in Firefox. As I'm new to this I can't begin to picture what I've done.

    A good problem example page is: http://www.spr8.wildapricot.org/Defa...pageId=1421907

    Any suggestions as to what the problem is? All help is hugely appreciated!

    Example code is below:

    <body bgcolor="#FFFFFF" leftmargin="0" topmargin="0" marginwidth="0" marginheight="0">
    <!-- Save for Web Slices (James Armstrong.psd) -->

    <div id="body">
    <table id="Table_01" width="600" height="1440" border="0" cellpadding="0" cellspacing="0">
    <tr>
    <td width="600" height="15" colspan="5">
    <img src="images/spacer.gif" width="600" height="15" alt=""></td>
    </tr>
    <tr>
    <td width="346" height="104" colspan="2">

    <div class="title">
    James<br>Armstrong
    </div>
    </td>
    <td colspan="3" rowspan="2">
    <img src="images/Logo.gif" width="254" height="141" alt=""></td>
    </tr>
    <tr>
    <td width="346" height="37" colspan="2">
    <div class="title2">
    Australia
    </div>
    </td>
    </tr>
    <tr>
    <td colspan="2">
    <t width="346" height="39" alt="">
    <div class="title2">
    2012 Leavers'
    </div>
    </td>
    <td width="38" height="39" colspan="2">
    <img src="images/spacer.gif" width="38" height="39" alt=""></td>
    <td rowspan="2">
    <img src="images/Pic-1.gif" width="216" height="256" alt=""></td>
    </tr>

  • #2
    Senior Coder
    Join Date
    Jan 2011
    Location
    Missouri
    Posts
    4,306
    Thanks
    23
    Thanked 612 Times in 611 Posts
    Here is a link to the validater with your page that has 36 errors. The doctype seems to be all wrong. Use this one:
    Code:
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
    <head>
    The <html> tag does not need an ID.

    Your divs and the content are separated causing many problems. You should not use tables for lay out. Read this http://upwithabang.com/articles/css-...of-tables.html

    I'd recode the page from the ground up.


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •