Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 3 of 3
  1. #1
    New to the CF scene
    Join Date
    Feb 2012
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Internet Explorer vs. My Site

    Hello everyone,

    I'm a beginner when it comes to programming and I am trying to learn HTML, PHP and Javascript at the moment.

    I have a simple private site that has a photo album which uses HTML and PHP. At the moment, everything works fine in Google Chrome and Firefox.

    But.. when I open my website in Internet Explorer the site is not centered as it should be. I am guessing some code is not compatible with IE but how do I fix this?

    This is the site I am talking about: www.deniali.com

    And while I am at it, how can I make it possible to add videos to the photo gallery? For example; it appears as a thumbnail and when you click it opens like a normal picture but with controls to play/pause the video.

    I appreciate it if someone could kick me in the right direction .


    Thanks!

  • #2
    Supreme Master coder! abduraooft's Avatar
    Join Date
    Mar 2007
    Location
    N/A
    Posts
    14,864
    Thanks
    160
    Thanked 2,224 Times in 2,211 Posts
    The html source of your page begins as follows
    Code:
    <html>
    <head>
    <meta name="description" content="DeniAli - a random collection">
    
    <meta name="keywords" content="deniali,deni,ali,collection,denial,random,photos,lol,9gag,tumblr,private,">
    </head>
    
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    IE turns to quirks mode when it encounters anything before DOCTYPE declaration. So, remove the highlighted portion from your code.

    PS: Make use of validator, when dealing with cross browser issues.
    The Dream is not what you see in sleep; Dream is the thing which doesn't let you sleep. --(Dr. APJ. Abdul Kalam)

  • #3
    New to the CF scene
    Join Date
    Feb 2012
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by abduraooft View Post
    The html source of your page begins as follows
    Code:
    <html>
    <head>
    <meta name="description" content="DeniAli - a random collection">
    
    <meta name="keywords" content="deniali,deni,ali,collection,denial,random,photos,lol,9gag,tumblr,private,">
    </head>
    
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    IE turns to quirks mode when it encounters anything before DOCTYPE declaration. So, remove the highlighted portion from your code.

    PS: Make use of validator, when dealing with cross browser issues.

    Thanks for your reply.

    I removed the line of code from index.php but it has no effect.

    edit: Never mind, it is working now. Thank you very much that was stupid of me!

    Any ideas on my second question would be very much appreciated.
    Last edited by Killfrenzy; 02-11-2012 at 03:11 PM. Reason: First question solved


  •  

    Tags for this Thread

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •