Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 3 of 3
  1. #1
    Regular Coder
    Join Date
    Aug 2009
    Posts
    410
    Thanks
    119
    Thanked 0 Times in 0 Posts

    display:block not working on sub-menu

    on this site when you hover over Events or Leagues in the top navigation bar, you'll see a dropdown menu. That menu is .sub-menu.

    I want the .sub-menu to show, even when not hovering over it, so that I can tinker with the CSS to get the widths correct so I added this css element to try and get it to appear:
    Code:
    .sub-menu {display:block;}
    but for some reason, it's not appearing. how i get it to permanently appear, not just when i hover over it.

    please advise. thanks in advance!
    Last edited by sixrfan; 09-08-2011 at 03:13 PM. Reason: asdf

  • #2
    Regular Coder
    Join Date
    Aug 2011
    Location
    U.S.A.
    Posts
    233
    Thanks
    2
    Thanked 48 Times in 48 Posts
    that's because your not "hiding" the sublinks, your css is moving them off the page. Then on hover, it moves them back on the page. This is your "hiding" code:

    Code:
    #nav ul, #nav .sfhover ul ul, #nav *:hover ul ul {
        left: -9999px;
        position: absolute;
    Change the left: -9999px to be left: 0 and your sublinks will show up (all of them will show up and it will be cluttered, but you can work with them.

  • Users who have thanked resdog for this post:

    sixrfan (09-08-2011)

  • #3
    Regular Coder
    Join Date
    Aug 2009
    Posts
    410
    Thanks
    119
    Thanked 0 Times in 0 Posts
    gotcha. thanks.


  •  

    Tags for this Thread

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •