Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Page 1 of 2 12 LastLast
Results 1 to 15 of 16
  1. #1
    New Coder
    Join Date
    Jul 2011
    Location
    Mexico
    Posts
    16
    Thanks
    10
    Thanked 0 Times in 0 Posts

    " /> showing on top left of homepage

    I messed up my webpage in an attempt to customize my static frontpage and I have part of a code showing at the top left of my homepage:
    " />

    In preview it also shows whatever text I type in a post at my blog in the same place, at the very top, all words are repeated. It repeated the three only words I had at my homepage as well, I deleted those and only that part of the code was left.

    I'm not sure what other info I should post.
    My website is hosted -for free- by a very kind friend that owns a server and he uses Site5.

    I don't know any coding but can follow instructions and would deeply appreciate any help so I could continue blogging and learning how to build my website.

    Thank you very much in advance for taking the time to read this!
    Claudia Liliana / rasamalai
    Last edited by Apostropartheid; 07-24-2011 at 01:51 PM.

  • #2
    The Apostate Apostropartheid's Avatar
    Join Date
    Oct 2007
    Posts
    3,215
    Thanks
    16
    Thanked 265 Times in 263 Posts
    Line 104:
    Code:
    				</script>" />
    Delete the " />.

    I'm afraid we can't be of much help without raw code.

  • Users who have thanked Apostropartheid for this post:

    rasamalai (07-22-2011)

  • #3
    New Coder
    Join Date
    Jul 2011
    Location
    Mexico
    Posts
    16
    Thanks
    10
    Thanked 0 Times in 0 Posts
    I don't know where to delete it from. I thought perhaps I had erased the opening part of the code by mistake and was hoping to restore it. Also because I intend to keep on blogging and as it is right now I can't.

    Could you perhaps suggest me of a place to get help from please?

  • #4
    New Coder
    Join Date
    Jul 2011
    Location
    Kediri - Indonesia
    Posts
    61
    Thanks
    2
    Thanked 19 Times in 19 Posts
    i don't know what this line about:
    Code:
    <meta name="description" content="<div id="fb-root"></div><script src="http://connect.facebook.net/en_US/all.js#appId=20320310172&amp;xfbml=1"></script><script language="JavaScript">
    					FB.Event.subscribe('edge.create', function(response) {
    						_gaq.push(['_trackEvent','SocialSharing','Facebook - like button',unescape(String(response).replace(/\+/g, " "))]);
    					});
    				</script>" />
    you uses any tag (div,script) on content of meta description. is this correct?

    if it is correct, try backslash on any doble quote in meta content.

    Code:
    <meta name="description" content="<div id='fb-root'></div><script src=\"http://connect.facebook.net/en_US/all.js#appId=20320310172&amp;xfbml=1\"></script><script language=\"JavaScript\">
                        FB.Event.subscribe('edge.create', function(response) {
                            _gaq.push(['_trackEvent','SocialSharing','Facebook - like button',unescape(String(response).replace(/\+/g, ' '))]);
                        });
                    </script>" />

    or just replace doble quote with single quote
    Code:
    <meta name="description" content="<div id='fb-root'></div><script src='http://connect.facebook.net/en_US/all.js#appId=20320310172&amp;xfbml=1'></script><script language='JavaScript'>
                        FB.Event.subscribe('edge.create', function(response) {
                            _gaq.push(['_trackEvent','SocialSharing','Facebook - like button',unescape(String(response).replace(/\+/g, ' '))]);
                        });
                    </script>" />
    hope it helps

  • Users who have thanked XterM for this post:

    rasamalai (07-22-2011)

  • #5
    The Apostate Apostropartheid's Avatar
    Join Date
    Oct 2007
    Posts
    3,215
    Thanks
    16
    Thanked 265 Times in 263 Posts
    Quote Originally Posted by rasamalai View Post
    I don't know where to delete it from. I thought perhaps I had erased the opening part of the code by mistake and was hoping to restore it. Also because I intend to keep on blogging and as it is right now I can't.

    Could you perhaps suggest me of a place to get help from please?
    You could pay somebody who would access your server and do it.

    But I wouldn't want you to spend money; if you paste the template files here (especially anything with the name "Index", "Main" or "Head" in it), I'll try my best.

  • Users who have thanked Apostropartheid for this post:

    rasamalai (07-22-2011)

  • #6
    New Coder
    Join Date
    Jul 2011
    Location
    Mexico
    Posts
    16
    Thanks
    10
    Thanked 0 Times in 0 Posts
    Thank you so very much! Honestly I can't afford to pay for outside help. It's taken me a year to get this far and I still am pretty ignorant.

    @XterM Did you get that code from right clicking on the homepage? That is so neat!
    I feel so ignorant looking at those codes and understanding nothing!
    I try my best not to touch them and try to stick to wordpress plugins. I did recently add a description to the Meta, but it was in wordpress dashboard so I didn't touch any code for that.

    I attempted to add a code to get an excerpt from the first post on the blog at the homepage but I couldn't figure out where to add it. Unfortunately I did try a few places and I'm afraid I might have deleted or misplaced part of a code that I swear I was very careful not to touch. That was done at wordpress dashboard as well on the Theme editor.

    @Apostropartheid:
    I'm not sure if I've wrapped the code right.
    Thank you so so much for looking at this!:
    Index.php
    Code:
    index.php 
    PHP script text
    <?php
    /**
     * Front to the WordPress application. This file doesn't do anything, but loads
     * wp-blog-header.php which does and tells WordPress to load the theme.
     *
     * @package WordPress
     */
    
    /**
     * Tells WordPress to load the WordPress theme and output it.
     *
     * @var bool
     */
    define('WP_USE_THEMES', true);
    
    /** Loads the WordPress Environment and Template */
    require('./wp-blog-header.php');
    ?>
    wp-blog-header.php
    Code:
     wp-blog-header.php 
    PHP script text
    <?php
    /**
     * Loads the WordPress environment and template.
     *
     * @package WordPress
     */
    
    if ( !isset($wp_did_header) ) {
    
    	$wp_did_header = true;
    
    	require_once( dirname(__FILE__) . '/wp-load.php' );
    
    	wp();
    
    	require_once( ABSPATH . WPINC . '/template-loader.php' );
    
    }
    
    ?>
    These are from the template editor:
    Code:
    <?php
    
        // calling the header.php
        get_header(); 
    
    ?> 
    
    <!-- generated with index.php -->
    
    	<div id="content">
    		<div class="notable">	
    		<!-- begin post -->
    
    		<?php 	
    		if (! empty($display_stats) ) { get_stats(1); echo "<br />"; };
    	 	if (($posts & empty($display_stats)) ) {
    	 	while ( have_posts() ) {
    	 		the_post();
    	  	?>   
    		
    		<div class="entry <?php $cat = get_the_category(); $cat = $cat[0]; echo $cat->category_nicename; ?> notable-post">
    			<div id="post-<?php the_ID(); ?>" <?php post_class(); ?>>
    	 			<!--POST TITLE-->		
    				<h2 class="post-title"><a title="'<?php the_title_attribute(); ?>', posted on <?php the_time('F jS, Y') ?>" href="<?php the_permalink() ?>"><?php the_title(''); ?></a></h2> 
    				<!--END POST TITLE-->
    
    				<h4 class="notable-date"><a href="<?php the_permalink() ?>"><?php the_date('F d, Y', '', ''); ?></a></h4>
    				<?php the_content('continue...'); ?>  
    				
    				<?php wp_link_pages(array('before' => '<p class="link_pages"><strong>Pages:</strong> ', 'after' => '</p>', 'next_or_number' => 'number'));  ?>
    				
    			</div> <!-- #post-id --> 
    			
    			<h5><?php comments_popup_link(__('Comments (0)'), __('Comments (1)'), __('Comments (%)'), __(''), __('')); ?> <?php the_tags('| Tags: ',', ',''); ?> | More: <?php the_category(', '); ?> <?php edit_post_link('edit this', '<span class="edit-link">', '</span>'); ?> <!--USER EDIT LINK--></h5>
    
    		</div> <!-- .category-nicename, .notable-post-->  		    
    		
    <!-- <?php trackback_rdf(); ?> -->    
    <?php }} else{ _e('Sorry, no posts matched your criteria.', 'wpfolio'); }?>    
    
    			<div class="prevnext">
    				<div class="prev"><?php previous_posts_link('Previous') ?></div> 
    				<div class="next"><?php next_posts_link('Next') ?></div>
    			</div><!--.prevnext -->	  
    			
    	</div><!-- .notable -->
    
    	<div id="sidebar">
    		<ul>
    		<?php if ( function_exists('dynamic_sidebar') && dynamic_sidebar('sidebar') ) ; ?> 
    		</ul>
    	</div><!-- #sidebar -->
    	
    </div><!-- #content -->
    <!-- end post-->     
    
    
    
    
    <?php     
    
    	// calling footer.php
        get_footer();
    
    ?>
    WPFolio header:

    Code:
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html <?php language_attributes(); ?> xmlns="http://www.w3.org/1999/xhtml">   
    <head profile="http://gmpg.org/xfn/11">  
    
    <meta http-equiv="Content-Type" content="<?php bloginfo('html_type'); ?>; charset=<?php bloginfo('charset'); ?>" />
    
    <!-- calling monthly archives -->
    <?php wp_get_archives('type=monthly&format=link'); ?>  
     <?php global $settings; ?>
        	
    <!-- done calling monthly archives -->
      
    	<title>
    	<?php if ( is_page() ) { ?><?php bloginfo('name'); ?><?php wp_title('|'); ?><?php } ?>
    	<?php if ( is_home() ) { ?><?php bloginfo('name'); ?>&nbsp;|&nbsp;<?php bloginfo('description'); ?><?php } ?>
    	<?php if ( is_single() ) { ?><?php wp_title(''); ?>&nbsp;|&nbsp;<?php bloginfo('name'); ?><?php } ?>
    	<?php if ( is_category() ) { ?><?php bloginfo('name'); ?>&nbsp;|&nbsp;<?php single_cat_title(); ?><?php } ?>
    	<?php if ( is_year() ) { ?><?php bloginfo('name'); ?>&nbsp;|&nbsp;<?php the_time('Y'); ?><?php } ?>
    	<?php if ( is_tax() ) { ?><?php bloginfo('name'); ?>&nbsp;|&nbsp;Media: <?php $term = get_term_by( 'slug', get_query_var( 'term' ), get_query_var( 'taxonomy' ) ); echo $term->name; ?><?php } ?>
    	<?php if (function_exists('is_tag')) { if ( is_tag() ) { ?><?php bloginfo('name'); ?>&nbsp;|&nbsp;<?php  single_tag_title("Tag Archive:", true); } } ?>
    	</title>  
    
    
    <!-- Superfish Support -->
    <link rel="stylesheet" href="<?php echo get_template_directory_uri(); ?>/css/superfish.css" type="text/css" media="screen"/>
    <!--
    Add if you want to enable the SuperFish Navbar. It will need styling! 
    <link rel="stylesheet" href="<?php echo get_template_directory_uri(); ?>/css/superfish-navbar.css" type="text/css" media="screen"/> -->
    <!-- end superfish -->
    
    <!--[if IE]>
    <link rel="stylesheet" href="<?php echo get_template_directory_uri(); ?>/css/ie-sucks.css" type="text/css" media="screen" />
    <![endif]-->
    <?php if (is_page(array('RESUME','Resume','resume','CV','cv'))) { ?>
    <link rel="stylesheet" href="<?php echo get_template_directory_uri(); ?>/css/resume.css" type="text/css" media="screen" />
    <?php } else if (is_page("")) { } ?>
    
    <link href="<?php bloginfo('stylesheet_url'); ?>" rel="stylesheet" type="text/css" />
    <link href="<?php echo home_url();?>/?wp_folio_css=css" rel="stylesheet" type="text/css" />
    
    
    <!-- calling wp_head -->
    <?php wp_head(); ?> <!-- done calling wp_head -->
    </head>   
    
    <body <?php body_class(); ?>>  
    <div class="container">  
    	<div id="header">  
    		<div class="headertext">   
    		<h1><a href="<?php echo home_url( '/' ); ?>"><?php bloginfo('name'); ?></a></h1> 		 
    		<h4><?php bloginfo('description'); ?></h4>  
    		</div><!-- .headertext -->
    	</div><!-- #header -->
    
    <!-- MENU  --> 
    	<div class="nav">
    		<?php /* Our navigation menu.  If one isn't filled out, wp_nav_menu falls back to wp_page_menu.  The menu assiged to the primary position is the one used.  If none is assigned, the menu with the lowest ID is used.  */ ?>
    		<?php if ( has_nav_menu( 'navbar' ) ) { ?>
    		<?php wp_nav_menu( array( 'container_class' => 'menu-header', 'menu_class' => 'sf-menu sf-navbar', 'theme_location' => 'navbar' ) ); 
    		} else { ?>
    		<ul class="sf-menu">
    		<?php wp_list_pages('exclude=&title_li=' );?>
    		</ul> <?php
    		} ?>
    		
    	</div><!-- .nav -->
    <!-- END MENU -->
    Last edited by Apostropartheid; 07-22-2011 at 07:05 PM.

  • #7
    Regular Coder
    Join Date
    Jul 2011
    Location
    India
    Posts
    496
    Thanks
    3
    Thanked 57 Times in 56 Posts
    Issue is in the following code. please check the highlighted one:

    Code:
    <script language="JavaScript">
     FB.Event.subscribe('edge.create', function(response) {  
       _gaq.push(['_trackEvent','SocialSharing','Facebook - like button',unescape(String(response).replace(/\+/g, " "))]);
     });                 </script>" />

  • Users who have thanked vikram1vicky for this post:

    rasamalai (07-22-2011)

  • #8
    New Coder
    Join Date
    Jul 2011
    Location
    Mexico
    Posts
    16
    Thanks
    10
    Thanked 0 Times in 0 Posts
    Thank you Vikram!
    I know this may seem obvious to you, but, how do I get to that code and should I just delete the highlighted part?

    Thank you!

    P.S. Oh! And will that also fix the other pages where text was showing at the top?
    I sure hope so and thanks once more!
    Last edited by rasamalai; 07-22-2011 at 02:45 PM. Reason: added PS

  • #9
    Regular Coder
    Join Date
    Jul 2011
    Location
    India
    Posts
    496
    Thanks
    3
    Thanked 57 Times in 56 Posts
    Quote Originally Posted by rasamalai View Post
    Thank you Vikram!
    I know this may seem obvious to you, but, how do I get to that code and should I just delete the highlighted part?

    Thank you!

    P.S. Oh! And will that also fix the other pages where text was showing at the top?
    I sure hope so and thanks once more!

    Yaa.. you just need to removed highlighted code from all pages where it is coming

  • #10
    The Apostate Apostropartheid's Avatar
    Join Date
    Oct 2007
    Posts
    3,215
    Thanks
    16
    Thanked 265 Times in 263 Posts
    Quote Originally Posted by vikram1vicky View Post
    Yaa.. you just need to removed highlighted code from all pages where it is coming
    We had already established the error, but as this is WP removing it is more tricky than you might think.

    @OP: It looks like a Facebook plugin is having trouble hooking into your page. Can you search for the list of plugins you have active and post them for me, please?

  • Users who have thanked Apostropartheid for this post:

    rasamalai (07-22-2011)

  • #11
    New Coder
    Join Date
    Jul 2011
    Location
    Mexico
    Posts
    16
    Thanks
    10
    Thanked 0 Times in 0 Posts
    Hi Apostropartheid! I'm glad I read your reply before I tried to remove that code from every single page, and possibly further messed up the website.

    the list of facebook related plugins I have installed and active:


    Come to think of it, I have a plugin for Meta tags, something about it was mentioned in the first posts:
    Seo Meta Tags, By Wordpressapi.com This plugin will add post excerpt as a meta tags of each individual post.

    PS: I checked out the links at your profile, thanks for posting them.
    They seem very useful, hope to understand them in the future!

    Update
    I've just noticed that my header is where a third column on the right would be at, if I had one, I can't recall but I believe I didn't make 3 for that page:
    http://artisanofwhimsy.com/pages/son...dad-de-hierro/
    So it took over the entire website

    Ooh! After scrolling down the entire page I see that it repeats the entire content of the post in the header, or something similar! I don't know why I had thought it had only affected new posts and not the old ones.

    PS I kind of like how the header looks in that spot he he, I hope to learn eventually how to tweak things around.
    Reading, be it plain text, music scores or code just seems something very important -to me- in order to feel human! <3 ^u^
    Last edited by rasamalai; 07-23-2011 at 06:44 AM. Reason: added update and then PS

  • #12
    The Apostate Apostropartheid's Avatar
    Join Date
    Oct 2007
    Posts
    3,215
    Thanks
    16
    Thanked 265 Times in 263 Posts
    Quote Originally Posted by rasamalai View Post
    Hi Apostropartheid! I'm glad I read your reply before I tried to remove that code from every single page, and possibly further messed up the website.

    the list of facebook related plugins I have installed and active:


    Come to think of it, I have a plugin for Meta tags, something about it was mentioned in the first posts:
    Seo Meta Tags, By Wordpressapi.com This plugin will add post excerpt as a meta tags of each individual post.
    Try deactivating the Facebook one, and see if it goes away. If not, deactivate the Seo Meta Tags too. That should, hopefully, remove the issue. When we've sorted out its exact cause we can try to fix the plugins.

    PS: I checked out the links at your profile, thanks for posting them.
    They seem very useful, hope to understand them in the future!
    Happy to help.

  • Users who have thanked Apostropartheid for this post:

    rasamalai (07-24-2011)

  • #13
    New Coder
    Join Date
    Jul 2011
    Location
    Mexico
    Posts
    16
    Thanks
    10
    Thanked 0 Times in 0 Posts
    That did it! I had 2 for SEO actually I tried them one by one, it was the Trackable Social Share Icons plugin messing everything up!
    I tried deleting and re-installing in case the file had become corrupted but it didn't fix it so it's still de-activated, I had not had problems with it before, perhaps it's having a conflict with something I installed after it. Thank you so much!

    PS. Should I mark the thread as resolved now? And if so how do I do that?
    Last edited by rasamalai; 07-24-2011 at 01:01 AM. Reason: Added PS

  • #14
    The Apostate Apostropartheid's Avatar
    Join Date
    Oct 2007
    Posts
    3,215
    Thanks
    16
    Thanked 265 Times in 263 Posts
    Quote Originally Posted by rasamalai View Post
    PS. Should I mark the thread as resolved now? And if so how do I do that?
    I did it for you.

  • Users who have thanked Apostropartheid for this post:

    rasamalai (07-24-2011)

  • #15
    New Coder
    Join Date
    Jul 2011
    Location
    Mexico
    Posts
    16
    Thanks
    10
    Thanked 0 Times in 0 Posts
    Thank you!
    That was really nice of you


  •  
    Page 1 of 2 12 LastLast

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •