Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 4 of 4
  1. #1
    New to the CF scene
    Join Date
    Jan 2011
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Exclamation I Need Help Making a Button Link.

    I'm trying to make a button that will link to another page as part of my first web design course. I already have the destination page complete and I'm able to go to the page, but the button won't show up for whatever reason. All I get is the box with the alt text in it, with one of those red "x" cannot display boxes in the side.


    <a href="characters/characters.htm"><img src="charactersbutton.gif" alt="To Characters Page" /></a>

    Is there anything wrong with this? Because I'm using an example page as a reference and it looks like this:

    <a href="bio/bio.htm"><img src="About.gif" alt="About Renee Button" border="none" /></a>

    Which to me looks the exact same except for the names of the files, and it works, but mine doesn't. I'm looking at it right now and the image file is in C:\Users\Myname\Documents\Myname\cs102(class name)\myname\assign2, where everything else on the page is. Can anyone help me? It's probably elementary to you but the assignment is due tomorrow morning and I can't seem to figure out why this won't work. Any help would be greatly appreciated!

  • #2
    Master Coder Excavator's Avatar
    Join Date
    Dec 2006
    Location
    Alaska
    Posts
    9,747
    Thanks
    22
    Thanked 1,838 Times in 1,822 Posts
    Hello Flapjacks,
    All I can suggest is doublecheck both your path and your spelling. Then check again. Then verify the image is actually there.

    Here's a site that explains about absolute and relative paths, maybe that will help.
    Validate often DURING development - Use it like a splelchecker | Debug during Development |Write it for FireFox, ignore IE
    Use the right DocType | Validate your markup | Validate your CSS | Why validating is good | Why tables are bad

  • #3
    Regular Coder Pepe, the bull's Avatar
    Join Date
    Feb 2005
    Location
    Vancouver, WA
    Posts
    163
    Thanks
    1
    Thanked 16 Times in 16 Posts
    You may also want to double check that your image is a "gif" and not "jpg" or some other extension. I've made that mistake before. It's frusterating.
    Pepe, the bull

  • #4
    New Coder
    Join Date
    Dec 2010
    Posts
    49
    Thanks
    0
    Thanked 1 Time in 1 Post
    do you know in which file you have the image? because i see that you did exactly as the sample or the reference.

    the name of the button is: charactersbutton.gif

    and the destination where you want to send it is: characters/characters.htm

    this is saying that you want to send it to a file name: "characters" and the name of the web page is characters.htm

    try removing the characters and leave it with "characters.htm" to see if it helps.

    i hope this helps.
    Learn how to create a Website with HTML www.htmltutorialtopics.com Free tutorials


  •  

    Tags for this Thread

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •