Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 4 of 4
  1. #1
    New to the CF scene
    Join Date
    Dec 2010
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Exclamation Ok Mystery Issue with CSS Menu and BG Image.

    Ok so me and my partner just launched our new layout on our website. But we have an issue. On the index our menu works just fine (www.lcudclan.com), but when you venture off to other pages like (lcudclan.com/members.php) then the menu does not work. The menu only works with the index, and me, my partner, nor HostGator Tech Supports agents can find the issue. Ok so here is the issue.

    (Use the HTML code to go along with all the things during my description of the issue.) The background image on the top of our webpage (lcudclan.com) covers the top, plus is the blue/red background for the menu. And all of that is in the core.css (as defined in the HTML). But the menu properties itself (background color, width, height, rollover, etc.) are all in the /menu folder (again as defined in the HTML). Now on index.php the menu works fine no issues. But on any of the other pages in the root folder (the root folder is the only folder that has this design) the menu does not work, it does not display the bottom of the background image that it should display.

    Below is my partners description of the issue, as he is the developer of the layout.

  • #2
    New to the CF scene
    Join Date
    Dec 2010
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    OK to all of you immature minds, by "partner" he meant web design partner, of course.

    When you look at the navigation bar/menu on the index page, you see the blue/red bar that goes across the screen. When you hover over it, that section is replaced by the same dark gray that is in the background. By default, the menu is set to 0% opacity, but when you hover, it goes to 100% #252525...

    When you venture off onto the other pages with the same design, it is by default the same dark gray as the background, and the same when you hover over it. So, any idea what the issue seems to be?

  • #3
    Master Coder Excavator's Avatar
    Join Date
    Dec 2006
    Location
    Alaska
    Posts
    9,695
    Thanks
    22
    Thanked 1,832 Times in 1,816 Posts
    Hello wesslayneb and RapideGT,
    On the home page, .eBanner is margined down so it doesn't cover the parent ul of your menu.
    On other pages there is no .eBanner and .contentPage covers the parent ul, I think because of collapsing margins.

    On pages that have .contentPage, add this bit in red -
    Code:
    .contentPage {
    		width:980px;
    		background:#252525;
    		padding:10px 10px 10px 10px;
    margin: 50px 0 0 0;
    }
    This would work equally well -
    Code:
    .contentPage {
    		width:980px;
    		background:#252525;
    		padding:10px 10px 10px 10px;
    clear: both;
    }
    Validate often DURING development - Use it like a splelchecker | Debug during Development |Write it for FireFox, ignore IE
    Use the right DocType | Validate your markup | Validate your CSS | Why validating is good | Why tables are bad

  • #4
    New to the CF scene
    Join Date
    Dec 2010
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thank you very much, this fixed our issue!


  •  

    Tags for this Thread

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •