Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 4 of 4
  1. #1
    Regular Coder djh101's Avatar
    Join Date
    May 2009
    Location
    California
    Posts
    626
    Thanks
    51
    Thanked 67 Times in 67 Posts

    UTF-8 in Internet Explore 8 causing page to span entire browser

    ANSI Page
    UTF-8 Page

    Both of the above pages are almost identical, but one is in ANSI encoding while the other is in UTF-8 encoding. I am using a widescreen computer with more than 1024 pixels in width, so the page (which is set in CSS to be 1024 pixels) shouldn't take up the entire web browser, however, in the UTF-8 page it does and the stretching makes everything look sloppy.

  • #2
    New Coder
    Join Date
    Sep 2008
    Posts
    67
    Thanks
    8
    Thanked 2 Times in 2 Posts
    Maybe IE is ignoring the fact that you've set the width on the body element.

    I didn't look at all the css, but if you take that out and set the appropriate width on the div that's supposed to be 1024px, you should be ok.

  • #3
    Regular Coder djh101's Avatar
    Join Date
    May 2009
    Location
    California
    Posts
    626
    Thanks
    51
    Thanked 67 Times in 67 Posts
    I have body width set to 1024, everything else is in percents. I'm just curious as to why it only ignores the width setting if the page is in UTF-8 and only in Internet Explorer.

  • #4
    New to the CF scene
    Join Date
    Dec 2009
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts
    short and quick solution is if possible use 'IE7 emulator' meta tag, to fix this problem for IE8. Emulator will render ur page same as it renders in IE7. but make sure that page is fine in IE7 before using this meta tag.


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •