Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 14 of 14
  1. #1
    Regular Coder
    Join Date
    Aug 2009
    Posts
    411
    Thanks
    119
    Thanked 0 Times in 0 Posts

    disecting validator cleanup

    any idea how i fix the first four errors, which all seem to be the same type of error: document type does not allow element "li" here; missing one of "ul", "ol", "menu", "dir" start-tag???? all my li's are within ul's so i'm not sure what the problem is.

    http://validator.w3.org/check?uri=ht...ne=1&verbose=1

    please advise. thanks!

  • #2
    Master Coder Excavator's Avatar
    Join Date
    Dec 2006
    Location
    Alaska
    Posts
    9,746
    Thanks
    22
    Thanked 1,838 Times in 1,822 Posts
    Hello sixrfan,
    Looks like one missing closing tag is causing those four errors? Don't know how that works.
    Try this-
    Code:
    <ul>
    	 <li><a href="index.html">Home</a></li> 
         <li><a href="">DESIGNS ▼</a> 
             <ul> 
                <li><a href="/products.php?cat=29">Joe Shark</a></li>
                <li><a href="/products.php?cat=23">For Those About to Rack, We Salute You</a></li>
                <li><a href="/products.php?cat=21">Homo-e-rack-tus</a></li>
                <li><a href="/products.php?cat=10">Straight Pool Union</a></li>
                <li><a href="/products.php?cat=13">NYC Pool Hustler</a></li>
                <li><a href="/products.php?cat=15">Who Says Chicks Can't Shoot Pool</a></li>
                <li><a href="/products.php?cat=14">Scotch Doubles</a></li>
                <li><a href="/products.php?cat=12">Major League Hustling</a></li>
                <li><a href="/products.php?cat=16">Shoot Pool Not People</a></li>
                <li><a href="/products.php?cat=18">Miscue-angelo</a></li>
                <li><a href="/products.php?cat=17">Got Chalk?</a></li>
                <li><a href="/products.php?cat=19">Road Hustling</a></li>
                <li><a href="/products.php?cat=22">Kiddie Pool Shark</a></li>
                <li><a href="/products.php?cat=9">Mens - Drunk Pool</a></li>
                <li><a href="/products.php?cat=30">Womens - Drunk Pool</a></li>			
                <li><a href="/products.php?cat=11">Jesus Safes</a></li>
             </ul> 
         </li> 
         <li><a href="/products.php?cat=26">Mens Gear ▼</a>
             <ul> 
                <li><a href="/products.php?cat=36">Mens T Shirts</a></li>	
                <li><a href="/products.php?cat=34">Long Sleeves and Sweatshirts</a></li>	
                <li><a href="/products.php?cat=37">Collar Golf Shirts</a></li>	
                <li><a href="/products.php?cat=35">Hats</a></li>	
                <li><a href="/products.php?cat=26">All Mens</a></li>	
             </ul> 	 
         </li>
         <li><a href="/products.php?cat=27">Womens Gear ▼</a>
             <ul> 
                <li><a href="/products.php?cat=33">Womens T Shirts</a></li>	
                <li><a href="/products.php?cat=31">Tank Tops</a></li>	 
                <li><a href="/products.php?cat=32">Long Sleeves</a></li>	
                <li><a href="/products.php?cat=27">All Womens</a></li>	
           </ul> 
    	 </li> 
         <li><a href="/products.php?cat=24">All Youth/Babies</a></li>
         <li><a href="/products.php?cat=25">All Accessories</a></li>
         <li class="last"><a href="/products.php?cat=28">All Clearance</a></li> 
       </ul>
    Validate often DURING development - Use it like a splelchecker | Debug during Development |Write it for FireFox, ignore IE
    Use the right DocType | Validate your markup | Validate your CSS | Why validating is good | Why tables are bad

  • #3
    Regular Coder
    Join Date
    Aug 2009
    Posts
    411
    Thanks
    119
    Thanked 0 Times in 0 Posts
    thanks excavatar. how in the world did you pinpoint that that was missing?

    regardless, maybe you can help with my next validator error as well. its now the top one on the list: Line 99, Column 121: end tag for element "a" which is not open i dont get it because i have properly opened and closed the a href...i think.

    http://validator.w3.org/check?uri=ht...bose=1#line-99

    please advise. thanks!

  • #4
    Master Coder Excavator's Avatar
    Join Date
    Dec 2006
    Location
    Alaska
    Posts
    9,746
    Thanks
    22
    Thanked 1,838 Times in 1,822 Posts
    <li><a href="http://www.myspace.com/pooltees_dot_com" target="_blank" /><img src="pics/nav_thumbs/3.gif" alt="" /></a></li>


    By using that /> , you are closing the a. When you follow it with </a> you close an anchor that is not open...because you've closed it with />
    Validate often DURING development - Use it like a splelchecker | Debug during Development |Write it for FireFox, ignore IE
    Use the right DocType | Validate your markup | Validate your CSS | Why validating is good | Why tables are bad

  • Users who have thanked Excavator for this post:

    sixrfan (12-21-2009)

  • #5
    Regular Coder
    Join Date
    Aug 2009
    Posts
    411
    Thanks
    119
    Thanked 0 Times in 0 Posts
    thanks but then why isn't the validator also complaining about lines 100 to 107 which are all coded in the same fashion?

  • #6
    The Apostate Apostropartheid's Avatar
    Join Date
    Oct 2007
    Posts
    3,215
    Thanks
    16
    Thanked 265 Times in 263 Posts
    You need to encode your ampersands (these introduce entities in XML.) Use &amp; in it's place.

  • Users who have thanked Apostropartheid for this post:

    sixrfan (12-21-2009)

  • #7
    Master Coder Excavator's Avatar
    Join Date
    Dec 2006
    Location
    Alaska
    Posts
    9,746
    Thanks
    22
    Thanked 1,838 Times in 1,822 Posts
    Quote Originally Posted by sixrfan View Post
    thanks but then why isn't the validator also complaining about lines 100 to 107 which are all coded in the same fashion?
    Who knows? It's like that last one where it was really only the one mistake and it generated 4 or 5 errors. This time, 4 or 5 mistakes are only generating one error.
    Fix the one it points out, run the updated code through it and see what you come up with...
    Validate often DURING development - Use it like a splelchecker | Debug during Development |Write it for FireFox, ignore IE
    Use the right DocType | Validate your markup | Validate your CSS | Why validating is good | Why tables are bad

  • #8
    Regular Coder
    Join Date
    Aug 2009
    Posts
    411
    Thanks
    119
    Thanked 0 Times in 0 Posts
    cool. making progress now.

    http://validator.w3.org/check?uri=ht...1.654#line-188

    so a little over half my remaining errors are from these few lines alone:

    Code:
    <script src="https://sealserver.trustkeeper.net/compliance/seal_js.php?code=w6oj3BWieJraVGclPlFEuih5pDGgvC&style=normal&size=105x54&language=en" type=""></script>
    <noscript>
    <a href="https://sealserver.trustkeeper.net/compliance/cert.php?code=w6oj3BWieJraVGclPlFEuih5pDGgvC&style=normal&size=105x54&language=en" target="hATW"><img src="https://sealserver.trustkeeper.net/compliance/seal.php?code=w6oj3BWieJraVGclPlFEuih5pDGgvC&style=normal&size=105x54&language=en" border="0" alt="Trusted Commerce"/></a>
    </noscript>
    this code puts that Trustwave link in my left nav bar. i copied it verbatim from my shopping cart instructions. what in the world do i do to fix these errors??? thanks!

  • #9
    Master Coder Excavator's Avatar
    Join Date
    Dec 2006
    Location
    Alaska
    Posts
    9,746
    Thanks
    22
    Thanked 1,838 Times in 1,822 Posts
    Quote Originally Posted by sixrfan View Post
    this code puts that Trustwave link in my left nav bar. i copied it verbatim from my shopping cart instructions. what in the world do i do to fix these errors??? thanks!
    Like Apostropartheid says, you'll need to replace your ampersands with &amp;
    Validate often DURING development - Use it like a splelchecker | Debug during Development |Write it for FireFox, ignore IE
    Use the right DocType | Validate your markup | Validate your CSS | Why validating is good | Why tables are bad

  • #10
    Regular Coder
    Join Date
    Aug 2009
    Posts
    411
    Thanks
    119
    Thanked 0 Times in 0 Posts
    thanks! i did it! no errors! no errors!

  • #11
    Master Coder Excavator's Avatar
    Join Date
    Dec 2006
    Location
    Alaska
    Posts
    9,746
    Thanks
    22
    Thanked 1,838 Times in 1,822 Posts
    Last edited by Excavator; 12-21-2009 at 08:42 PM.
    Validate often DURING development - Use it like a splelchecker | Debug during Development |Write it for FireFox, ignore IE
    Use the right DocType | Validate your markup | Validate your CSS | Why validating is good | Why tables are bad

  • #12
    Regular Coder
    Join Date
    Aug 2009
    Posts
    411
    Thanks
    119
    Thanked 0 Times in 0 Posts
    crap!i didnt know there was a CSS validator.

    apparently it doesnt like the asterisk in this code:
    Code:
    * {
    	outline: 0;
    	padding: 0;
    	margin: 0;
    }
    but i thought i need this code to fix alignment issues in IE???

  • #13
    Master Coder Excavator's Avatar
    Join Date
    Dec 2006
    Location
    Alaska
    Posts
    9,746
    Thanks
    22
    Thanked 1,838 Times in 1,822 Posts
    Uh, it says you have an error in line 191. There is no such thing as alink.
    Validate often DURING development - Use it like a splelchecker | Debug during Development |Write it for FireFox, ignore IE
    Use the right DocType | Validate your markup | Validate your CSS | Why validating is good | Why tables are bad

  • Users who have thanked Excavator for this post:

    sixrfan (12-22-2009)

  • #14
    Regular Coder
    Join Date
    Aug 2009
    Posts
    411
    Thanks
    119
    Thanked 0 Times in 0 Posts
    oh, i see. i totally misread that. thanks!


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •