Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 2 of 2
  1. #1
    New Coder
    Join Date
    Dec 2009
    Posts
    16
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Arrow shtml SSI problem

    Hi everyone, I decided to use shtml for my site, but I can't seem to get it to work correctly. For my navbar I included this code in where it should be
    Code:
    <div id="leftnav">
    <!--#include virtual="includes/navigation.html" -->
    
    
    </div>
    and in my other file I created a normal HTML document plain with just the navigation links using microsoft expression web (code for that is below).
    Code:
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml">
    
    <head>
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
    <title>Untitled 1</title>
    <script type="text/javascript">
    <!--
    function FP_preloadImgs() {//v1.0
     var d=document,a=arguments; if(!d.FP_imgs) d.FP_imgs=new Array();
     for(var i=0; i<a.length; i++) { d.FP_imgs[i]=new Image; d.FP_imgs[i].src=a[i]; }
    }
    
    function FP_swapImg() {//v1.0
     var doc=document,args=arguments,elm,n; doc.$imgSwaps=new Array(); for(n=2; n<args.length;
     n+=2) { elm=FP_getObjectByID(args[n]); if(elm) { doc.$imgSwaps[doc.$imgSwaps.length]=elm;
     elm.$src=elm.src; elm.src=args[n+1]; } }
    }
    
    function FP_getObjectByID(id,o) {//v1.0
     var c,el,els,f,m,n; if(!o)o=document; if(o.getElementById) el=o.getElementById(id);
     else if(o.layers) c=o.layers; else if(o.all) el=o.all[id]; if(el) return el;
     if(o.id==id || o.name==id) return o; if(o.childNodes) c=o.childNodes; if(c)
     for(n=0; n<c.length; n++) { el=FP_getObjectByID(id,c[n]); if(el) return el; }
     f=o.forms; if(f) for(n=0; n<f.length; n++) { els=f[n].elements;
     for(m=0; m<els.length; m++){ el=FP_getObjectByID(id,els[n]); if(el) return el; } }
     return null;
    }
    // -->
    </script>
    </head>
    
    <body onload="FP_preloadImgs(/*url*/'../navigation_images/button7.jpg',/*url*/'../navigation_images/button8.jpg',/*url*/'../navigation_images/buttonD.jpg',/*url*/'../navigation_images/buttonE.jpg',/*url*/'../navigation_images/button10.jpg',/*url*/'../navigation_images/button11.jpg')">
    
    <p><a href="">
    <img style="border: 0" id="img1" src="../navigation_images/button6.jpg" height="20" width="100" alt="Home" onmouseover="FP_swapImg(1,0,/*id*/'img1',/*url*/'../navigation_images/button7.jpg')" onmouseout="FP_swapImg(0,0,/*id*/'img1',/*url*/'../navigation_images/button6.jpg')" onmousedown="FP_swapImg(1,0,/*id*/'img1',/*url*/'../navigation_images/button8.jpg')" onmouseup="FP_swapImg(0,0,/*id*/'img1',/*url*/'../navigation_images/button7.jpg')" /><!-- MSComment="ibutton" fp-style="fp-btn: Embossed Capsule 5; fp-bgcolor: #EA3130" fp-title="Home" --></a><br />
    <br />
    <a href="">
    <img style="border: 0" id="img2" src="../navigation_images/buttonC.jpg" height="20" width="100" alt="Home" onmouseover="FP_swapImg(1,0,/*id*/'img2',/*url*/'../navigation_images/buttonD.jpg')" onmouseout="FP_swapImg(0,0,/*id*/'img2',/*url*/'../navigation_images/buttonC.jpg')" onmousedown="FP_swapImg(1,0,/*id*/'img2',/*url*/'../navigation_images/buttonE.jpg')" onmouseup="FP_swapImg(0,0,/*id*/'img2',/*url*/'../navigation_images/buttonD.jpg')" /><!-- MSComment="ibutton" fp-style="fp-btn: Embossed Capsule 5; fp-bgcolor: #EA3130" fp-title="Home" --></a><br />
    <br />
    <a href="">
    <img style="border: 0" id="img3" src="../navigation_images/buttonF.jpg" height="20" width="100" alt="Home" onmouseover="FP_swapImg(1,0,/*id*/'img3',/*url*/'../navigation_images/button10.jpg')" onmouseout="FP_swapImg(0,0,/*id*/'img3',/*url*/'../navigation_images/buttonF.jpg')" onmousedown="FP_swapImg(1,0,/*id*/'img3',/*url*/'../navigation_images/button11.jpg')" onmouseup="FP_swapImg(0,0,/*id*/'img3',/*url*/'../navigation_images/button10.jpg')" /><!-- MSComment="ibutton" fp-style="fp-btn: Embossed Capsule 5; fp-bgcolor: #EA3130" fp-title="Home" --></a></p>
    
    </body>
    
    </html>
    When the page is displayed, it doesn't display the links right. Is there something I'm missing why it's not working for me??

  • #2
    New Coder
    Join Date
    Dec 2009
    Posts
    11
    Thanks
    0
    Thanked 1 Time in 1 Post

    shtml ssi

    I don't know anything about the script that you are running, but usually the included file should not have the doctype and head etc. I know nothing about the microsoft expression web.
    Last edited by weaver; 12-13-2009 at 07:06 PM.


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •