Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 6 of 6
  1. #1
    Regular Coder
    Join Date
    Aug 2009
    Posts
    407
    Thanks
    119
    Thanked 0 Times in 0 Posts

    CSS Border not showing

    for reason the yellow border on my wrapper div is not extending all the way around my wrapper div. if you look very closely you can see it outside the very top left corner and top right corner of my banner. it's no more than a pixel or two in height, but it should run all the way down to and around the footer to emcompass everything: http://www.21centuryinc.com/new_index.htm.

    any idea what's wrong here? thanks in advance!

    Code:
    #wrapper {
    	margin-right: auto;
    	margin-left: auto;
    	padding: 0px 1px 1px;
    	margin-top: 0px;
    	margin-bottom: 0px;
    	width: 904px;
    	background-color: #00FF00;
    	border-right-width: 1px;
    	border-bottom-width: 1px;
    	border-left-width: 1px;
    	border-right-style: solid;
    	border-bottom-style: solid;
    	border-left-style: solid;
    	border-right-color: #FFFF00;
    	border-bottom-color: #FFFF00;
    	border-left-color: #FFFF00;
    	height: auto;
    }

  • #2
    New Coder
    Join Date
    Jul 2007
    Location
    at home
    Posts
    10
    Thanks
    0
    Thanked 0 Times in 0 Posts
    try

    Code:
     border:1px solid #ffff00; border-top-width:0px;
    -Sehana

  • #3
    Senior Coder
    Join Date
    Feb 2009
    Location
    Ilkley, West Yorkshire, UK
    Posts
    2,956
    Thanks
    9
    Thanked 727 Times in 721 Posts
    All the items within #wrapper are floated - which takes them out of the normal flow of the document, and hence #wrapper doesn't extend to include them.

    To fix, apply overflow:auto to #wrapper - which effectively clear the floats at the end of #wrapper and hence the border will extend as you want.

  • #4
    Regular Coder
    Join Date
    Aug 2009
    Posts
    407
    Thanks
    119
    Thanked 0 Times in 0 Posts
    thanks but that did not seem to work. any other ideas?

  • #5
    Senior Coder
    Join Date
    Feb 2009
    Location
    Ilkley, West Yorkshire, UK
    Posts
    2,956
    Thanks
    9
    Thanked 727 Times in 721 Posts
    Worked for me with Firebug - have you posted your amended code?

    EDIT: Or is your post in response to sehana's suggestion?

  • #6
    Regular Coder
    Join Date
    Aug 2009
    Posts
    407
    Thanks
    119
    Thanked 0 Times in 0 Posts
    sb65, i missed your suggesting when attempting sehana's change. it works now. thanks to both of you!!!


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •