Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 8 of 8
  1. #1
    New Coder
    Join Date
    Jun 2007
    Posts
    79
    Thanks
    5
    Thanked 0 Times in 0 Posts

    <solved>Rollover Menu breaks in IE

    Hi guys! Im having an issue with a menu breaking in IE. Its just a simple menu with background color changing on rollover. Also, the search form is out of place. Cant seem to figure it out. Both the menu and the search form render fine in FF of course. The site is www.greasycheese.com. Its the submenu at the top. Thanks for any help.

    Mike
    Last edited by Muckiem14; 06-16-2009 at 04:16 AM. Reason: solved

  • #2
    New to the CF scene
    Join Date
    Jun 2009
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    The codes?

  • #3
    Supreme Master coder! abduraooft's Avatar
    Join Date
    Mar 2007
    Location
    N/A
    Posts
    14,861
    Thanks
    160
    Thanked 2,223 Times in 2,210 Posts
    Blog Entries
    1
    Quote Originally Posted by jungle View Post
    The codes?
    can be obtained by viewing the source of the give link(by OP) after opening that page.
    The Dream is not what you see in sleep; Dream is the thing which doesn't let you sleep. --(Dr. APJ. Abdul Kalam)

  • #4
    New Coder
    Join Date
    Jun 2007
    Posts
    79
    Thanks
    5
    Thanked 0 Times in 0 Posts
    Any ideas?

  • #5
    Regular Coder noneforit's Avatar
    Join Date
    Apr 2009
    Location
    England
    Posts
    268
    Thanks
    10
    Thanked 20 Times in 20 Posts
    There are errors in both your css and html

    http://jigsaw.w3.org/css-validator/v...ning=1&lang=en

    http://validator.w3.org/check?uri=ww...Inline&group=0

    Fix these first and maybe the search bar will display as it should in ie and ff

  • #6
    Regular Coder
    Join Date
    Jan 2009
    Posts
    316
    Thanks
    7
    Thanked 92 Times in 91 Posts
    Add this:
    Code:
    #menu li {
    display:inline;
    }
    I did this after I fixed the errors though.

    You've still got problems even then though (at least in IE6), as your page doesn't hold shape when you resize it.

  • #7
    New Coder
    Join Date
    Jun 2007
    Posts
    79
    Thanks
    5
    Thanked 0 Times in 0 Posts
    Thanks for your time guys. I should have fixed the errors before posting. Dont worrry... ill beat myself with a wet noodle so no one else has to.

  • #8
    New Coder
    Join Date
    Jun 2007
    Posts
    79
    Thanks
    5
    Thanked 0 Times in 0 Posts
    Fixed the errors and added display: inline to to #menu li and it fixed the IE issues. Thanks.


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •