Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 3 of 3
  1. #1
    New to the CF scene
    Join Date
    Mar 2009
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts

    custom browser query help

    I built a custom browser for a web ring. The Member Sites are stored as IDs.

    The "Prev" and "next" buttons query the database for the site ID and then go to the Previous ID or the Next ID depending on what button is clicked.

    Well . . . its not working!

    When I click it goes to the next ID the FIRST time, but the second time, it does nothing, it is not realizing that it already submitted the NEW ID that is now shown, and will not use the NEW ID to calculate a new "next"

    Here is where the browser is:
    http://www.liberty-alliance.net/Pages/Webring.html

    Here is the code:

    [CODE] </div>
    <table border="0" cellpadding="2" cellspacing="0" style="border:5px outset #a0b0c0;margin:0px auto;font:normal 12px Arial,sans-serif;background:#d0d7df none;color:#000000;">
    <thead>
    <tr>
    <th style="text-align:center;font-size:15px;background:#2D46EF none;"><b><font color="white">Liberty Alliance Webring </font></b></th>
    </tr>
    </thead>
    <tbody>
    <tr>
    <td style="text-align:center;background-color:#ED7F7F;"><b><a href="http://www.individualism.asia/_ringmaker.php?Go&amp;Prev&amp;__id__" style="color:#1D33B8;" target="_top">&lt;</a><font color="#2d46ef"><a href="http://www.individualism.asia/_ringmaker.php?Go&amp;Prev&amp;__id__" style="color:#1D33B8;" target="viewer">&lt; Previous</a></font><font color="white"> | <a href="http://www.individualism.asia/_ringmaker.php" style="color:#1D33B8;" target="viewer">Central Hub</a></font><font color="white"> | <a href="http://www.individualism.asia/masterforum/forumdisplay.php?f=2" style="color:#1D33B8;" target="viewer">Rate! / Review!</a> | <a href="http://www.individualism.asia/_ringmaker.php?Join" style="color:#1D33B8;" target="viewer">Join!</a> | <a href="http://www.individualism.asia/_ringmaker.php?Go&amp;Rand&amp;__id__" style="color:#1D33B8;" target="viewer">Random</a> | <a href="http://www.individualism.asia/_ringmaker.php?Go&amp;Next&amp;__id__" style="color:#1D33B8;" target="viewer">Next &gt;&gt;</a></font></b></td>
    </tr>
    </tbody>
    </table>
    <tr height="*">
    <td colspan="3" valign="top">
    <iframe id="viewer" name="viewer" src="http://www.individualism.asia" height="100%" width="100%"></iframe>
    </td>
    </tr>
    <hr />
    <div align="center">
    [CODE]

    Thanks in advance for any advise . . . I know I am misunderstanding something, but i boiled out what little brain I have trying to figure it out!
    I am thinking that it is reading the main page ID instead of the "viewer" frame ID . . .

  • #2
    Supreme Master coder! _Aerospace_Eng_'s Avatar
    Join Date
    Dec 2004
    Location
    In a place far, far away...
    Posts
    19,291
    Thanks
    2
    Thanked 1,043 Times in 1,019 Posts
    Well all you have in your code is this
    Code:
    __id__
    How do you expect to get the id from that? Also this seems like a php problem. Post your code for _ringmaker.php.
    ||||If you are getting paid to do a job, don't ask for help on it!||||

  • #3
    New to the CF scene
    Join Date
    Mar 2009
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I am so sorry it took me so long to reply, I got sent out of town on a hectic trip . . .

    The _ringmaker php just does some cosmetic stuff and then fetches the body.php.

    but I honestly think it is in the browser, because the "random" button fetches the IDs just fine, and if you put a browser on each website, instead of feeding it to the frame, then all the buttons work right . . it has to do with the initial ID it is using to base the "prev" and "next" commands off of. IMHO


    Well all you have in your code is this
    Code:
    __id__
    How do you expect to get the id from that?
    Because "id" is the name of the variable?

    just go to http://www.liberty-alliance.net/Pages/Webring.html and click "random" and you'll see it works fine. It's the prev and next buttons that glitched!

    I would post the body, but all it does is build the ring: eg: you enter your website name, it assigns it an ID and stores them together in the Database.

    It is the browser that fetches the IDs. I just need to tell the browser to use the ID of the website in the frame, not the ID of the website holding the frame, to base its "next" and "prev" off.

    Like the reverse of a "target" command


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •